extra/webkitgtk to 2.4.11-6

This commit is contained in:
Kevin Mihelich 2017-04-29 16:11:00 +00:00
parent 7b8fecaf9f
commit ce4fb7cd11
2 changed files with 45 additions and 4 deletions

View file

@ -12,7 +12,7 @@ highmem=1
pkgbase=webkitgtk
pkgname=(webkitgtk webkitgtk2)
pkgver=2.4.11
pkgrel=4
pkgrel=6
pkgdesc="Legacy Web content engine"
arch=(i686 x86_64)
url="https://webkitgtk.org/"
@ -25,10 +25,12 @@ optdepends=('gst-plugins-base: free media decoding'
'gst-libav: nonfree media decoding')
options=(!emptydirs)
install=webkitgtk.install
source=(http://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
webkitgtk-2.4.9-abs.patch)
source=(https://webkitgtk.org/releases/$pkgbase-${pkgver}.tar.xz
webkitgtk-2.4.9-abs.patch
icu59.patch)
sha256sums=('588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7'
'ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70')
'ec294bbb5588a1802a68e3615c6718486b22f922645c5fef686d3d103014bf70'
'eb791b9c8dcb84996904846dedf8c3ddf1a5fde32330177f3f0071510bd8ca6d')
prepare() {
mkdir build-gtk{,2} path
@ -36,6 +38,7 @@ prepare() {
# AArch64 fixes
cd $pkgbase-$pkgver
patch -Np1 -i ../icu59.patch
if [[ $CARCH == "aarch64" ]]; then
CFLAGS+=" -DENABLE_YARR_JIT=0"
CXXFLAGS+=" -DENABLE_YARR_JIT=0"

View file

@ -0,0 +1,38 @@
--- webkitgtk-2.16.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2017-02-20 17:20:08.000000000 +0100
+++ webkitgtk-2.16.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-22 14:35:00.926530142 +0200
@@ -32,6 +32,7 @@
#include <stdbool.h>
#endif
#include <stddef.h> /* for size_t */
+#include <uchar.h>
#ifdef __cplusplus
extern "C" {
@@ -46,7 +47,7 @@
character. As with all scalar types, endianness depends on the underlying
architecture.
*/
- typedef unsigned short JSChar;
+ typedef char16_t JSChar;
#else
typedef wchar_t JSChar;
#endif
--- webkitgtk-2.16.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2017-02-20 17:20:17.000000000 +0100
+++ webkitgtk-2.16.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-22 14:35:56.853196170 +0200
@@ -28,6 +28,7 @@
#include <WebKit/WKBase.h>
#include <stddef.h>
+#include <uchar.h>
#ifndef __cplusplus
#include <stdbool.h>
@@ -39,7 +40,7 @@
#if !defined(WIN32) && !defined(_WIN32) \
&& !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
- typedef unsigned short WKChar;
+ typedef char16_t WKChar;
#else
typedef wchar_t WKChar;
#endif