mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-aarch64-rc to 4.15.rc8-1
This commit is contained in:
parent
16560f01d0
commit
ce591baadd
5 changed files with 95 additions and 10 deletions
|
@ -1,7 +1,7 @@
|
|||
From d376e5ec07c26c3713a96632294070f07b2c7a9a Mon Sep 17 00:00:00 2001
|
||||
From 7c430158e1aefb9232fc9e1c00fdbfc0c4147e66 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 1/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 64f2ffd426344a749f27a00485ad1eabc7ecbdb1 Mon Sep 17 00:00:00 2001
|
||||
From 79e9d9f4ad2f3ddb1ee12fc6d7ea9e4cf39d674c Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
||||
Subject: [PATCH 2/2] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||
Subject: [PATCH 2/3] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||
|
||||
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
|
||||
---
|
||||
|
|
|
@ -0,0 +1,81 @@
|
|||
From 8887bcecdc3f5588ae52e65fd0a32c72b1542305 Mon Sep 17 00:00:00 2001
|
||||
From: Arnd Bergmann <arnd@arndb.de>
|
||||
Date: Fri, 12 Jan 2018 11:12:05 +0100
|
||||
Subject: [PATCH 3/3] phy: work around 'phys' references to usb-nop-xceiv
|
||||
devices
|
||||
|
||||
Stefan Wahren reports a problem with a warning fix that was merged
|
||||
for v4.15: we had lots of device nodes with a 'phys' property pointing
|
||||
to a device node that is not compliant with the binding documented in
|
||||
Documentation/devicetree/bindings/phy/phy-bindings.txt
|
||||
|
||||
This generally works because USB HCD drivers that support both the generic
|
||||
phy subsystem and the older usb-phy subsystem ignore most errors from
|
||||
phy_get() and related calls and then use the usb-phy driver instead.
|
||||
|
||||
However, it turns out that making the usb-nop-xceiv device compatible with
|
||||
the generic-phy binding changes the phy_get() return code from -EINVAL to
|
||||
-EPROBE_DEFER, and the dwc2 usb controller driver for bcm2835 now returns
|
||||
-EPROBE_DEFER from its probe function rather than ignoring the failure,
|
||||
breaking all USB support on raspberry-pi when CONFIG_GENERIC_PHY is
|
||||
enabled. The same code is used in the dwc3 driver and the usb_add_hcd()
|
||||
function, so a reasonable assumption would be that many other platforms
|
||||
are affected as well.
|
||||
|
||||
I have reviewed all the related patches and concluded that "usb-nop-xceiv"
|
||||
is the only USB phy that is affected by the change, and since it is by far
|
||||
the most commonly referenced phy, all the other USB phy drivers appear
|
||||
to be used in ways that are are either safe in DT (they don't use the
|
||||
'phys' property), or in the driver (they already ignore -EPROBE_DEFER
|
||||
from generic-phy when usb-phy is available).
|
||||
|
||||
To work around the problem, this adds a special case to _of_phy_get()
|
||||
so we ignore any PHY node that is compatible with "usb-nop-xceiv",
|
||||
as we know that this can never load no matter how much we defer. In the
|
||||
future, we might implement a generic-phy driver for "usb-nop-xceiv"
|
||||
and then remove this workaround.
|
||||
|
||||
Since we generally want older kernels to also want to work with the
|
||||
fixed devicetree files, it would be good to backport the patch into
|
||||
stable kernels as well (3.13+ are possibly affected), even though they
|
||||
don't contain any of the patches that may have caused regressions.
|
||||
|
||||
Fixes: 014d6da6cb25 ARM: dts: bcm283x: Fix DTC warnings about missing phy-cells
|
||||
Fixes: c5bbf358b790 arm: dts: nspire: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: 44e5dced2ef6 arm: dts: marvell: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: f568f6f554b8 ARM: dts: omap: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: d745d5f277bf ARM: dts: imx51-zii-rdu1: Add missing #phy-cells to usb-nop-xceiv
|
||||
Fixes: 915fbe59cbf2 ARM: dts: imx: Add missing #phy-cells to usb-nop-xceiv
|
||||
Link: https://marc.info/?l=linux-usb&m=151518314314753&w=2
|
||||
Link: https://patchwork.kernel.org/patch/10158145/
|
||||
Cc: stable@vger.kernel.org
|
||||
Cc: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
Cc: Felipe Balbi <balbi@kernel.org>
|
||||
Cc: Eric Anholt <eric@anholt.net>
|
||||
Tested-by: Hans Verkuil <hans.verkuil@cisco.com>
|
||||
Acked-by: Kishon Vijay Abraham I <kishon@ti.com>
|
||||
Signed-off-by: Arnd Bergmann <arnd@arndb.de>
|
||||
Tested-by: Stefan Wahren <stefan.wahren@i2se.com>
|
||||
Acked-by: Rob Herring <robh@kernel.org>
|
||||
---
|
||||
drivers/phy/phy-core.c | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/drivers/phy/phy-core.c b/drivers/phy/phy-core.c
|
||||
index b4964b067aec..8f6e8e28996d 100644
|
||||
--- a/drivers/phy/phy-core.c
|
||||
+++ b/drivers/phy/phy-core.c
|
||||
@@ -410,6 +410,10 @@ static struct phy *_of_phy_get(struct device_node *np, int index)
|
||||
if (ret)
|
||||
return ERR_PTR(-ENODEV);
|
||||
|
||||
+ /* This phy type handled by the usb-phy subsystem for now */
|
||||
+ if (of_device_is_compatible(args.np, "usb-nop-xceiv"))
|
||||
+ return ERR_PTR(-ENODEV);
|
||||
+
|
||||
mutex_lock(&phy_provider_mutex);
|
||||
phy_provider = of_phy_provider_lookup(args.np);
|
||||
if (IS_ERR(phy_provider) || !try_module_get(phy_provider->owner)) {
|
||||
--
|
||||
2.15.0
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=8
|
||||
|
||||
_rcver=4.15
|
||||
_rcrel=7
|
||||
_rcrel=8
|
||||
|
||||
pkgbase=linux-aarch64-rc
|
||||
_srcname=linux-${_rcver}-rc${_rcrel}
|
||||
|
@ -20,16 +20,18 @@ options=('!strip')
|
|||
source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
|
||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
|
||||
'0003-phy-work-around-phys-references-to-usb-nop-xceiv-dev.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('c94fe83caa8956ca6e751511d56513ba'
|
||||
'e5665f36e3d168e4f788e4004495bca9'
|
||||
'337ea9d073b92e9fa6f75870e2114991'
|
||||
'3d58725e46de092fdce67db31661d998'
|
||||
md5sums=('ad8277e87079747f0e352f1fba151d38'
|
||||
'1ad543c6461367851f9226b7f90d6836'
|
||||
'a6b5bedc8171f255b5d17952db69a587'
|
||||
'924c1db50b0696edf79ed6788e80fda4'
|
||||
'5bd923c06aa6bcf8aad98d707afb0958'
|
||||
'11a4f35c50f0bde59c30182aa7b797b7'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8'
|
||||
|
@ -42,6 +44,7 @@ prepare() {
|
|||
# ALARM patches
|
||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0002-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
|
||||
git apply ../0003-phy-work-around-phys-references-to-usb-nop-xceiv-dev.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm64 4.15.0-rc5-1 Kernel Configuration
|
||||
# Linux/arm64 4.15.0-rc8-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM64=y
|
||||
CONFIG_64BIT=y
|
||||
|
@ -202,6 +202,7 @@ CONFIG_KALLSYMS_ALL=y
|
|||
# CONFIG_KALLSYMS_ABSOLUTE_PERCPU is not set
|
||||
CONFIG_KALLSYMS_BASE_RELATIVE=y
|
||||
CONFIG_BPF_SYSCALL=y
|
||||
# CONFIG_BPF_JIT_ALWAYS_ON is not set
|
||||
# CONFIG_USERFAULTFD is not set
|
||||
# CONFIG_EMBEDDED is not set
|
||||
CONFIG_HAVE_PERF_EVENTS=y
|
||||
|
|
Loading…
Reference in a new issue