added community/kompozer

This commit is contained in:
Kevin Mihelich 2015-12-11 03:52:54 +00:00
parent 83df70d96d
commit ce9081345f
15 changed files with 574 additions and 0 deletions

View file

@ -0,0 +1,14 @@
Patch from Steve Langasek to fix unused vs. used gcc attribute on arm.
bz#307418
--- a/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
+++ b/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
@@ -45,7 +45,8 @@
#endif
/* Specify explicitly a symbol for this function, don't try to guess the c++ mangled symbol. */
-static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch");
+static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch")
+__attribute__((used));
static nsresult
PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args)

View file

@ -0,0 +1,13 @@
Patch from Antti P Miettinen to fix small optimization problem with
newer gcc's on arm. bz#322806
--- a/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
+++ b/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
@@ -212,7 +212,7 @@ XPTC_InvokeByIndex(nsISupports* that, PR
"add sp, sp, r4 \n\t" /* restore stack pointer */
"mov %0, r0 \n\t" /* the result... */
: "=r" (result)
- : "r" (&my_params)
+ : "r" (&my_params), "m" (my_params)
: "r0", "r1", "r2", "r3", "r4", "ip", "lr", "sp"
);

View file

@ -0,0 +1,11 @@
--- xpcom/base/nscore.h 2009-05-02 17:43:48.000000000 +0100
+++ xpcom/base/nscore.h 2012-08-10 23:08:07.168628118 +0100
@@ -182,7 +182,7 @@
#define NS_IMPORT_(type) NS_EXTERNAL_VIS_(type)
#define NS_EXPORT NS_EXTERNAL_VIS
#define NS_EXPORT_(type) NS_EXTERNAL_VIS_(type)
-#define NS_IMETHOD_(type) virtual IMETHOD_VISIBILITY type NS_DEFCALL
+#define NS_IMETHOD_(type) virtual type
#define NS_IMETHODIMP_(type) type
#define NS_METHOD_(type) type
#define NS_CALLBACK_(_type, _name) _type (* _name)

View file

@ -0,0 +1,95 @@
# $Id$
# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: peace4all <markspost at rocketmail dot com>
# Contributor: ingamedeo <ingamedeo at gmail dot com>
# thanks to tadzio, and techlive for the investigation
# work and fix included as the NS_IMETHOD_i686.patch
# Sorry for not honouring makepkg.conf (!buildflags)
# but the source doesn't compile with makepkg's default C/CXXFLAGS
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - ARM patches from debian to fix FTBFS
pkgname=kompozer
pkgver=0.8b3
pkgrel=17
pkgdesc="A Dreamweaver style WYSIWYG web editor; Nvu unofficial bug-fix release"
arch=('x86_64' 'i686')
license=('GPL')
url="http://www.kompozer.net"
depends=('gtk2' 'nss' 'libxt' 'libidl2' 'gnome-vfs' 'desktop-file-utils')
makedepends=('zip' 'pkgconfig' 'pangox-compat' 'nss')
options=('!buildflags')
source=("http://downloads.sourceforge.net/kompozer/${pkgname}-${pkgver}-src.tar.bz2"
'kompozer.desktop'
'mozconfig.patch'
'kompozer-libpng15.patch'
'kompozer-libpng14.patch'
'gcc46_default_ctors.patch'
'kompozer_gcc_4.7.patch'
'any_kernel_26_plus.patch'
'NS_IMETHOD_i686.patch'
'freetype-pango.patch'
'freetype-xft.patch'
'external-nss-for-shlibsign.patch'
'11_arm_xpcom_unused_attribute.patch'
'12_arm_xpcom_optim.patch')
md5sums=('cd4664ecda908666b19ef0607010c627'
'ed8edf6817892a38b8b181fc9b2caaea'
'4778f967307cf569089daca843de1df9'
'4852034f99e7943071946e7eedc6c2f5'
'd5ba90f7fbaed76f77a6d9717e86f3a5'
'ad3ec5cbc6677dd712b140148398f58f'
'75b0e1cad65dbeb8feedac5d4f52be32'
'58a294356b3e17ad070e4c93180bf0ad'
'186c47586bebf83b9b76d339e3a38c95'
'aab21bbbd12818bd38bfce466dd1053f'
'8575801724f9aa05f50f26c5a704df69'
'190d5c11dccb28c4b060a93270cc3d26'
'a1bd22939deea48666abfd2df96cc886'
'131f80138cd0e6ff99697da5725cf5ef')
install="${pkgname}.install"
prepare() {
cd "${srcdir}/mozilla"
patch -Np0 -i "${srcdir}/mozconfig.patch"
patch -Np0 -i "${srcdir}/kompozer-libpng14.patch"
patch -Np0 -i "${srcdir}/kompozer-libpng15.patch"
patch -Np0 -i "${srcdir}/gcc46_default_ctors.patch"
patch -Np0 -i "${srcdir}/kompozer_gcc_4.7.patch"
patch -Np0 -i "${srcdir}/any_kernel_26_plus.patch"
patch -Np0 -i "${srcdir}/NS_IMETHOD_i686.patch"
# Patches for moving from freetype to freetype2 packages
patch -Np2 -i "${srcdir}/freetype-pango.patch"
patch -Np2 -i "${srcdir}/freetype-xft.patch"
# Patch to exclude the integrated nss library to sign
# the binary libraries (currently broken for i686)
patch -Np1 -i "${srcdir}/external-nss-for-shlibsign.patch"
# ARM fixes
patch -Np2 -i "${srcdir}/11_arm_xpcom_unused_attribute.patch"
patch -Np2 -i "${srcdir}/12_arm_xpcom_optim.patch"
}
build() {
cd "${srcdir}/mozilla"
./configure
make
}
package() {
cd "${srcdir}/mozilla"
make DESTDIR="${pkgdir}" install
# Remove nspr.m4 because it's now provided by nspr package
rm "${pkgdir}/usr/share/aclocal/nspr.m4"
rmdir "${pkgdir}/usr/share/aclocal"
install -m755 -dD "${pkgdir}/usr/share/applications/"
install -m644 "${srcdir}/kompozer.desktop" "${pkgdir}/usr/share/applications/"
install -d -m755 "${pkgdir}/usr/share/pixmaps/"
ln -s "/usr/lib/kompozer/icons/mozicon256.png" "${pkgdir}/usr/share/pixmaps/kompozer.png"
ln -s "/usr/lib/kompozer/icons/mozicon50.xpm" "${pkgdir}/usr/share/pixmaps/kompozer.xpm"
}

View file

@ -0,0 +1,31 @@
--- security/coreconf/config.mk 2009-05-02 17:42:18.000000000 +0100
+++ security/coreconf/config.mk 2012-05-22 00:08:39.000000000 +0100
@@ -63,7 +63,7 @@
#######################################################################
TARGET_OSES = FreeBSD BSD_OS NetBSD OpenUNIX OS2 QNX Darwin BeOS OpenBSD \
- OpenVMS AIX
+ OpenVMS AIX Linux
ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
--- security/coreconf/Linux.mk 2009-05-02 17:42:18.000000000 +0100
+++ security/coreconf/Linux.mk 2012-05-22 00:36:03.533374797 +0100
@@ -176,3 +176,17 @@
# Always set CPU_TAG on Linux, OpenVMS, WINCE.
#
CPU_TAG = _$(CPU_ARCH)
+
+#
+#Try to compile with any kernel version 2.6 and above.
+#
+DSO_LDOPTS += -Wl,-z,defs
+
+OS_REL_CFLAGS += -DLINUX2_1
+MKSHLIB = $(CC) $(DSO_LDOPTS) -Wl,-soname -Wl,$(@:$(OBJDIR)/%.so=%.so)
+
+ifdef MAPFILE
+ MKSHLIB += -Wl,--version-script,$(MAPFILE)
+endif
+PROCESS_MAP_FILE = grep -v ';-' $< | \
+ sed -e 's,;+,,' -e 's; DATA ;;' -e 's,;;,,' -e 's,;.*,;,' > $@

View file

@ -0,0 +1,12 @@
diff -Naur mozilla.orig/security/nss/cmd/shlibsign/sign.sh mozilla/security/nss/cmd/shlibsign/sign.sh
--- mozilla.orig/security/nss/cmd/shlibsign/sign.sh 2009-05-02 18:41:54.000000000 +0200
+++ mozilla/security/nss/cmd/shlibsign/sign.sh 2015-06-19 17:46:53.079361603 +0200
@@ -45,7 +45,7 @@
SHLIB_PATH=${1}/lib:${4}:$SHLIB_PATH
export SHLIB_PATH
LD_LIBRARY_PATH=${1}/lib:${4}:$LD_LIBRARY_PATH
- export LD_LIBRARY_PATH
+ #export LD_LIBRARY_PATH
DYLD_LIBRARY_PATH=${1}/lib:${4}:$DYLD_LIBRARY_PATH
export DYLD_LIBRARY_PATH
LIBRARY_PATH=${1}/lib:${4}:$LIBRARY_PATH

View file

@ -0,0 +1,11 @@
--- src/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp.orig 2009-05-02 18:42:41.000000000 +0200
+++ src/mozilla/gfx/src/gtk/nsFontMetricsPango.cpp 2013-12-05 17:42:14.091938000 +0100
@@ -58,7 +58,7 @@
#include <fontconfig/fontconfig.h>
#include <gdk/gdk.h>
#include <gdk/gdkx.h>
-#include <freetype/tttables.h>
+#include <freetype2/freetype/tttables.h>
#include "mozilla-decoder.h"

View file

@ -0,0 +1,13 @@
--- src/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp.orig 2009-05-02 18:42:41.000000000 +0200
+++ src/mozilla/gfx/src/gtk/nsFontMetricsXft.cpp 2013-12-05 17:41:02.125268000 +0100
@@ -67,8 +67,8 @@
#include "nsFontConfigUtils.h"
#include <gdk/gdkx.h>
-#include <freetype/tttables.h>
-#include <freetype/freetype.h>
+#include <freetype2/freetype/tttables.h>
+#include <freetype2/freetype/freetype.h>
#define FORCE_PR_LOG
#include "prlog.h"

View file

@ -0,0 +1,22 @@
--- intl/unicharutil/util/nsUnicharUtils.h 2011-05-10 17:02:12.472642196 +0200
+++ intl/unicharutil/util/nsUnicharUtils.h 2011-05-10 17:02:50.656034735 +0200
@@ -64,6 +64,9 @@
: public nsStringComparator
{
public:
+ nsCaseInsensitiveStringComparator()
+ {
+ }
virtual int operator()( const PRUnichar*, const PRUnichar*, PRUint32 aLength ) const;
virtual int operator()( PRUnichar, PRUnichar ) const;
};
--- toolkit/xre/nsAppRunner.cpp 2011-05-10 17:26:05.853608464 +0200
+++ toolkit/xre/nsAppRunner.cpp 2011-05-10 17:26:15.079221177 +0200
@@ -491,6 +491,7 @@
{
public:
+ nsXULAppInfo() {}
NS_DECL_ISUPPORTS_INHERITED
NS_DECL_NSIXULAPPINFO
NS_DECL_NSIXULRUNTIME

View file

@ -0,0 +1,17 @@
diff -Naur mozilla/modules/libpr0n/encoders/png/nsPNGEncoder.cpp{-,}
--- mozilla/modules/libpr0n/encoders/png/nsPNGEncoder.cpp- 2010-06-10 19:34:09.000000000 -0700
+++ modules/libpr0n/encoders/png/nsPNGEncoder.cpp 2010-06-10 19:35:13.000000000 -0700
@@ -111,9 +111,9 @@
// initialize
png_struct* png_ptr = png_create_write_struct(PNG_LIBPNG_VER_STRING,
- png_voidp_NULL,
- png_error_ptr_NULL,
- png_error_ptr_NULL);
+ NULL,
+ NULL,
+ NULL);
if (! png_ptr)
return NS_ERROR_OUT_OF_MEMORY;
png_info* info_ptr = png_create_info_struct(png_ptr);

View file

@ -0,0 +1,64 @@
diff -urp mozilla.orig/modules/libpr0n/decoders/png/nsPNGDecoder.cpp mozilla/modules/libpr0n/decoders/png/nsPNGDecoder.cpp
--- mozilla.orig/modules/libpr0n/decoders/png/nsPNGDecoder.cpp 2011-11-14 21:55:42.513856274 +0000
+++ modules/libpr0n/decoders/png/nsPNGDecoder.cpp 2011-11-14 22:15:35.899962674 +0000
@@ -171,7 +171,7 @@ static NS_METHOD ReadDataOut(nsIInputStr
}
// we need to do the setjmp here otherwise bad things will happen
- if (setjmp(decoder->mPNG->jmpbuf)) {
+ if (setjmp (png_jmpbuf(decoder->mPNG))) {
png_destroy_read_struct(&decoder->mPNG, &decoder->mInfo, NULL);
decoder->mError = PR_TRUE;
@@ -227,7 +227,7 @@ info_callback(png_structp png_ptr, png_i
if (width > MOZ_PNG_MAX_DIMENSION || height > MOZ_PNG_MAX_DIMENSION) {
nsPNGDecoder *decoder = NS_STATIC_CAST(nsPNGDecoder*,
png_get_progressive_ptr(png_ptr));
- longjmp(decoder->mPNG->jmpbuf, 1);
+ longjmp(png_jmpbuf(decoder->mPNG), 1);
}
#undef MOZ_PNG_MAX_DIMENSION
@@ -307,7 +307,7 @@ info_callback(png_structp png_ptr, png_i
decoder->mImage = do_CreateInstance("@mozilla.org/image/container;1");
if (!decoder->mImage)
- longjmp(decoder->mPNG->jmpbuf, 5); // NS_ERROR_OUT_OF_MEMORY
+ longjmp(png_jmpbuf(decoder->mPNG), 5); // NS_ERROR_OUT_OF_MEMORY
decoder->mImageLoad->SetImage(decoder->mImage);
@@ -319,7 +319,7 @@ info_callback(png_structp png_ptr, png_i
decoder->mFrame = do_CreateInstance("@mozilla.org/gfx/image/frame;2");
if (!decoder->mFrame)
- longjmp(decoder->mPNG->jmpbuf, 5); // NS_ERROR_OUT_OF_MEMORY
+ longjmp(png_jmpbuf(decoder->mPNG), 5); // NS_ERROR_OUT_OF_MEMORY
gfx_format format;
@@ -341,7 +341,7 @@ info_callback(png_structp png_ptr, png_i
// then initalize the frame and append it to the container
nsresult rv = decoder->mFrame->Init(0, 0, width, height, format, 24);
if (NS_FAILED(rv))
- longjmp(decoder->mPNG->jmpbuf, 5); // NS_ERROR_OUT_OF_MEMORY
+ longjmp(png_jmpbuf(decoder->mPNG), 5); // NS_ERROR_OUT_OF_MEMORY
decoder->mImage->AppendFrame(decoder->mFrame);
@@ -362,7 +362,7 @@ info_callback(png_structp png_ptr, png_i
decoder->ibpr = bpr;
decoder->interlacebuf = (PRUint8 *)nsMemory::Alloc(decoder->ibpr*height);
if (!decoder->interlacebuf) {
- longjmp(decoder->mPNG->jmpbuf, 5); // NS_ERROR_OUT_OF_MEMORY
+ longjmp(png_jmpbuf(decoder->mPNG), 5); // NS_ERROR_OUT_OF_MEMORY
}
}
@@ -555,7 +555,7 @@ void
error_callback(png_structp png_ptr, png_const_charp error_msg)
{
PR_LOG(gPNGLog, PR_LOG_ERROR, ("libpng error: %s\n", error_msg));
- longjmp(png_ptr->jmpbuf, 1);
+ longjmp(png_jmpbuf(png_ptr), 1);
}

View file

@ -0,0 +1,11 @@
[Desktop Entry]
Exec=kompozer
Icon=kompozer
Type=Application
Terminal=false
Name=KompoZer
GenericName=Web Authoring System
Comment=WYSIWYG Web Editor
MimeType=text/html;text/xml;text/css;text/x-javascript;text/javascript;application/xhtml+xml;
Categories=Development;WebDevelopment;Network;

View file

@ -0,0 +1,11 @@
post_install() {
update-desktop-database -q
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}

View file

@ -0,0 +1,107 @@
--- xpcom/glue/nsBaseHashtable.h 2009-05-02 17:43:39.000000000 +0100
+++ xpcom/glue/nsBaseHashtable.h 2012-07-27 13:43:55.000000000 +0100
@@ -123,7 +123,7 @@
*/
PRBool Get(KeyType aKey, UserDataType* pData) const
{
- EntryType* ent = GetEntry(aKey);
+ EntryType* ent = this->GetEntry(aKey);
if (!ent)
return PR_FALSE;
@@ -142,7 +142,7 @@
*/
PRBool Put(KeyType aKey, UserDataType aData)
{
- EntryType* ent = PutEntry(aKey);
+ EntryType* ent = this->PutEntry(aKey);
if (!ent)
return PR_FALSE;
@@ -156,7 +156,7 @@
* remove the data for the associated key
* @param aKey the key to remove from the hashtable
*/
- void Remove(KeyType aKey) { RemoveEntry(aKey); }
+ void Remove(KeyType aKey) { this->RemoveEntry(aKey); }
/**
* function type provided by the application for enumeration.
--- xpcom/glue/nsClassHashtable.h 2009-05-02 17:43:39.000000000 +0100
+++ xpcom/glue/nsClassHashtable.h 2012-07-27 13:15:10.000000000 +0100
@@ -98,7 +98,7 @@
nsClassHashtable<KeyClass,T>::Get(KeyType aKey, T** retVal) const
{
typename nsBaseHashtable<KeyClass,nsAutoPtr<T>,T*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
@@ -126,7 +126,7 @@
PR_Lock(this->mLock);
typename nsBaseHashtableMT<KeyClass,nsAutoPtr<T>,T*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
--- xpcom/glue/nsInterfaceHashtable.h 2009-05-02 17:43:39.000000000 +0100
+++ xpcom/glue/nsInterfaceHashtable.h 2012-07-27 13:30:08.000000000 +0100
@@ -111,7 +111,7 @@
(KeyType aKey, UserDataType* pInterface) const
{
typename nsBaseHashtable<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
@@ -139,7 +139,7 @@
(KeyType aKey, PRBool* aFound) const
{
typename nsBaseHashtable<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
@@ -167,7 +167,7 @@
PR_Lock(this->mLock);
typename nsBaseHashtableMT<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
--- xpcom/glue/nsRefPtrHashtable.h 2009-05-02 17:43:39.000000000 +0100
+++ xpcom/glue/nsRefPtrHashtable.h 2012-07-27 13:52:48.000000000 +0100
@@ -112,7 +112,7 @@
(KeyType aKey, UserDataType* pRefPtr) const
{
typename nsBaseHashtable<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
@@ -140,7 +140,7 @@
(KeyType aKey, PRBool* aFound) const
{
typename nsBaseHashtable<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{
@@ -168,7 +168,7 @@
PR_Lock(this->mLock);
typename nsBaseHashtableMT<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
- GetEntry(aKey);
+ this->GetEntry(aKey);
if (ent)
{

View file

@ -0,0 +1,142 @@
--- .mozconfig 2009-04-26 16:19:33.000000000 +0100
+++ .mozconfig 1970-01-01 10:14:21.000000000 +0100
@@ -1,85 +1,80 @@
-# Pulling Composer from the 1.8 Mozilla branch (cvs)
-#$ cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot co -r MOZILLA_1_8_BRANCH mozilla/client.mk
-#$ cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot co -r FIREFOX_2_0_0_20_RELEASE mozilla/client.mk
-#$ cd mozilla
-#$ make -f client.mk checkout MOZ_CO_PROJECT=composer
-#$ find . -name CVS -prune -exec rm -rf {} \;
-#$ find . -name .cvsignore -prune -exec rm -rf {} \;
-
-# Building Composer on the 1.8 Mozilla branch
-# Note: on Ubuntu 8.04, requires libgtk2-dev, libxt-dev, libidl-dev
-# + dbus-glib-1-dev, curl (for Mozilla 1.9+)
-#$ make -f client.mk build
-#
+# Build configuration script for Debian
+
+# build in a separate directory (optional)
+#mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-@CONFIG_GUESS@
-export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
+export BUILD_OFFICIAL=1
+
+export MOZ_STANDALONE_COMPOSER=1
+mk_add_options MOZ_STANDALONE_COMPOSER=1
+
+# if you want don't want to use gcc and g or want to use
+# a specific version of the compilers, specify it in the
+# two following lines and uncomment them
+#export CC="gcc-3.0"
+#export CXX="g-3.0"
+
+# Uncomment the 3 following lines on Debian
+#export OS_LIBS="-lc -lpthread"
+#export CFLAGS="-DDEBIAN"
+#export CXXFLAGS="-DDEBIAN"
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-kompozer
-mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../obj-@CONFIG_GUESS@
-#mk_add_options MOZ_CO_PROJECT=composer
+# build the standalone composer, obviously
+mk_add_options MOZ_CO_PROJECT=composer
ac_add_options --enable-application=composer
+# change these two line to build in debug mode
ac_add_options --enable-optimize
+ac_add_options --with-pthreads
ac_add_options --disable-debug
-#ac_add_options --disable-optimize
-#ac_add_options --enable-debug
-
-#ac_add_options --disable-shared
-#ac_add_options --enable-static
-#ac_add_options --disable-libxul
-#ac_add_options --disable-xpfe-components
-ac_add_options --enable-xpfe-components
-ac_add_options --disable-tests
-ac_add_options --disable-installer
-
-#ac_add_options --disable-libxul
-#ac_add_options --disable-crashreporter
+# adapt the following lines according to your distribution
-#ac_add_options --enable-optimize
-#ac_add_options --enable-default-toolkit=gtk2
-##ac_add_options --enable-default-toolkit=cairo-gtk2
-#ac_add_options --enable-xft
-#ac_add_options --disable-canvas
-##ac_add_options --disable-cairo
-
-#ac_add_options --enable-extensions="default inspector venkman"
-ac_add_options --enable-extensions="default spellcheck"
-#ac_add_options --enable-inspector-apis
-
-##ac_add_options --enable-extensions=wallet,xml-rpc,xmlextras,pref,universalchardet,spellcheck
-##ac_add_options --enable-extensions=xml-rpc,xmlextras,pref,universalchardet
-#ac_add_options --disable-extensions
-## (now by default) ac_add_options --enable-necko-protocols=http,ftp,file,jar,viewsource,res,data
-ac_add_options --enable-necko-protocols=http,ftp,file,jar,viewsource,res,data
-##ac_add_options --enable-mathml
-#ac_add_options --enable-svg
-
-#ac_add_options --disable-installer
-#ac_add_options --disable-javaxpcom
-#ac_add_options --disable-activex
-#ac_add_options --disable-activex-scripting
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+ac_add_options --disable-tests
+ac_add_options --enable-necko-protocols=http,ftp,file,jar,viewsource,res,data
-# Ubuntu 7.10 default flags: https://wiki.mozilla.org/Linux/Compiler_Options
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-xft
ac_add_options --enable-pango
ac_add_options --enable-postscript
ac_add_options --disable-xprint
-ac_add_options --enable-mathml
+#ac_add_options --enable-mathml
ac_add_options --enable-svg
-ac_add_options --enable-svg-renderer=cairo
+#ac_add_options --enable-svg-renderer=cairo
ac_add_options --enable-system-cairo
ac_add_options --enable-canvas
-ac_add_options --with-system-png=/usr
-ac_add_options --with-system-jpeg=/usr
-ac_add_options --with-system-zlib=/usr
+ac_add_options --with-system-png
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
ac_add_options --enable-gnomevfs
-ac_add_options --enable-xinerama
ac_add_options --enable-single-profile
ac_add_options --disable-profilesharing
ac_add_options --enable-system-myspell
+ac_add_options --disable-installer
+ac_add_options --disable-xpfe-components
+ac_add_options --with-default-mozilla-five-home=/usr/lib/kompozer
+ac_add_options --with-distribution-id=aur.archlinux.org
+ac_add_options --without-system-nspr
+ac_add_options --without-system-nss
+
+#ac_add_options --disable-elf-dynstr-gc
+#ac_add_options --disable-gtktest
+ac_add_options --enable-strip
+#ac_add_options --disable-strip-lib
+ac_add_options --disable-updater
+
+ac_add_options --enable-xinerama
+ac_add_options --enable-xpcom-fastload
+
+ac_cv_visibility_pragma=no
+
+
+