mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
added community/lash
This commit is contained in:
parent
66b417f48c
commit
cecc366ce6
4 changed files with 92 additions and 0 deletions
29
community/lash/04_disable_stacktrace.patch
Normal file
29
community/lash/04_disable_stacktrace.patch
Normal file
|
@ -0,0 +1,29 @@
|
||||||
|
Description: Don't print the stacktrace on segfaults.
|
||||||
|
Fixes FTBFS on armel,powerpc,ia64,alpha.
|
||||||
|
Origin: Ubuntu, https://launchpad.net/bugs/647091
|
||||||
|
Bug-Ubuntu: https://launchpad.net/bugs/647091
|
||||||
|
---
|
||||||
|
lashd/sigsegv.c | 5 +++++
|
||||||
|
1 file changed, 5 insertions(+)
|
||||||
|
|
||||||
|
--- lash.orig/lashd/sigsegv.c
|
||||||
|
+++ lash/lashd/sigsegv.c
|
||||||
|
@@ -90,6 +90,10 @@ static void signal_segv(int signum, sigi
|
||||||
|
lash_error("info.si_errno = %d", info->si_errno);
|
||||||
|
lash_error("info.si_code = %d (%s)", info->si_code, si_codes[info->si_code]);
|
||||||
|
lash_error("info.si_addr = %p", info->si_addr);
|
||||||
|
+
|
||||||
|
+#if defined(__arm__) || defined(__powerpc__) || defined (__ia64__) || defined (__alpha__) || defined (__FreeBSD_kernel__)
|
||||||
|
+ lash_error("No stack trace");
|
||||||
|
+#else
|
||||||
|
for(i = 0; i < NGREG; i++)
|
||||||
|
lash_error("reg[%02d] = 0x" REGFORMAT, i, ucontext->uc_mcontext.gregs[i]);
|
||||||
|
|
||||||
|
@@ -143,6 +147,7 @@ static void signal_segv(int signum, sigi
|
||||||
|
lash_error("%s", strings[i]);
|
||||||
|
#endif
|
||||||
|
lash_error("End of stack trace");
|
||||||
|
+#endif
|
||||||
|
exit (-1);
|
||||||
|
}
|
||||||
|
|
43
community/lash/PKGBUILD
Normal file
43
community/lash/PKGBUILD
Normal file
|
@ -0,0 +1,43 @@
|
||||||
|
# $Id$
|
||||||
|
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
|
||||||
|
# Contributor: DonVla <donvla@users.sourceforge.net>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to fix FTBFS on ARM
|
||||||
|
|
||||||
|
pkgname=lash
|
||||||
|
pkgver=0.6.0~rc2
|
||||||
|
_relver=0.6.0.594
|
||||||
|
pkgrel=7
|
||||||
|
pkgdesc="A session management system for JACK and ALSA"
|
||||||
|
arch=('i686' 'x86_64')
|
||||||
|
#url="http://lash-audio.org"
|
||||||
|
url="http://lash.nongnu.org/"
|
||||||
|
license=('GPL')
|
||||||
|
depends=('dbus-core' 'gtk2' 'jack' 'libxml2' 'python2')
|
||||||
|
install=$pkgname.install
|
||||||
|
source=("http://download.savannah.gnu.org/releases/lash/${pkgname}-${pkgver}.tar.bz2" "makefile.patch"
|
||||||
|
'04_disable_stacktrace.patch')
|
||||||
|
md5sums=('af1dc4f4ceb284b1b0845de4f4c2fe47'
|
||||||
|
'24ceb7e3d008c25e1490102983165612'
|
||||||
|
'5bca5868120205e93caffb30c877e946')
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "${srcdir}/${pkgname}-${_relver}"
|
||||||
|
patch -p0 < "${srcdir}/makefile.patch"
|
||||||
|
patch -p1 -i ../04_disable_stacktrace.patch
|
||||||
|
|
||||||
|
# Python2 fixes
|
||||||
|
export PYTHON="python2"
|
||||||
|
sed -i "s#env python#&2#" clients/lash_control
|
||||||
|
|
||||||
|
export LDFLAGS="-ldl -lm"
|
||||||
|
|
||||||
|
./configure --prefix=/usr
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd "${srcdir}/${pkgname}-${_relver}"
|
||||||
|
make DESTDIR=${pkgdir} install
|
||||||
|
}
|
6
community/lash/lash.install
Normal file
6
community/lash/lash.install
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
post_install() {
|
||||||
|
printf "\n"
|
||||||
|
printf "==> You might need to add following line to your /etc/services(without quotes):\n"
|
||||||
|
printf "==> \"lash 14541/tcp # LASH client/server protocol\"\n"
|
||||||
|
printf "\n"
|
||||||
|
}
|
14
community/lash/makefile.patch
Normal file
14
community/lash/makefile.patch
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
--- docs/Makefile.in.orig 2008-11-09 22:45:28.000000000 +0100
|
||||||
|
+++ docs/Makefile.in 2011-07-23 17:12:26.000000000 +0200
|
||||||
|
@@ -527,9 +527,9 @@
|
||||||
|
@HAVE_TEXI2HTML_TRUE@ mkdir -lash-manual-html-split; \
|
||||||
|
@HAVE_TEXI2HTML_TRUE@ fi
|
||||||
|
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-one-page && \
|
||||||
|
-@HAVE_TEXI2HTML_TRUE@ texi2html --number ../$(top_srcdir)/docs/lash-manual.texi
|
||||||
|
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections ../$(top_srcdir)/docs/lash-manual.texi
|
||||||
|
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-split && \
|
||||||
|
-@HAVE_TEXI2HTML_TRUE@ texi2html --number --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
||||||
|
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
||||||
|
@HAVE_TEXI2HTML_TRUE@ touch html-manual-stamp
|
||||||
|
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||||
|
# Otherwise a system limit (for SysV at least) may be exceeded.
|
Loading…
Reference in a new issue