mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/js78 to 78.9.0-1
This commit is contained in:
parent
29e7fafb45
commit
ced5f6ccb7
3 changed files with 14 additions and 14 deletions
|
@ -34,7 +34,7 @@ index 366c6691f7d11..e5342a037ee92 100644
|
|||
add_old_configure_assignment('MOZ_LTO_CFLAGS', lto.cflags)
|
||||
add_old_configure_assignment('MOZ_LTO_LDFLAGS', lto.ldflags)
|
||||
diff --git a/config/makefiles/rust.mk b/config/makefiles/rust.mk
|
||||
index b5c7973104ceb..079408b358edb 100644
|
||||
index f4475054f8979..f19dfbc72fad0 100644
|
||||
--- a/config/makefiles/rust.mk
|
||||
+++ b/config/makefiles/rust.mk
|
||||
@@ -59,17 +59,19 @@ cargo_rustc_flags = $(CARGO_RUSTCFLAGS)
|
||||
|
@ -58,7 +58,7 @@ index b5c7973104ceb..079408b358edb 100644
|
|||
|
||||
ifdef CARGO_INCREMENTAL
|
||||
export CARGO_INCREMENTAL
|
||||
@@ -185,10 +187,19 @@ target_rust_ltoable := force-cargo-library-build
|
||||
@@ -195,10 +197,19 @@ target_rust_ltoable := force-cargo-library-build
|
||||
target_rust_nonltoable := force-cargo-test-run force-cargo-library-check $(foreach b,build check,force-cargo-program-$(b))
|
||||
|
||||
ifdef MOZ_PGO_RUST
|
||||
|
@ -80,7 +80,7 @@ index b5c7973104ceb..079408b358edb 100644
|
|||
$(target_rust_nonltoable): RUSTFLAGS:=$(rustflags_override) $(rustflags_sancov) $(RUSTFLAGS)
|
||||
|
||||
TARGET_RECIPES := $(target_rust_ltoable) $(target_rust_nonltoable)
|
||||
@@ -302,17 +313,19 @@ $(RUST_LIBRARY_FILE): force-cargo-library-build
|
||||
@@ -312,17 +323,19 @@ $(RUST_LIBRARY_FILE): force-cargo-library-build
|
||||
# When we are building in --enable-release mode; we add an additional check to confirm
|
||||
# that we are not importing any networking-related functions in rust code. This reduces
|
||||
# the chance of proxy bypasses originating from rust code.
|
||||
|
|
|
@ -87,7 +87,7 @@ Differential Revision: https://phabricator.services.mozilla.com/D91572
|
|||
create mode 100644 third_party/rust/packed_simd/src/api/bitmask.rs
|
||||
|
||||
diff --git a/.cargo/config.in b/.cargo/config.in
|
||||
index f014783896510..0ee86efe406ab 100644
|
||||
index b1a1b35f77e30..1accd1ef72586 100644
|
||||
--- a/.cargo/config.in
|
||||
+++ b/.cargo/config.in
|
||||
@@ -50,7 +50,7 @@ tag = "v0.3.0"
|
||||
|
@ -100,7 +100,7 @@ index f014783896510..0ee86efe406ab 100644
|
|||
[source."https://github.com/djg/cubeb-pulse-rs"]
|
||||
git = "https://github.com/djg/cubeb-pulse-rs"
|
||||
diff --git a/Cargo.lock b/Cargo.lock
|
||||
index 82d9a4645da27..b6994d525fb3a 100644
|
||||
index c41d9fcc3e394..eee2f32fe1a5a 100644
|
||||
--- a/Cargo.lock
|
||||
+++ b/Cargo.lock
|
||||
@@ -3425,8 +3425,8 @@ dependencies = [
|
||||
|
@ -115,7 +115,7 @@ index 82d9a4645da27..b6994d525fb3a 100644
|
|||
"cfg-if",
|
||||
]
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 6f6199ab26653..2c162e6567781 100644
|
||||
index b723c1da2d57d..3173ef840cdf1 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -66,7 +66,7 @@ panic = "abort"
|
||||
|
@ -125,8 +125,8 @@ index 6f6199ab26653..2c162e6567781 100644
|
|||
-packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="3541e3818fdc7c2a24f87e3459151a4ce955a67a" }
|
||||
+packed_simd = { git = "https://github.com/hsivonen/packed_simd", rev="0917fe780032a6bbb23d71be545f9c1834128d75" }
|
||||
rlbox_lucet_sandbox = { git = "https://github.com/PLSysSec/rlbox_lucet_sandbox/", rev="d510da5999a744c563b0acd18056069d1698273f" }
|
||||
nix = { git = "https://github.com/shravanrn/nix/", branch = "r0.13.1", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
|
||||
spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3", rev = "20191ad2f370afd6d247edcb9ff9da32d3bedb9c" }
|
||||
nix = { git = "https://github.com/shravanrn/nix/", rev="4af6c367603869a30fddb5ffb0aba2b9477ba92e" }
|
||||
spirv_cross = { git = "https://github.com/kvark/spirv_cross", branch = "wgpu3" }
|
||||
diff --git a/third_party/rust/packed_simd/.cargo-checksum.json b/third_party/rust/packed_simd/.cargo-checksum.json
|
||||
index 01afcc1efdacd..1512803e57292 100644
|
||||
--- a/third_party/rust/packed_simd/.cargo-checksum.json
|
||||
|
|
|
@ -5,7 +5,7 @@
|
|||
# - patch to fix build on ARM
|
||||
|
||||
pkgname=js78
|
||||
pkgver=78.8.0
|
||||
pkgver=78.9.0
|
||||
pkgrel=1
|
||||
pkgdesc="JavaScript interpreter and libraries - Version 78"
|
||||
arch=(x86_64)
|
||||
|
@ -19,10 +19,10 @@ source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox
|
|||
0001-Fixes-for-LTO-PGO-support.patch
|
||||
0002-Bug-1667736-Update-packed_simd-to-compile-on-Rust-1..patch
|
||||
arm.patch)
|
||||
sha256sums=('1cf2dfdee2e31fd0a5ecced6275a33fa11bee1d2a7c65e23350b26992584a110'
|
||||
sha256sums=('8e03ac1dfc5ac804c8b13a529414a9387e0425e545bb2f4462d74c3175e64864'
|
||||
'SKIP'
|
||||
'2c5381bd087dc04287f830d8a3ea739d0c69e43170c2240fd5db78c795d2e65a'
|
||||
'ad3dd149651d76c1c3de2dc71d3fb3361181a1add75ff095df7bfba88a4e4ad6'
|
||||
'926a573eabe3b6177363b795ed5e5641b4a4ebc6d7cfa093f11e1779ac0f897c'
|
||||
'5f7c132fe7dab5e412cfd24c0c542531d4bfbcf030c736d46993845ba262cf9c'
|
||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966')
|
||||
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
|
||||
|
||||
|
@ -62,8 +62,8 @@ build() {
|
|||
--without-system-icu
|
||||
)
|
||||
|
||||
export CC='clang --target=x86_64-unknown-linux-gnu'
|
||||
export CXX='clang++ --target=x86_64-unknown-linux-gnu'
|
||||
export CC='clang'
|
||||
export CXX='clang++'
|
||||
export AR=llvm-ar
|
||||
export NM=llvm-nm
|
||||
export RANLIB=llvm-ranlib
|
||||
|
|
Loading…
Reference in a new issue