mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/lensfun to 0.2.8-1
This commit is contained in:
parent
9e20900b38
commit
ceda38df1c
4 changed files with 18 additions and 27 deletions
|
@ -5,7 +5,7 @@
|
|||
# - disable vectorization, ensure our cflags get used to build
|
||||
|
||||
pkgname=lensfun
|
||||
pkgver=0.2.7
|
||||
pkgver=0.2.8
|
||||
pkgrel=1
|
||||
pkgdesc="Database of photographic lenses and a library that allows advanced access to the database"
|
||||
arch=(i686 x86_64)
|
||||
|
@ -13,11 +13,14 @@ url="http://lensfun.berlios.de/"
|
|||
license=('LGPL3')
|
||||
depends=('glibc' 'glib2')
|
||||
makedepends=('python2' 'libpng' 'doxygen')
|
||||
source=("http://download.berlios.de/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
|
||||
source=("http://download.berlios.de/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
|
||||
lensfun-0.2.8-make-4.0.patch)
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
sed -i 's|#!/usr/bin/python|#!/usr/bin/python2|' configure
|
||||
# fix configure script for make 4.0
|
||||
patch -Np0 -i "${srcdir}/lensfun-0.2.8-make-4.0.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
@ -33,4 +36,5 @@ package() {
|
|||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make INSTALL_PREFIX="$pkgdir" install
|
||||
}
|
||||
md5sums=('6061cc2d00a42d3e62512878426fc841')
|
||||
md5sums=('db2988505e7432c6b331aa597789c639'
|
||||
'9464d933a5e4ccefed7fc38656a9ec18')
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
diff -ru lensfun-0.2.3.orig/build/mak/compiler/gcc.mak lensfun-0.2.3/build/mak/compiler/gcc.mak
|
||||
--- lensfun-0.2.3.orig/build/mak/compiler/gcc.mak 2009-03-15 02:42:40.000000000 +0100
|
||||
+++ lensfun-0.2.3/build/mak/compiler/gcc.mak 2009-03-15 02:43:37.000000000 +0100
|
||||
@@ -71,7 +71,7 @@
|
||||
endef
|
||||
|
||||
LINK.GCC.AR = $(GCC.AR) $(GCC.ARFLAGS) $@ $^
|
||||
-LINK.GCC.EXEC = $(GCC.LD) -o $@ $(GCC.LDFLAGS) $(LDFLAGS) $1 $^ $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $2
|
||||
+LINK.GCC.EXEC = $(GCC.LD) $(LDFLAGS) $^ $2 $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $(GCC.LDFLAGS) $1 -o $@
|
||||
define LINK.GCC.SO
|
||||
$(GCC.LD) -o $@.$(SHARED.$3) -Wl,"-soname=$(notdir $@).$(basename $(basename $(SHARED.$3)))" $(GCC.LDFLAGS.SHARED) $(GCC.LDFLAGS) $(LDFLAGS) $1 $^ $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $2
|
||||
ln -fs $(notdir $@.$(SHARED.$3)) $@.$(basename $(basename $(SHARED.$3)))
|
||||
Only in lensfun-0.2.3/out/posix/release: deps
|
|
@ -1,11 +0,0 @@
|
|||
--- lensfun-0.2.3.orig/tools/makedep/cppsetup.cpp 2009-07-04 21:20:49.000000000 +0200
|
||||
+++ lensfun-0.2.3/tools/makedep/cppsetup.cpp 2009-07-04 22:19:18.000000000 +0200
|
||||
@@ -195,7 +195,7 @@
|
||||
}
|
||||
while (s);
|
||||
|
||||
- eol = strchr (var, 0);
|
||||
+ eol = (char *)strchr (var, 0);
|
||||
|
||||
// Skip parentheses which Microsoft likes so much
|
||||
if (*var == '(')
|
11
extra/lensfun/lensfun-0.2.8-make-4.0.patch
Normal file
11
extra/lensfun/lensfun-0.2.8-make-4.0.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.old 2013-12-06 16:55:09.098654166 +0100
|
||||
+++ configure 2013-12-06 16:55:20.298676545 +0100
|
||||
@@ -45,7 +45,7 @@
|
||||
}
|
||||
|
||||
# Check for tools
|
||||
-tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "3.81", True)
|
||||
+tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "4.0", True)
|
||||
if tibs.check_program ("makedep", "makedep -V", ".*Version.*?([0-9\.]+).*", "0.1.0"):
|
||||
tibs.add_config_mak ("MAKEDEP", "makedep")
|
||||
makedep = "yes"
|
Loading…
Reference in a new issue