added community/tuxcmd

This commit is contained in:
Kevin Mihelich 2016-01-10 01:34:32 +00:00
parent 550e864820
commit cf9e222321
3 changed files with 76 additions and 0 deletions

44
community/tuxcmd/PKGBUILD Normal file
View file

@ -0,0 +1,44 @@
# $Id$
# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch and libgcc hack to fix ARM FTBFS
pkgname=tuxcmd
pkgver=0.6.70
pkgrel=5
pkgdesc='A GTK2 file manager with two panels'
arch=('i686' 'x86_64')
url='http://tuxcmd.sourceforge.net/'
license=('GPL')
depends=('gtk2' 'hicolor-icon-theme')
makedepends=('fpc' 'desktop-file-utils')
optdepends=('gnome-vfs: support for gvfs'
'tuxcmd-modules: modules for tuxcmd')
options=('!docs' '!emptydirs')
install=${pkgname}.install
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgname}-dev-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
'tuxcmd-arm-gcc_s.so-linking.patch')
md5sums=('52e3bfa7c4118539b4c4b83e335290d1'
'abee41cc4c60f19655e81a27f1a60d4e')
prepare() {
cd ${pkgname}-${pkgver}
patch -p1 -i ../tuxcmd-arm-gcc_s.so-linking.patch
ln -s /usr/lib/libgcc_s.so.1 libgcc_s.so
}
build() {
cd ${pkgname}-${pkgver}
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir}/usr install
# remove license and README file
rm -rf ${pkgdir}/usr/share/doc/
}

View file

@ -0,0 +1,21 @@
diff -up tuxcmd-0.6.70/ULibc.pas.old tuxcmd-0.6.70/ULibc.pas
--- tuxcmd-0.6.70/ULibc.pas.old 2009-11-15 11:00:35.000000000 -0500
+++ tuxcmd-0.6.70/ULibc.pas 2013-09-27 11:59:23.651774490 -0400
@@ -28,6 +28,7 @@ interface
const GLIBC_LIB = 'libc.so.6';
DL_LIB = 'libdl.so.2';
PTHREAD_LIB = 'libpthread.so.0';
+ GCC_S_LIB = 'libgcc_s.so.1';
type
{$IFDEF KYLIX}
@@ -892,6 +893,9 @@ function getegid: __gid_t; cdecl; extern
function access(pathname: PChar; mode: Longint): Longint; cdecl; external GLIBC_LIB name 'access';
function euidaccess(pathname: PChar; mode: Longint): Longint; cdecl; external GLIBC_LIB name 'euidaccess';
+{$IFDEF CPUARM}
+function __aeabi_unwind_cpp_pr0: integer; cdecl; external GCC_S_LIB name '__aeabi_unwind_cpp_pr0';
+{$ENDIF}
type pthread_t = {$ifdef cpu64}QWord{$else}DWord{$endif};

View file

@ -0,0 +1,11 @@
post_install() {
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}
post_upgrade() {
post_install
}
post_remove() {
post_install
}