From cfe70a97f49d57f9a39c563e891646aec00faa70 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Tue, 27 Oct 2015 12:45:25 +0000
Subject: [PATCH] removed community/rebar

---
 community/rebar/PKGBUILD      | 38 -----------------------------------
 community/rebar/aarch64.patch | 15 --------------
 2 files changed, 53 deletions(-)
 delete mode 100644 community/rebar/PKGBUILD
 delete mode 100644 community/rebar/aarch64.patch

diff --git a/community/rebar/PKGBUILD b/community/rebar/PKGBUILD
deleted file mode 100644
index d09e97c12..000000000
--- a/community/rebar/PKGBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# $Id$
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
-# Maintainer: AeroNotix <aaron.l.france@gmail.com>
-# Contributor: AeroNotix <aaron.l.france@gmail.com>
-
-# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
-#  - patch for AArch64 (https://github.com/rebar/rebar/pull/538)
-
-pkgname=rebar
-epoch=1
-pkgver=2.6.0
-pkgrel=1.1
-pkgdesc="A sophisticated build-tool for Erlang projects that follows OTP principles."
-arch=('any')
-url="https://github.com/rebar/rebar"
-license=('APACHE')
-depends=('erlang-nox')
-makedepends=('git')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rebar/rebar/archive/$pkgver.tar.gz"
-        'aarch64.patch')
-md5sums=('20aea5eafe90f68accfe9487974ed0bf'
-         '72bcc92fe06030bba13295bfc5578947')
-
-prepare() {
-  cd "$srcdir/rebar-$pkgver"
-  patch -p1 -i ../aarch64.patch
-}
-
-build() {
-  cd "$srcdir/rebar-$pkgver"
-  make
-}
-
-package() {
-  cd "$srcdir/rebar-$pkgver"
-  install -Dm0755 "rebar" "$pkgdir/usr/bin/rebar"
-  install -Dm0644 "priv/shell-completion/bash/rebar" "$pkgdir/usr/share/bash-completion/completions/rebar"
-}
diff --git a/community/rebar/aarch64.patch b/community/rebar/aarch64.patch
deleted file mode 100644
index 10e9df631..000000000
--- a/community/rebar/aarch64.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -urN a/src/rebar_port_compiler.erl b/src/rebar_port_compiler.erl
---- a/src/rebar_port_compiler.erl	2015-06-19 10:14:28.000000000 -0600
-+++ b/src/rebar_port_compiler.erl	2015-09-07 19:16:25.828631245 -0600
-@@ -604,11 +604,6 @@
-      {"solaris.*-64$", "CXXFLAGS", "-D_REENTRANT -m64 $CXXFLAGS"},
-      {"solaris.*-64$", "LDFLAGS", "-m64 $LDFLAGS"},
- 
--     %% Linux specific flags for multiarch
--     {"linux.*-64$", "CFLAGS", "-m64 $CFLAGS"},
--     {"linux.*-64$", "CXXFLAGS", "-m64 $CXXFLAGS"},
--     {"linux.*-64$", "LDFLAGS", "$LDFLAGS"},
--
-      %% OS X Leopard flags for 64-bit
-      {"darwin9.*-64$", "CFLAGS", "-m64 $CFLAGS"},
-      {"darwin9.*-64$", "CXXFLAGS", "-m64 $CXXFLAGS"},