extra/qt5 to 5.5.0-1

This commit is contained in:
Kevin Mihelich 2015-07-15 03:19:31 +00:00
parent 46f481ac18
commit d0d649fa5a
4 changed files with 111 additions and 274 deletions

View file

@ -3,7 +3,7 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - removed libfbclient, ibase
# - removed libfbclient makedepend
# - no x86/neon optimizations
# - restricted makeflags to -j3
# - enabled opengl es2, mesa makedepend for headers
@ -15,7 +15,9 @@
# - fix Raspberry Pi EGL/GLESv2 build
pkgbase=qt5
pkgname=('qt5-base'
pkgname=('qt5-3d'
'qt5-base'
'qt5-canvas3d'
'qt5-connectivity'
'qt5-declarative'
'qt5-doc'
@ -38,34 +40,30 @@ pkgname=('qt5-base'
'qt5-websockets'
'qt5-x11extras'
'qt5-xmlpatterns')
pkgver=5.4.2
pkgver=5.5.0
pkgrel=1
arch=('i686' 'x86_64')
url='http://qt-project.org/'
url='http://www.qt.io/developers'
license=('GPL3' 'LGPL' 'FDL' 'custom')
makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
'mesa' 'at-spi2-core' 'alsa-lib' 'gst-plugins-base-libs' 'gstreamer0.10-base-plugins'
'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
'postgresql-libs' 'libmariadbclient' 'sqlite' 'unixodbc' 'libfbclient' 'libmng'
'python2' 'ruby' 'gperf' 'libxslt' 'libxcomposite' 'fontconfig' 'bluez-libs'
'openal' 'gtk2' 'libxkbcommon-x11' 'mtdev' 'harfbuzz' 'libwebp' 'leveldb'
'geoclue' 'pciutils' 'nss' 'gstreamer0.10-bad')
'mesa' 'at-spi2-core' 'alsa-lib' 'gst-plugins-base-libs' 'libjpeg-turbo' 'cups'
'libpulse' 'hicolor-icon-theme' 'desktop-file-utils' 'postgresql-libs' 'nss'
'libmariadbclient' 'sqlite' 'unixodbc' 'libmng' 'python2' 'ruby'
'gperf' 'libxslt' 'libxcomposite' 'fontconfig' 'bluez-libs' 'openal' 'gtk2'
'libxkbcommon-x11' 'mtdev' 'harfbuzz' 'libwebp' 'leveldb' 'geoclue' 'pciutils'
'libinput')
groups=('qt' 'qt5')
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/${pkgver%.*}/${pkgver}/single/${_pkgfqn}.tar.xz"
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
'keypad-shortcuts.patch' 'avoid-calling-potentially-pure-virtual-method.patch'
'ibus-get-display-number-when-screen-number-is-omitted.patch'
'rpi.patch'
'keypad-shortcuts.patch'
'qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch')
md5sums=('c23bd0f14d66e7901d24906a1edce9b0'
md5sums=('65d5282f3dee0336da9ed1f77148952f'
'b2897dd6a2967bccf8f10e397aafee55'
'76e150b20178d2d43801f7367232e5f7'
'188da8f4c87316e730ebf1c6217bf5a0'
'322b419b16c75d4de0ee7ad0a246caa1'
'665439088fc7de52a97455c5eaf87889'
'cab3284d52ea700b8761f4d71d68baf0'
'39e285d08b4951de095c2f6d6acdc925'
'9fe115d2c1d4778b8cb8e7f1b2e2bca6'
'd55ad1f1c90725834b44eada5db4e401')
@ -75,12 +73,6 @@ prepare() {
# https://bugs.archlinux.org/task/44676
(cd qtbase; patch -p1 -i "$srcdir/keypad-shortcuts.patch")
# https://bugs.archlinux.org/task/43986
(cd qtdeclarative; patch -p1 -i "$srcdir/avoid-calling-potentially-pure-virtual-method.patch")
# https://bugs.archlinux.org/task/45180
(cd qtbase; patch -p1 -i "$srcdir/ibus-get-display-number-when-screen-number-is-omitted.patch")
MAKEFLAGS="-j3"
# Fix building on armv5
@ -88,29 +80,6 @@ prepare() {
patch -p1 -i "${srcdir}"/qt5webkit-0002-Fix-QtWebKit-build-on-ARM-softfp.patch
cd ..
# Raspberry Pi
# if [ "$CARCH" == 'armv6h' ]; then
# # Removes pkg-config checks for egl and glesv2 which would interfere with our custom paths below.
# # Better solution would be to provide a raspberrypi-libgl package which provides 'libgl' and pkg-config modules
# # for the egl, glesv2 libs in /opt/vc/. Not sure if that would break other packages, though. So I'm leaving it
# # at this for now.
# patch -p1 -i "${srcdir}"/rpi.patch
#
# # VideoCore libs and includes
# vc_include_dir="/opt/vc/include /opt/vc/include/interface/vcos/pthreads /opt/vc/include/interface/vmcs_host/linux"
# vc_lib_dir="/opt/vc/lib"
# sed -i "/^QMAKE_INCDIR_OPENGL\s/s|=|= $vc_include_dir|g" qtbase/mkspecs/common/linux.conf
# sed -i "/^QMAKE_LIBDIR_OPENGL\s/s|=|= $vc_lib_dir|g" qtbase/mkspecs/common/linux.conf
#
# sed -i "/^QMAKE_INCDIR_EGL\s/s|=|= $vc_include_dir|g" qtbase/mkspecs/common/linux.conf
# sed -i "/^QMAKE_LIBDIR_EGL\s/s|=|= $vc_lib_dir|g" qtbase/mkspecs/common/linux.conf
# sed -i "/^QMAKE_LIBS_EGL\s/s|= -lEGL|= -lEGL -lGLESv2|g" qtbase/mkspecs/common/linux.conf
# sed -i "/^QMAKE_LIBS_OPENGL_ES2\s/s|= -lGLESv2|= -lEGL -lGLESv2|g" qtbase/mkspecs/common/linux.conf
#
# echo "EGLFS_PLATFORM_HOOKS_SOURCES = $PWD/qtbase/mkspecs/devices/linux-rasp-pi-g++/qeglfshooks_pi.cpp" >> qtbase/mkspecs/common/linux.conf
# echo "EGLFS_PLATFORM_HOOKS_LIBS = -lbcm_host" >> qtbase/mkspecs/common/linux.conf
# fi
sed -i "s|-O2|${CXXFLAGS}|" qtbase/mkspecs/common/{g++,gcc}-base.conf
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" qtbase/mkspecs/common/gcc-base-unix.conf
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" qtbase/mkspecs/common/gcc-base.conf
@ -153,7 +122,9 @@ build() {
-dbus-linked \
-system-harfbuzz \
-journald \
-libinput \
-no-use-gold-linker \
-no-reduce-relocations \
-no-sse2 \
-no-sse3 \
-no-ssse3 \
@ -183,11 +154,24 @@ build() {
make docs
}
package_qt5-3d() {
pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics'
depends=('qt5-declarative')
license=('LGPL')
cd ${_pkgfqn}/qt3d
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
}
package_qt5-base() {
pkgdesc='A cross-platform application and UI framework'
depends=('libjpeg-turbo' 'xcb-util-keysyms' 'dbus' 'fontconfig' 'systemd'
'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
'qtchooser' 'libgl')
'qtchooser' 'libinput')
optdepends=('qt5-svg: to use SVG icon themes'
'postgresql-libs: PostgreSQL driver'
'libmariadbclient: MariaDB driver'
@ -219,6 +203,19 @@ package_qt5-base() {
done
}
package_qt5-canvas3d() {
pkgdesc='A JavaScript 3D rendering API for Qt Quick'
depends=('qt5-declarative')
license=('LGPL')
cd ${_pkgfqn}/qtcanvas3d
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
}
package_qt5-connectivity() {
pkgdesc='Provides access to Bluetooth hardware'
depends=('qt5-declarative' 'bluez-libs')
@ -288,57 +285,6 @@ package_qt5-enginio() {
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-xmlpatterns() {
pkgdesc='Support for XPath, XQuery, XSLT and XML schema validation'
depends=('qt5-base')
conflicts=('qt')
cd ${_pkgfqn}/qtxmlpatterns
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
# Useful symlinks
install -d "${pkgdir}"/usr/bin
for b in "${pkgdir}"/usr/lib/qt/bin/*; do
ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
done
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-translations() {
pkgdesc='A cross-platform application and UI framework (Translations)'
depends=('qt5-base')
optdepends=('gstreamer0.10-bad: Qt MediaService plugin')
conflicts=('qt')
cd ${_pkgfqn}/qttranslations
make INSTALL_ROOT="${pkgdir}" install
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-multimedia() {
pkgdesc='Classes for audio, video, radio and camera functionality'
depends=('qt5-declarative' 'libpulse' 'gstreamer0.10-base' 'openal')
conflicts=('qt')
cd ${_pkgfqn}/qtmultimedia
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-graphicaleffects() {
pkgdesc='Graphical effects for use with Qt Quick 2'
depends=('qt5-declarative')
@ -377,10 +323,28 @@ package_qt5-location() {
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-multimedia() {
pkgdesc='Classes for audio, video, radio and camera functionality'
depends=('qt5-declarative' 'libpulse' 'gst-plugins-base-libs' 'openal')
optdepends=('gst-plugins-bad: Qt MediaService plugin')
conflicts=('qt')
cd ${_pkgfqn}/qtmultimedia
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-quick1() {
pkgdesc='Qt Declarative is provided for Qt 4 compatibility'
depends=('qt5-webkit' 'qt5-script')
conflicts=('qt')
license=('LGPL')
cd ${_pkgfqn}/qtquick1
make INSTALL_ROOT="${pkgdir}" install
@ -394,9 +358,6 @@ package_qt5-quick1() {
for b in "${pkgdir}"/usr/lib/qt/bin/*; do
ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
done
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-quickcontrols() {
@ -519,22 +480,16 @@ package_qt5-tools() {
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-webkit() {
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
depends=('qt5-sensors' 'qt5-location' 'qt5-webchannel' 'gst-plugins-base' 'libxslt'
'libxcomposite' 'libwebp')
optdepends=('gst-plugins-good: Webm codec support')
license=('GPL3' 'LGPL' 'FDL')
package_qt5-translations() {
pkgdesc='A cross-platform application and UI framework (Translations)'
depends=('qt5-base')
conflicts=('qt')
cd ${_pkgfqn}/qtwebkit
cd ${_pkgfqn}/qttranslations
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
# Fix wrong path in pc file
perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/Qt5WebKit.pc
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-wayland() {
@ -567,10 +522,27 @@ package_qt5-webchannel() {
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-webkit() {
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
depends=('qt5-sensors' 'qt5-location' 'qt5-webchannel' 'gst-plugins-base' 'libxslt'
'libxcomposite' 'libwebp')
optdepends=('gst-plugins-good: Webm codec support')
license=('GPL3' 'LGPL' 'FDL')
cd ${_pkgfqn}/qtwebkit
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
# Fix wrong path in pc file
perl -pi -e "s, -L${srcdir}/?\S+,,g" "${pkgdir}"/usr/lib/pkgconfig/Qt5WebKit.pc
}
package_qt5-websockets() {
pkgdesc='Provides WebSocket communication compliant with RFC 6455'
depends=('qt5-declarative')
license=('LGPL')
cd ${_pkgfqn}/qtwebsockets
make INSTALL_ROOT="${pkgdir}" install
@ -578,6 +550,9 @@ package_qt5-websockets() {
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-x11extras() {
@ -594,3 +569,25 @@ package_qt5-x11extras() {
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}
package_qt5-xmlpatterns() {
pkgdesc='Support for XPath, XQuery, XSLT and XML schema validation'
depends=('qt5-base')
conflicts=('qt')
cd ${_pkgfqn}/qtxmlpatterns
make INSTALL_ROOT="${pkgdir}" install
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
# Useful symlinks
install -d "${pkgdir}"/usr/bin
for b in "${pkgdir}"/usr/lib/qt/bin/*; do
ln -s /usr/lib/qt/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
done
install -D -m644 LGPL_EXCEPTION.txt \
"${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
}

View file

@ -1,64 +0,0 @@
From 0d31aa1617c96ed3e3624d77332ea6f13aba1492 Mon Sep 17 00:00:00 2001
From: David Edmundson <davidedmundson@kde.org>
Date: Thu, 23 Apr 2015 15:01:24 +0200
Subject: [PATCH 67/68] Avoid calling potentially pure virtual method
In Qt 5.4 screenChanged is called indirectly from the destructor of
QPlatformScreen. By comparing new values against the oldScreen we call
call virtual methods of QPlatformScreen from it's own destructor which
results in a crash.
This patch simply emits change signals whenever a screen change regardless
of whether the value differs from the previous screen. Arguably less
efficient, but better than crashing.
This fix is not needed in Qt 5.5 where the QPA architecture has changed.
Task-number: QTBUG-45753
Change-Id: Ic155906928855a377add9b21bff9e72b31f4667e
Reviewed-by: Alan Alpert <aalpert@blackberry.com>
---
src/quick/items/qquickscreen.cpp | 27 +++++++++------------------
1 file changed, 9 insertions(+), 18 deletions(-)
diff --git a/src/quick/items/qquickscreen.cpp b/src/quick/items/qquickscreen.cpp
index c4d1407..0900adb 100644
--- a/src/quick/items/qquickscreen.cpp
+++ b/src/quick/items/qquickscreen.cpp
@@ -347,24 +347,15 @@ void QQuickScreenAttached::screenChanged(QScreen *screen)
emit orientationUpdateMaskChanged();
}
- if (!oldScreen || screen->size() != oldScreen->size()) {
- emit widthChanged();
- emit heightChanged();
- }
- if (!oldScreen || screen->name() != oldScreen->name())
- emit nameChanged();
- if (!oldScreen || screen->orientation() != oldScreen->orientation())
- emit orientationChanged();
- if (!oldScreen || screen->primaryOrientation() != oldScreen->primaryOrientation())
- emit primaryOrientationChanged();
- if (!oldScreen || screen->availableVirtualGeometry() != oldScreen->availableVirtualGeometry())
- emit desktopGeometryChanged();
- if (!oldScreen || screen->logicalDotsPerInch() != oldScreen->logicalDotsPerInch())
- emit logicalPixelDensityChanged();
- if (!oldScreen || screen->physicalDotsPerInch() != oldScreen->physicalDotsPerInch())
- emit pixelDensityChanged();
- if (!oldScreen || screen->devicePixelRatio() != oldScreen->devicePixelRatio())
- emit devicePixelRatioChanged();
+ emit widthChanged();
+ emit heightChanged();
+ emit nameChanged();
+ emit orientationChanged();
+ emit primaryOrientationChanged();
+ emit desktopGeometryChanged();
+ emit logicalPixelDensityChanged();
+ emit pixelDensityChanged();
+ emit devicePixelRatioChanged();
connect(screen, SIGNAL(geometryChanged(QRect)),
this, SIGNAL(widthChanged()));
--
2.3.7

View file

@ -1,32 +0,0 @@
From c72325d52575cb8a46cc8595c592c27581089dec Mon Sep 17 00:00:00 2001
From: Takao Fujiwara <tfujiwar@redhat.com>
Date: Tue, 24 Mar 2015 19:08:34 +0900
Subject: [PATCH] ibus: Get display number when screen number is omitted.
QIBusPlatformInputContextPrivate::createConnection() parses DISPLAY
variable and it does not get the display number when the screen number
is omitted. E.g. DISPLAY=":1".
Change-Id: I9f81d8114d4e0f654a27ada67c5dc110eb34cd64
Reviewed-by: Gatis Paeglis <gatis.paeglis@digia.com>
---
.../ibus/qibusplatforminputcontext.cpp | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/src/plugins/platforminputcontexts/ibus/qibusplatforminputcontext.cpp b/src/plugins/platforminputcontexts/ibus/qibusplatforminputcontext.cpp
index d00435b..673942b 100644
--- a/src/plugins/platforminputcontexts/ibus/qibusplatforminputcontext.cpp
+++ b/src/plugins/platforminputcontexts/ibus/qibusplatforminputcontext.cpp
@@ -351,6 +351,8 @@ QDBusConnection *QIBusPlatformInputContextPrivate::createConnection()
int pos2 = display.indexOf('.', pos);
if (pos2 > 0)
displayNumber = display.mid(pos, pos2 - pos);
+ else
+ displayNumber = display.right(pos);
if (debug)
qDebug() << "host=" << host << "displayNumber" << displayNumber;
--
1.7.1

View file

@ -1,64 +0,0 @@
diff -urN a/qtbase/configure b/qtbase/configure
--- a/qtbase/configure 2014-12-05 09:24:14.000000000 -0700
+++ b/qtbase/configure 2014-12-12 07:42:49.588901813 -0700
@@ -4853,16 +4853,6 @@
fi
elif [ "$CFG_OPENGL" = "es2" ]; then
#OpenGL ES 2.0
- if [ -n "$PKG_CONFIG" ] && $PKG_CONFIG --exists glesv2 2>/dev/null; then
- QMAKE_INCDIR_OPENGL_ES2=`$PKG_CONFIG --cflags-only-I glesv2 2>/dev/null | sed -e 's,^-I,,g' -e 's, -I, ,g'`
- QMAKE_LIBDIR_OPENGL_ES2=`$PKG_CONFIG --libs-only-L glesv2 2>/dev/null | sed -e 's,^-L,,g' -e 's, -L, ,g'`
- QMAKE_LIBS_OPENGL_ES2=`$PKG_CONFIG --libs glesv2 2>/dev/null`
- QMAKE_CFLAGS_OPENGL_ES2=`$PKG_CONFIG --cflags glesv2 2>/dev/null`
- QMakeVar set QMAKE_INCDIR_OPENGL_ES2 "`shellArgumentListToQMakeList "$QMAKE_INCDIR_OPENGL_ES2"`"
- QMakeVar set QMAKE_LIBDIR_OPENGL_ES2 "`shellArgumentListToQMakeList "$QMAKE_LIBDIR_OPENGL_ES2"`"
- QMakeVar set QMAKE_LIBS_OPENGL_ES2 "`shellArgumentListToQMakeList "$QMAKE_LIBS_OPENGL_ES2"`"
- fi
-
compileTest unix/opengles2 "OpenGL ES 2.0" $QMAKE_LIBS_OPENGL_ES2 $QMAKE_CFLAGS_OPENGL_ES2
if [ $? != "0" ]; then
echo "The OpenGL ES 2.0 functionality test failed!"
@@ -5204,14 +5194,6 @@
exit 101
fi
- if [ -n "$PKG_CONFIG" ] && $PKG_CONFIG --exists egl 2>/dev/null; then
- QMAKE_INCDIR_EGL=`$PKG_CONFIG --cflags-only-I egl 2>/dev/null | sed -e 's,^-I,,g' -e 's, -I, ,g'`
- QMAKE_LIBS_EGL=`$PKG_CONFIG --libs egl 2>/dev/null`
- QMAKE_CFLAGS_EGL=`$PKG_CONFIG --cflags egl 2>/dev/null`
- QMakeVar set QMAKE_INCDIR_EGL "$QMAKE_INCDIR_EGL"
- QMakeVar set QMAKE_LIBS_EGL "$QMAKE_LIBS_EGL"
- QMakeVar set QMAKE_CFLAGS_EGL "`echo " $QMAKE_CFLAGS_EGL " | sed -e 's, -I[^ ]* , ,g;s,^ ,,;s, $,,'`"
- fi # detect EGL support
if compileTest qpa/egl "EGL" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
CFG_EGL=yes
if compileTest qpa/egl-x11 "EGL-X11" $QMAKE_CFLAGS_EGL $QMAKE_LIBS_EGL; then
diff -urN a/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in b/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in
--- a/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-12-05 09:24:36.000000000 -0700
+++ b/qtbase/src/gui/Qt5GuiConfigExtras.cmake.in 2014-12-12 07:42:49.593901822 -0700
@@ -97,8 +97,8 @@
string(REGEX REPLACE "[^_A-Za-z0-9]" "_" _cmake_lib_name ${_lib})
if (NOT TARGET Qt5::Gui_${_cmake_lib_name} AND NOT _Qt5Gui_${_cmake_lib_name}_LIBRARY_DONE)
find_library(Qt5Gui_${_cmake_lib_name}_LIBRARY ${_lib}
+ HINTS \"${LibDir}\"
!!IF !isEmpty(CROSS_COMPILE)
- PATHS \"${LibDir}\"
!!IF !mac
NO_DEFAULT_PATH
!!ENDIF
@@ -155,8 +155,15 @@
unset(Qt5Gui_${_cmake_lib_name}_LIBRARY_DEBUG CACHE)
list(APPEND Qt5Gui_${Name}_LIBRARIES Qt5::Gui_${_cmake_lib_name})
endif()
+ else()
+ if (WIN32 AND NOT Qt5Gui_${_cmake_lib_name}_LIBRARY)
+ list(APPEND Qt5Gui_${Name}_LIBRARIES ${_lib})
+ else()
+ list(APPEND Qt5Gui_${Name}_LIBRARIES Qt5::Gui_${_cmake_lib_name})
+ endif()
endif()
endforeach()
+ list(REMOVE_DUPLICATES Qt5Gui_${Name}_LIBRARIES)
endmacro()