core/linux-armv5 to 4.4.1-1

This commit is contained in:
Kevin Mihelich 2016-01-31 20:05:38 +00:00
parent 034cf55283
commit d0f43154bf
3 changed files with 8 additions and 92 deletions

View file

@ -7,38 +7,36 @@ pkgbase=linux-armv5
_srcname=linux-4.4
_kernelname=${pkgbase#linux}
_desc="ARMv5 multi-platform"
pkgver=4.4.0
pkgrel=2
pkgver=4.4.1
pkgrel=1
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
options=('!strip')
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
'0001-at91-ariag25-updates.patch'
'0002-at91-arietta-g25-support.patch'
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'kernel-CVE-2016-0728.patch'
'config')
md5sums=('9a78fa2eb6c68ca5a40ed5af08142599'
'd9e951895c8c249f0bf52d85f3e63bce'
'efc43501dde0e8fb9329c8ef762ffdf4'
'8cf88daec8febbc1a0703c8a3bd6b25c'
'd311439f7fb7cb067121812236bbad47'
'6470e9783bd1c7a8feddc2d67f07afd5'
'328c76559533938021e2ebe49c9752a6')
'c7e1f6dc037e4316d3df54b862de77c5')
prepare() {
cd "${srcdir}/${_srcname}"
# add upstream patch
#git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
git apply --whitespace=nowarn "${srcdir}/patch-${pkgver}"
# ALARM patches
git apply ../0001-at91-ariag25-updates.patch
git apply ../0002-at91-arietta-g25-support.patch
git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../kernel-CVE-2016-0728.patch
cat "${srcdir}/config" > ./.config

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 4.4.0-rc4-1 Kernel Configuration
# Linux/arm 4.4.0-2 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -2077,8 +2077,7 @@ CONFIG_HW_CONSOLE=y
CONFIG_VT_HW_CONSOLE_BINDING=y
CONFIG_UNIX98_PTYS=y
CONFIG_DEVPTS_MULTIPLE_INSTANCES=y
CONFIG_LEGACY_PTYS=y
CONFIG_LEGACY_PTY_COUNT=4
# CONFIG_LEGACY_PTYS is not set
# CONFIG_SERIAL_NONSTANDARD is not set
# CONFIG_N_GSM is not set
# CONFIG_TRACE_SINK is not set

View file

@ -1,81 +0,0 @@
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
From: Yevgeny Pats <yevgeny@perception-point.io>
Date: Tue, 19 Jan 2016 22:09:04 +0000
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
This fixes CVE-2016-0728.
If a thread is asked to join as a session keyring the keyring that's already
set as its session, we leak a keyring reference.
This can be tested with the following program:
#include <stddef.h>
#include <stdio.h>
#include <sys/types.h>
#include <keyutils.h>
int main(int argc, const char *argv[])
{
int i = 0;
key_serial_t serial;
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
if (keyctl(KEYCTL_SETPERM, serial,
KEY_POS_ALL | KEY_USR_ALL) < 0) {
perror("keyctl");
return -1;
}
for (i = 0; i < 100; i++) {
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
"leaked-keyring");
if (serial < 0) {
perror("keyctl");
return -1;
}
}
return 0;
}
If, after the program has run, there something like the following line in
/proc/keys:
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
with a usage count of 100 * the number of times the program has been run,
then the kernel is malfunctioning. If leaked-keyring has zero usages or
has been garbage collected, then the problem is fixed.
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
Signed-off-by: David Howells <dhowells@redhat.com>
Acked-by: Don Zickus <dzickus@redhat.com>
Acked-by: Prarit Bhargava <prarit@redhat.com>
Acked-by: Jarod Wilson <jarod@redhat.com>
Signed-off-by: James Morris <james.l.morris@oracle.com>
---
security/keys/process_keys.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
index a3f85d2..e6d50172 100644
--- a/security/keys/process_keys.c
+++ b/security/keys/process_keys.c
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
ret = PTR_ERR(keyring);
goto error2;
} else if (keyring == new->session_keyring) {
+ key_put(keyring);
ret = 0;
goto error2;
}
--
cgit v0.12