mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
extra/qt5-webkit to 5.212.0alpha4-9
This commit is contained in:
parent
41412b5229
commit
d10764954e
2 changed files with 177 additions and 4 deletions
|
@ -12,12 +12,13 @@ highmem=1
|
|||
pkgname=qt5-webkit
|
||||
_pkgver=5.212.0-alpha4
|
||||
pkgver=${_pkgver/-/}
|
||||
pkgrel=8
|
||||
pkgrel=9
|
||||
arch=(x86_64)
|
||||
url='https://www.qt.io'
|
||||
license=(GPL3 LGPL3 FDL custom)
|
||||
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
|
||||
source=("https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-$_pkgver/qtwebkit-$_pkgver.tar.xz"
|
||||
icu68.patch
|
||||
qt5-webkit-python-3.9.patch::"https://github.com/qtwebkit/qtwebkit/commit/78360c01.patch"
|
||||
qt5-webkit-bison-3.7.patch::"https://github.com/qtwebkit/qtwebkit/commit/d92b11fe.patch"
|
||||
'atomic.patch')
|
||||
|
@ -25,16 +26,18 @@ depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite g
|
|||
makedepends=(cmake ruby gperf python qt5-doc qt5-tools)
|
||||
optdepends=('gst-plugins-good: Webm codec support')
|
||||
sha256sums=('9ca126da9273664dd23a3ccd0c9bebceb7bb534bddd743db31caf6a5a6d4a9e6'
|
||||
'0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0'
|
||||
'9db5480dfbd3c440489e8e4131e3555b2af61fa4b6c19f35227588c5996be128'
|
||||
'cc5a2b762426e9cda5a3ae056bba266b5f775ee75c0590913839c255d5f10db0'
|
||||
'23fbd785daf116c71b3ce87d40860f0a6c56ab1065ee98ec41634626ca961129')
|
||||
|
||||
prepare() {
|
||||
patch -d qtwebkit-$_pkgver -p1 -i ../qt5-webkit-python-3.9.patch # Fix build with python 3.9
|
||||
patch -d qtwebkit-$_pkgver -p1 -i ../qt5-webkit-bison-3.7.patch # Fix build with bison 3.7
|
||||
cd qtwebkit-$_pkgver
|
||||
patch -p0 -i ../icu68.patch # Fix build with ICU 68.x
|
||||
patch -p1 -i ../qt5-webkit-python-3.9.patch # Fix build with python 3.9
|
||||
patch -p1 -i ../qt5-webkit-bison-3.7.patch # Fix build with bison 3.7
|
||||
|
||||
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
|
||||
cd qtwebkit-$_pkgver
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
}
|
||||
|
|
170
extra/qt5-webkit/icu68.patch
Normal file
170
extra/qt5-webkit/icu68.patch
Normal file
|
@ -0,0 +1,170 @@
|
|||
Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
|
||||
|
||||
In file included from Source/WebCore/platform/text/TextAllInOne.cpp:31:
|
||||
Source/WebCore/platform/text/TextCodecICU.cpp:311:42: error: use of undeclared identifier 'TRUE'
|
||||
ucnv_setFallback(m_converterICU, TRUE);
|
||||
^
|
||||
In file included from Source/WebCore/platform/text/TextAllInOne.cpp:40:
|
||||
In file included from Source/WebCore/platform/text/icu/UTextProvider.cpp:27:
|
||||
Source/WebCore/platform/text/icu/UTextProvider.h:83:28: error: use of undeclared identifier 'TRUE'
|
||||
isAccessible = TRUE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProvider.h:88:28: error: use of undeclared identifier 'FALSE'
|
||||
isAccessible = FALSE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProvider.h:97:28: error: use of undeclared identifier 'TRUE'
|
||||
isAccessible = TRUE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProvider.h:102:28: error: use of undeclared identifier 'FALSE'
|
||||
isAccessible = FALSE;
|
||||
^
|
||||
In file included from Source/WebCore/platform/text/TextAllInOne.cpp:41:
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:103:20: error: use of undeclared identifier 'TRUE'
|
||||
return TRUE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:108:20: error: use of undeclared identifier 'FALSE'
|
||||
return FALSE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:114:20: error: use of undeclared identifier 'TRUE'
|
||||
return TRUE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:119:20: error: use of undeclared identifier 'FALSE'
|
||||
return FALSE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:147:12: error: use of undeclared identifier 'TRUE'
|
||||
return TRUE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:339:16: error: use of undeclared identifier 'FALSE'
|
||||
return FALSE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:359:12: error: use of undeclared identifier 'TRUE'
|
||||
return TRUE;
|
||||
^
|
||||
In file included from Source/WebCore/platform/text/TextAllInOne.cpp:42:
|
||||
Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp:128:16: error: use of undeclared identifier 'FALSE'
|
||||
return FALSE;
|
||||
^
|
||||
Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp:148:12: error: use of undeclared identifier 'TRUE'
|
||||
return TRUE;
|
||||
^
|
||||
|
||||
--- Source/WebCore/platform/text/TextCodecICU.cpp.orig 2020-03-04 17:16:37 UTC
|
||||
+++ Source/WebCore/platform/text/TextCodecICU.cpp
|
||||
@@ -308,7 +308,7 @@ void TextCodecICU::createICUConverter() const
|
||||
m_converterICU = ucnv_open(m_canonicalConverterName, &err);
|
||||
ASSERT(U_SUCCESS(err));
|
||||
if (m_converterICU)
|
||||
- ucnv_setFallback(m_converterICU, TRUE);
|
||||
+ ucnv_setFallback(m_converterICU, true);
|
||||
}
|
||||
|
||||
int TextCodecICU::decodeToBuffer(UChar* target, UChar* targetLimit, const char*& source, const char* sourceLimit, int32_t* offsets, bool flush, UErrorCode& err)
|
||||
--- Source/WebCore/platform/text/icu/UTextProvider.h.orig 2020-03-04 17:16:37 UTC
|
||||
+++ Source/WebCore/platform/text/icu/UTextProvider.h
|
||||
@@ -80,12 +80,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text
|
||||
// Ensure chunk offset is well formed if computed offset exceeds int32_t range.
|
||||
ASSERT(offset < std::numeric_limits<int32_t>::max());
|
||||
text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
|
||||
- isAccessible = TRUE;
|
||||
+ isAccessible = true;
|
||||
return true;
|
||||
}
|
||||
if (nativeIndex >= nativeLength && text->chunkNativeLimit == nativeLength) {
|
||||
text->chunkOffset = text->chunkLength;
|
||||
- isAccessible = FALSE;
|
||||
+ isAccessible = false;
|
||||
return true;
|
||||
}
|
||||
} else {
|
||||
@@ -94,12 +94,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text
|
||||
// Ensure chunk offset is well formed if computed offset exceeds int32_t range.
|
||||
ASSERT(offset < std::numeric_limits<int32_t>::max());
|
||||
text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
|
||||
- isAccessible = TRUE;
|
||||
+ isAccessible = true;
|
||||
return true;
|
||||
}
|
||||
if (nativeIndex <= 0 && !text->chunkNativeStart) {
|
||||
text->chunkOffset = 0;
|
||||
- isAccessible = FALSE;
|
||||
+ isAccessible = false;
|
||||
return true;
|
||||
}
|
||||
}
|
||||
--- Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp.orig 2020-03-04 17:16:37 UTC
|
||||
+++ Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
|
||||
@@ -100,23 +100,23 @@ static UBool uTextLatin1Access(UText* uText, int64_t i
|
||||
if (index < uText->chunkNativeLimit && index >= uText->chunkNativeStart) {
|
||||
// Already inside the buffer. Set the new offset.
|
||||
uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
if (index >= length && uText->chunkNativeLimit == length) {
|
||||
// Off the end of the buffer, but we can't get it.
|
||||
uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
}
|
||||
} else {
|
||||
if (index <= uText->chunkNativeLimit && index > uText->chunkNativeStart) {
|
||||
// Already inside the buffer. Set the new offset.
|
||||
uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
if (!index && !uText->chunkNativeStart) {
|
||||
// Already at the beginning; can't go any farther.
|
||||
uText->chunkOffset = 0;
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -144,7 +144,7 @@ static UBool uTextLatin1Access(UText* uText, int64_t i
|
||||
|
||||
uText->nativeIndexingLimit = uText->chunkLength;
|
||||
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
static int32_t uTextLatin1Extract(UText* uText, int64_t start, int64_t limit, UChar* dest, int32_t destCapacity, UErrorCode* status)
|
||||
@@ -336,7 +336,7 @@ static int64_t uTextLatin1ContextAwareNativeLength(UTe
|
||||
static UBool uTextLatin1ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
|
||||
{
|
||||
if (!text->context)
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
int64_t nativeLength = uTextLatin1ContextAwareNativeLength(text);
|
||||
UBool isAccessible;
|
||||
if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
|
||||
@@ -356,7 +356,7 @@ static UBool uTextLatin1ContextAwareAccess(UText* text
|
||||
ASSERT(newContext == UTextProviderContext::PriorContext);
|
||||
textLatin1ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
|
||||
}
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
static int32_t uTextLatin1ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
|
||||
--- Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp.orig 2020-03-04 17:16:37 UTC
|
||||
+++ Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
|
||||
@@ -125,7 +125,7 @@ static inline int64_t uTextUTF16ContextAwareNativeLeng
|
||||
static UBool uTextUTF16ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
|
||||
{
|
||||
if (!text->context)
|
||||
- return FALSE;
|
||||
+ return false;
|
||||
int64_t nativeLength = uTextUTF16ContextAwareNativeLength(text);
|
||||
UBool isAccessible;
|
||||
if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
|
||||
@@ -145,7 +145,7 @@ static UBool uTextUTF16ContextAwareAccess(UText* text,
|
||||
ASSERT(newContext == UTextProviderContext::PriorContext);
|
||||
textUTF16ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
|
||||
}
|
||||
- return TRUE;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
static int32_t uTextUTF16ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
|
Loading…
Reference in a new issue