extra/rust to 1.72.0-1

This commit is contained in:
Kevin Mihelich 2023-08-29 12:52:41 +00:00
parent 41ebbbf33e
commit d1198a5a84
6 changed files with 25 additions and 57 deletions

View file

@ -9,7 +9,7 @@ Subject: [PATCH] bootstrap: Change libexec dir
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
index 9cead7adc8c3..fc353c39cca1 100644
index b34a4b2dc63b..be5ecfda261a 100644
--- a/src/bootstrap/dist.rs
+++ b/src/bootstrap/dist.rs
@@ -420,7 +420,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
@ -21,7 +21,7 @@ index 9cead7adc8c3..fc353c39cca1 100644
}
let libdir_relative = builder.libdir_relative(compiler);
@@ -1078,7 +1078,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
@@ -1081,7 +1081,7 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
for dirent in fs::read_dir(cargo.parent().unwrap()).expect("read_dir") {
let dirent = dirent.expect("read dir entry");
if dirent.file_name().to_str().expect("utf8").starts_with("cargo-credential-") {
@ -31,7 +31,7 @@ index 9cead7adc8c3..fc353c39cca1 100644
}
diff --git a/src/bootstrap/tool.rs b/src/bootstrap/tool.rs
index b3791efaf58c..dd2e2eaea705 100644
index 06c031788629..b7ca91a28157 100644
--- a/src/bootstrap/tool.rs
+++ b/src/bootstrap/tool.rs
@@ -719,7 +719,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {

View file

@ -4,14 +4,14 @@ Date: Thu, 6 May 2021 20:13:31 +0200
Subject: [PATCH] cargo: Change libexec dir
---
src/cargo/util/auth.rs | 2 +-
src/cargo/util/auth/mod.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/cargo/util/auth.rs b/src/cargo/util/auth.rs
index f19acaebe080..9edc8d72cae9 100644
--- a/src/cargo/util/auth.rs
+++ b/src/cargo/util/auth.rs
@@ -826,7 +826,7 @@ fn sysroot_credential(
diff --git a/src/cargo/util/auth/mod.rs b/src/cargo/util/auth/mod.rs
index 58309964f493..f621e1d643c4 100644
--- a/src/cargo/util/auth/mod.rs
+++ b/src/cargo/util/auth/mod.rs
@@ -711,7 +711,7 @@ fn sysroot_credential(
.parent()
.and_then(|p| p.parent())
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;

View file

@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change bash-completion dir
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
index fc353c39cca1..426b1277fb23 100644
index be5ecfda261a..7ab950067eb4 100644
--- a/src/bootstrap/dist.rs
+++ b/src/bootstrap/dist.rs
@@ -1071,7 +1071,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
@@ -1074,7 +1074,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
tarball.add_file(&cargo, "bin", 0o755);
tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644);

View file

@ -24,11 +24,11 @@ targets, as things break when this is done:
4 files changed, 12 insertions(+), 3 deletions(-)
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
index 6c8c8e484f93..a5e0f7125405 100644
index f97cb3440d25..e96a8749823a 100644
--- a/compiler/rustc_session/src/config.rs
+++ b/compiler/rustc_session/src/config.rs
@@ -1989,7 +1989,7 @@ pub fn parse_target_triple(
early_error(error_format, format!("target file {path:?} does not exist"))
@@ -2169,7 +2169,7 @@ pub fn parse_target_triple(
handler.early_error(format!("target file {path:?} does not exist"))
})
}
- Some(target) => TargetTriple::TargetTriple(target),
@ -50,10 +50,10 @@ index 73e536a7e4d9..af48d437533c 100644
data_layout: "e-m:e-p:32:32-p270:32:32-p271:32:32-p272:64:64-\
f64:32:64-f80:32-n8:16:32-S128"
diff --git a/compiler/rustc_target/src/spec/mod.rs b/compiler/rustc_target/src/spec/mod.rs
index ba4b89c9ea10..bb9a28a18bb4 100644
index 2365dfaf1af8..7e92928d214d 100644
--- a/compiler/rustc_target/src/spec/mod.rs
+++ b/compiler/rustc_target/src/spec/mod.rs
@@ -2984,6 +2984,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
@@ -3205,6 +3205,15 @@ pub fn from_path(path: &Path) -> Result<Self, io::Error> {
Ok(TargetTriple::TargetJson { path_for_rustdoc: canonicalized_path, triple, contents })
}
@ -70,10 +70,10 @@ index ba4b89c9ea10..bb9a28a18bb4 100644
///
/// If this target is a path, the file name (without extension) is returned.
diff --git a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
index 9af1049b8702..f2ca57a00e3d 100644
index 2f970f87cc64..f8a5eec3ad6c 100644
--- a/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
+++ b/compiler/rustc_target/src/spec/x86_64_unknown_linux_gnu.rs
@@ -15,7 +15,7 @@ pub fn target() -> Target {
@@ -17,7 +17,7 @@ pub fn target() -> Target {
base.supports_xray = true;
Target {

View file

@ -1,27 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Fri, 4 Aug 2023 02:05:02 +0200
Subject: [PATCH] bootstrap: Unbreak building Rust 1.71.1 with 1.71.0
See: https://github.com/rust-lang/rust/issues/114444
---
src/bootstrap/config.rs | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/bootstrap/config.rs b/src/bootstrap/config.rs
index e192cda9a9a7..5721d8cf5bf6 100644
--- a/src/bootstrap/config.rs
+++ b/src/bootstrap/config.rs
@@ -1803,9 +1803,9 @@ pub fn check_build_rustc_version(&self) {
let source_version =
Version::parse(&fs::read_to_string(self.src.join("src/version")).unwrap().trim())
.unwrap();
- if !(source_version == rustc_version
- || (source_version.major == rustc_version.major
- && source_version.minor == rustc_version.minor + 1))
+ if !(source_version.major == rustc_version.major
+ && (source_version.minor == rustc_version.minor
+ || source_version.minor == rustc_version.minor + 1))
{
let prev_version = format!("{}.{}.x", source_version.major, source_version.minor - 1);
eprintln!(

View file

@ -20,7 +20,7 @@ pkgname=(
rust-src
)
epoch=1
pkgver=1.71.1
pkgver=1.72.0
pkgrel=1
pkgdesc="Systems programming language focused on safety, speed and concurrency"
url=https://www.rust-lang.org/
@ -64,16 +64,14 @@ source=(
0002-bootstrap-Change-bash-completion-dir.patch
0003-compiler-Change-LLVM-targets.patch
0004-compiler-Use-wasm-ld-for-wasm-targets.patch
0005-bootstrap-Unbreak-building-Rust-1.71.1-with-1.71.0.patch
)
b2sums=('66c155e7a96d4c21e50feebe412fec0b4f4e3f6566f249a018b439c1e1ad1d807f00bcd854fecc267120db0a6d24939e21c86f46b1b13570b6f589d10f5b83c7'
b2sums=('cb0b20523154da26ce2e8cd2e214c3e3c62a66dcf15f1615c92c2efcf3cfc2a437e8b7d582f05cc123e0450ae924aef9c28884b2579c589f9e4336f6bc1b6e70'
'SKIP'
'd6b399d094d2c546d6fc53245e640dfb70921e250035b729bedc353a342de9daed167012810a47f4a2da3e0b70e31f89eeb02915870856ef2285a50a9553f14d'
'71b3a5a5c169ad426fa0e6b6bf6ec5afa126bbe9257a617a248bc83f278a61990efac0b35d4ff5e50f0fa43db2e26071e1240526ae045a990c2441d0ecc92e9b'
'fdf2159315b96337da84b45fc49b55ea73d6d14710f3967710da4fcee6d049ef9e5bb18e438e604750f4a3af9c909e58eea143f4a3c497acb7d806f834fd3b44'
'2ecae93bc6323ef8285b590d576f8b7de385dc121317bd108e1e0863e0ef57d6bd7529564342443b182f1979d2e432a105998da61db16be8e6ea24f79c9acfcd'
'e0acea294146ae14ec18ac1f99cb9113dfe0dbe87cfd557fb093b56fc15cf036ac076af905fbe358a11a913d2fc845619c5fd8e18ac97127c232127a28666117'
'13a0d671e86a385237b69d7fda728f04c910eef20fc5c46ba5c4bc6b3defea0d5b34c6744f137c6b4e86d01ad098ac2c4dd0d9a114eb20749f18ffc5d34477ed')
'c4bf40d48fd7ccb02c73fc02d5d968cfda80d1fd85c1ade4781d174bb4cb165b52998af4bf9495f2c04b0a25b147c13a5f3de4281d621353c9e799a67297a3fe'
'0b079767043116d1e2c30ce66e82972266bc46a70b54884c0d41786c7f4271fdacb04611d34d4106a394db9df4b384b0138fa4f52c3076bfb3932d410f668b15'
'f165abb36f03bb1ddcdca8e674244e51c7ce3a6b83e59b44d520e16e3735952cdd1c6da9edca51a755b343323f6f37c7ea7093708212300974e41560d15ee6ef'
'5faa0c65de5186dd225afcb58d0d0b2fddf2f2a7008f7a7d84bf14e78a23dbf08ae04c016d3c8241359ec9eb286f5186a7ae84ce03446f37e56fc2667fa1c114'
'e0acea294146ae14ec18ac1f99cb9113dfe0dbe87cfd557fb093b56fc15cf036ac076af905fbe358a11a913d2fc845619c5fd8e18ac97127c232127a28666117')
validpgpkeys=(
108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
)
@ -95,9 +93,6 @@ prepare() {
# Use our wasm-ld
patch -Np1 -i ../0004-compiler-Use-wasm-ld-for-wasm-targets.patch
# https://github.com/rust-lang/rust/issues/114444
patch -Np1 -i ../0005-bootstrap-Unbreak-building-Rust-1.71.1-with-1.71.0.patch
cat >config.toml <<END
profile = "user"
changelog-seen = 2