extra/chromium to 53.0.2785.143-1

This commit is contained in:
Kevin Mihelich 2016-10-01 04:24:09 +00:00
parent c940ce9191
commit d14db3d797
2 changed files with 40 additions and 4 deletions

View file

@ -19,7 +19,7 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=53.0.2785.116
pkgver=53.0.2785.143
pkgrel=1
_launcher_ver=3
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
@ -41,14 +41,16 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
chromium-widevine.patch
chromium-52.0.2743.116-unset-madv_free.patch
chromium-cups-2.2.patch
chromium-widevine.patch
0001-system-ffmpeg-fixes.patch)
sha256sums=('7a87629504346f64122ca7754574d187a4c1bf5736dea672ff3e247a0af16062'
sha256sums=('c52a58b79bfb27bb87e4a0a6ff213001485fbc747657b290f75d39ddce07dcc3'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
'3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
'6519cf913cb68e2def1bbf9210ef40a178b45bc9d325297c41b7a784ff57cc8e'
'4a8907651ea25dd7753566799bea28b74b8cd512d3cbc40c34b6d9a43cb36e22')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -85,7 +87,10 @@ prepare() {
# Disable MADV_FREE (if set by glibc)
# https://bugzilla.redhat.com/show_bug.cgi?id=1361157
patch -p1 -i "$srcdir"/chromium-52.0.2743.116-unset-madv_free.patch
patch -Np1 -i ../chromium-52.0.2743.116-unset-madv_free.patch
# Fix compiling with CUPS 2.2 backend
patch -Np0 -i ../chromium-cups-2.2.patch
[[ $CARCH == "armv7h" ]] && MAKEFLAGS=-j4

View file

@ -0,0 +1,31 @@
commit 5132ca58a0a3ada1aee99732fd30d53ebe5af984
author saiarcot895 <saiarcot895@gmail.com> Mon Aug 22 18:41:54 2016
committer Commit bot <commit-bot@chromium.org> Mon Aug 22 18:44:13 2016
tree b4783f1c90f2fdb001843ad83463e260de9b292c
parent da7b21cac1ded0c70cb330e4f76a1f7915e38ccf
Fix compiling with CUPS 2.2 backend.
cupsGetPPD() and cupsGetPPD2() have been moved into the cups/ppd.h
header starting with CUPS 2.2. This header file now needs to be included
to use these functions. The header file also exists on older versions of
CUPS, so a compile error will not occur.
R=skau@chromium.org, thestig@chromium.org
Review-Url: https://codereview.chromium.org/2258333004
Cr-Commit-Position: refs/heads/master@{#413484}
diff --git printing/backend/cups_helper.h printing/backend/cups_helper.h
index fd7601d..b72903f 100644
--- printing/backend/cups_helper.h
+++ printing/backend/cups_helper.h
@@ -6,6 +6,7 @@
#define PRINTING_BACKEND_CUPS_HELPER_H_
#include <cups/cups.h>
+#include <cups/ppd.h>
#include "base/strings/string_piece.h"
#include "printing/printing_export.h"