extra/couchdb to 3.3.2-1

This commit is contained in:
Kevin Mihelich 2023-06-29 03:20:01 +00:00
parent 653d99c833
commit d1b6bbd0ed
5 changed files with 70 additions and 14 deletions

View file

@ -7,8 +7,8 @@
# - patch to fix aarch64 js check, disable LTO
pkgname=couchdb
pkgver=3.2.2
pkgrel=5
pkgver=3.3.2
pkgrel=1
pkgdesc="Document-oriented database that can be queried and indexed in a MapReduce fashion using JSON"
arch=(x86_64)
url="https://couchdb.apache.org"
@ -16,24 +16,24 @@ license=(Apache)
depends=(icu js91 zlib)
optdepends=('erlang-nox: for weatherreport')
makedepends=(erlang-nox)
options=(!makeflags)
backup=(etc/couchdb/local.ini
etc/couchdb/vm.args
etc/default/couchdb)
options=(debug)
source=("https://archive.apache.org/dist/${pkgname}/source/${pkgver}/apache-${pkgname}-${pkgver}.tar.gz"{,.asc}
https://github.com/davisp/jiffy/archive/1.1.1/jiffy-1.1.1.tar.gz
erlang-25.patch
erlang-25-snappy.patch
erlang-26.patch
erlang-26-compatibilty.patch
couchdb.default
couchdb.service
couchdb.sysusers
couchdb.tmpfiles
arm.patch)
sha256sums=('69c9fd6f80133557f68a02e92dda72a4fd646d646f429f45bb8329a30f82f20e'
sha256sums=('3d6823d42d10cf0d4f86c9c4fe59c9932c89d68578fcb6c4b4278dc769308daa'
'SKIP'
'a999351d956d3ed10c33a6dd7e9435e674e519b5b82a46d60361afdb83062fd8'
'59a8a92200321f670f20746848fcadae35d1818f6bdacbedaf49012866dcfc27'
'8a74ae8cc5c5a54cd0a65f7aeed55af257eef8912630b953bfeb8d9329228b4b'
'06782fccf44ad0463f55f0d9edc03c3ba05958471811bc38c1a155d322e09fa5'
'ec18cdf8b0e7287db0467385797b5fe11f17701ab10df631cb74b6e56099bf5e'
'0d21fdd7851b3a6fa099b030cab0e96705b1d5a3a83a4ff1c871814d8742cae9'
'6ab3d362f3fcd9079036c883dc09dc597584cb627831460f2e0c68a31aa052ae'
'3ed1ad2a37a068ce194b03fb72eb35285d60fa7faf2d2c2bb710703d229108a8'
@ -55,15 +55,18 @@ prepare() {
rm -r src/jiffy
mv ../jiffy-1.1.1 src/jiffy
patch -Np1 <../erlang-25.patch
patch -Np1 -d src/snappy <../erlang-25-snappy.patch
patch -Np1 <../erlang-26.patch
# make it compile against erlang 26
# part of https://github.com/apache/couchdb/pull/4581
patch -Np1 <../erlang-26-compatibilty.patch
patch -p1 -i ../arm.patch
}
build() {
cd apache-couchdb-${pkgver}
./configure --spidermonkey-version 91
./configure --spidermonkey-version 91 #--help
make release
}
@ -82,7 +85,7 @@ package() {
install -Dm644 ${pkgname}.sysusers "${pkgdir}"/usr/lib/sysusers.d/${pkgname}.conf
# Remove some cruft
rm -r "${pkgdir}"/usr/lib/couchdb/erts-13.1.1/{doc,include,lib,man,src}
rm -r "${pkgdir}"/usr/lib/couchdb/erts-14.0.1/{doc,include,lib,man,src}
rm -rv "${pkgdir}"/usr/lib/couchdb/etc/
rm -rv "${pkgdir}"/usr/lib/couchdb/lib/couch-${pkgver}/priv/couch_{ejson_compare,js}
}

View file

@ -13,7 +13,7 @@ index a6a3b70..3b93f8a 100644
+++ b/rebar.config
@@ -1,4 +1,4 @@
-{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22|23|24"}.
+{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22|23|24|25"}.
+{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22|23|24|25|26"}.
{erl_opts, [debug_info, warn_unused_vars, warn_shadow_vars, warn_unused_import]}.
{port_sources, ["c_src/*.cc",

View file

@ -17,7 +17,7 @@ index 31855098b3..44c4d61b1a 100644
AddConfig = [
- {require_otp_vsn, "20|21|22|23|24"},
+ {require_otp_vsn, "20|21|22|23|24|25"},
+ {require_otp_vsn, "20|21|22|23|24|25|26"},
{deps_dir, "src"},
{deps, lists:map(MakeDep, DepDescs ++ OptionalDeps)},
{sub_dirs, SubDirs},

View file

@ -0,0 +1,22 @@
From a4bbb87d11d40dfee9808a7d5025a65845c6a4cd Mon Sep 17 00:00:00 2001
From: Jay Doane <jaydoane@apache.org>
Date: Thu, 13 Apr 2023 15:37:48 -0700
Subject: [PATCH] Remove excl_archive_filters
This parameter has been eliminated in OTP 26.
---
rel/reltool.config | 1 -
1 file changed, 1 deletion(-)
diff --git a/rel/reltool.config b/rel/reltool.config
index 41d45ef419..d84ef597c7 100644
--- a/rel/reltool.config
+++ b/rel/reltool.config
@@ -73,7 +73,6 @@
{boot_rel, "couchdb"},
{profile, embedded},
{excl_sys_filters, ["^bin/.*", "^erts.*/bin/(dialyzer|typer)"]},
- {excl_archive_filters, [".*"]},
{incl_cond, exclude},
%% stdlib

View file

@ -0,0 +1,31 @@
From 592837abc8b07f9b28898fa91c31658e2beecfc4 Mon Sep 17 00:00:00 2001
From: Ronny Berndt <ronny@apache.org>
Date: Sat, 11 Jun 2022 14:18:54 +0200
Subject: [PATCH] Add Erlang 25 support
Before merging this PR, PR #16 in couchdb-snappy needs to get merged and tagged with CouchDB-1.0.8
---
rebar.config.script | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/rebar.config.script b/rebar.config.script
index 31855098b3..44c4d61b1a 100644
--- a/rebar.config.script
+++ b/rebar.config.script
@@ -186,7 +186,7 @@
AddConfig = [
{cover_enabled, true},
{cover_print_enabled, true},
- {require_otp_vsn, "23|24|25"},
+ {require_otp_vsn, "23|24|25|26"},
{deps_dir, "src"},
{deps, lists:map(MakeDep, DepDescs ++ OptionalDeps)},
{sub_dirs, SubDirs},
--- apache-couchdb-3.3.2/src/snappy/rebar.config 2023-06-27 16:23:39.000000000 +0200
+++ apache-couchdb-3.3.2/src/snappy/rebar.config.new 2023-06-27 16:35:58.371758506 +0200
@@ -1,4 +1,4 @@
-{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22|23|24|25"}.
+{require_otp_vsn, "R14|R15|R16|17|18|19|20|21|22|23|24|25|26"}.
{erl_opts, [debug_info, warn_unused_vars, warn_shadow_vars, warn_unused_import]}.
{port_sources, ["c_src/*.cc",