extra/webkit2gtk to 2.18.4-1

This commit is contained in:
Kevin Mihelich 2017-12-20 06:23:03 +00:00
parent 78ffb51858
commit d22a389838
4 changed files with 49 additions and 99 deletions

View file

@ -8,8 +8,8 @@
highmem=1
pkgname=webkit2gtk
pkgver=2.18.3
pkgrel=3
pkgver=2.18.4
pkgrel=1
pkgdesc="GTK+ Web content engine library"
arch=(x86_64)
url="https://webkitgtk.org/"
@ -22,9 +22,11 @@ optdepends=('gtk2: Netscape plugin support'
'gst-plugins-good: media decoding'
'gst-libav: nonfree media decoding')
source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc}
gtkdoc.patch
remove_atomics.patch)
sha256sums=('e15420e1616a6f70f321541d467af5ca285bff66b1e0fa68a01df3ccf1b18f9e'
sha256sums=('87b6bb9a6065b949ecbe6191313c43e57ad28efdf1f2b5e763405093520632b8'
'SKIP'
'283c21a81bf743a31def6f5e7889fb919c818314d911cbc86945eb604ba9fcb6'
'410449817b1b181737538be10d96d6d8aec134285f6288e80c96fbfdd5d19519')
validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
@ -32,8 +34,8 @@ prepare() {
mkdir build
cd webkitgtk-$pkgver
sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
rm -r Source/ThirdParty/gtest
# GTK-Doc 1.27
patch -Np1 -i ../gtkdoc.patch
if [[ $CARCH == "arm" || $CARCH == "armv6h" ]]; then
patch -p0 -i ../remove_atomics.patch
@ -46,10 +48,17 @@ build() {
# do not use LLINT assembly for v5/v6
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && CONFIG="-DENABLE_JIT=OFF"
cmake -G Ninja -DPORT=GTK -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/lib/webkit2gtk-4.0 \
-DENABLE_GTKDOC=ON -DPYTHON_EXECUTABLE=/usr/bin/python2 $CONFIG ../webkitgtk-$pkgver
cmake \
-G Ninja \
-DPORT=GTK \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_RPATH=ON \
-DENABLE_GTKDOC=ON \
-DLIBEXEC_INSTALL_DIR=/usr/lib \
-DLIB_INSTALL_DIR=/usr/lib \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
$CONFIG ../webkitgtk-$pkgver
ninja
}
@ -57,9 +66,11 @@ package() {
cd build
DESTDIR="$pkgdir" ninja install
cd ../webkitgtk-$pkgver/Source
while IFS= read -d $'\0' -r _f; do
echo "### $_f ###"; cat "$_f"; echo
done < <(find . -name 'COPYING*' -or -name 'LICENSE*' -print0) \
| install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd ../webkitgtk-$pkgver
find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | while IFS= read -d $'\0' -r _f
do
echo "### $_f ###"
cat "$_f"
echo
done | install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

View file

@ -1,47 +0,0 @@
diff -u -r webkitgtk-2.16.5/Source/cmake/OptionsCommon.cmake webkitgtk-2.16.5-gcc7/Source/cmake/OptionsCommon.cmake
--- webkitgtk-2.16.5/Source/cmake/OptionsCommon.cmake 2017-05-06 10:48:27.000000000 +0200
+++ webkitgtk-2.16.5-gcc7/Source/cmake/OptionsCommon.cmake 2017-06-27 13:15:26.858090686 +0200
@@ -38,7 +38,9 @@
define_property(TARGET PROPERTY FOLDER INHERITED BRIEF_DOCS "folder" FULL_DOCS "IDE folder name")
if (COMPILER_IS_GCC_OR_CLANG)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-expansion-to-defined -Wno-implicit-fallthrough")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fno-exceptions -fno-strict-aliasing")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-expansion-to-defined -Wno-implicit-fallthrough")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-exceptions -fno-strict-aliasing -fno-rtti")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y")
endif ()
diff -u -r webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h
--- webkitgtk-2.16.5/Source/WTF/wtf/text/StringImpl.h 2017-02-20 17:20:15.000000000 +0100
+++ webkitgtk-2.16.5-gcc7/Source/WTF/wtf/text/StringImpl.h 2017-06-27 13:13:57.801527350 +0200
@@ -581,29 +581,7 @@
// FIXME: Does this really belong in StringImpl?
template <typename T> static void copyChars(T* destination, const T* source, unsigned numCharacters)
{
- if (numCharacters == 1) {
- *destination = *source;
- return;
- }
-
- if (numCharacters <= s_copyCharsInlineCutOff) {
- unsigned i = 0;
-#if (CPU(X86) || CPU(X86_64))
- const unsigned charsPerInt = sizeof(uint32_t) / sizeof(T);
-
- if (numCharacters > charsPerInt) {
- unsigned stopCount = numCharacters & ~(charsPerInt - 1);
-
- const uint32_t* srcCharacters = reinterpret_cast<const uint32_t*>(source);
- uint32_t* destCharacters = reinterpret_cast<uint32_t*>(destination);
- for (unsigned j = 0; i < stopCount; i += charsPerInt, ++j)
- destCharacters[j] = srcCharacters[j];
- }
-#endif
- for (; i < numCharacters; ++i)
- destination[i] = source[i];
- } else
- memcpy(destination, source, numCharacters * sizeof(T));
+ memcpy(destination, source, numCharacters * sizeof(T));
}
ALWAYS_INLINE static void copyChars(UChar* destination, const LChar* source, unsigned numCharacters)

View file

@ -0,0 +1,24 @@
diff -u -r webkitgtk-2.18.4/Tools/gtk/generate-gtkdoc webkitgtk-2.18.4-gtkdoc/Tools/gtk/generate-gtkdoc
--- webkitgtk-2.18.4/Tools/gtk/generate-gtkdoc 2017-12-18 18:36:59.000000000 +0100
+++ webkitgtk-2.18.4-gtkdoc/Tools/gtk/generate-gtkdoc 2017-12-20 02:52:09.008775941 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/env python2
# Copyright (C) 2011 Igalia S.L.
#
# This library is free software; you can redistribute it and/or
diff -u -r webkitgtk-2.18.4/Tools/gtk/gtkdoc.py webkitgtk-2.18.4-gtkdoc/Tools/gtk/gtkdoc.py
--- webkitgtk-2.18.4/Tools/gtk/gtkdoc.py 2017-08-09 11:13:53.000000000 +0200
+++ webkitgtk-2.18.4-gtkdoc/Tools/gtk/gtkdoc.py 2017-12-20 02:52:00.722090939 +0100
@@ -319,9 +319,9 @@
ldflags = ' "-L%s" %s ' % (self.library_path, additional_ldflags) + ldflags
current_ld_library_path = env.get('LD_LIBRARY_PATH')
if current_ld_library_path:
- env['RUN'] = 'LD_LIBRARY_PATH="%s:%s" ' % (self.library_path, current_ld_library_path)
+ env['RUN'] = 'env LD_LIBRARY_PATH="%s:%s" ' % (self.library_path, current_ld_library_path)
else:
- env['RUN'] = 'LD_LIBRARY_PATH="%s" ' % self.library_path
+ env['RUN'] = 'env LD_LIBRARY_PATH="%s" ' % self.library_path
if ldflags:
env['LDFLAGS'] = '%s %s' % (ldflags, env.get('LDFLAGS', ''))

View file

@ -1,38 +0,0 @@
--- webkitgtk-2.16.1/Source/JavaScriptCore/API/JSStringRef.h.orig 2017-02-20 17:20:08.000000000 +0100
+++ webkitgtk-2.16.1/Source/JavaScriptCore/API/JSStringRef.h 2017-04-22 14:35:00.926530142 +0200
@@ -32,6 +32,7 @@
#include <stdbool.h>
#endif
#include <stddef.h> /* for size_t */
+#include <uchar.h>
#ifdef __cplusplus
extern "C" {
@@ -46,7 +47,7 @@
character. As with all scalar types, endianness depends on the underlying
architecture.
*/
- typedef unsigned short JSChar;
+ typedef char16_t JSChar;
#else
typedef wchar_t JSChar;
#endif
--- webkitgtk-2.16.1/Source/WebKit2/Shared/API/c/WKString.h.orig 2017-02-20 17:20:17.000000000 +0100
+++ webkitgtk-2.16.1/Source/WebKit2/Shared/API/c/WKString.h 2017-04-22 14:35:56.853196170 +0200
@@ -28,6 +28,7 @@
#include <WebKit/WKBase.h>
#include <stddef.h>
+#include <uchar.h>
#ifndef __cplusplus
#include <stdbool.h>
@@ -39,7 +40,7 @@
#if !defined(WIN32) && !defined(_WIN32) \
&& !((defined(__CC_ARM) || defined(__ARMCC__)) && !defined(__linux__)) /* RVCT */
- typedef unsigned short WKChar;
+ typedef char16_t WKChar;
#else
typedef wchar_t WKChar;
#endif