mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-imx6 to 3.14.79-2
This commit is contained in:
parent
f4d7865442
commit
d239d39939
6 changed files with 539 additions and 10 deletions
|
@ -1,7 +1,7 @@
|
|||
From 5d77ba2d26110c678b40fd723866a17d4036de12 Mon Sep 17 00:00:00 2001
|
||||
From d1c07c41c09fb7219b6cd930100f098ed7ab2197 Mon Sep 17 00:00:00 2001
|
||||
From: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||
Date: Tue, 18 Feb 2014 02:19:26 -0300
|
||||
Subject: [PATCH 1/6] Bluetooth: allocate static minor for vhci
|
||||
Subject: [PATCH 1/5] Bluetooth: allocate static minor for vhci
|
||||
|
||||
Commit bfacbb9 (Bluetooth: Use devname:vhci module alias for virtual HCI
|
||||
driver) added the module alias to hci_vhci module so it's possible to
|
||||
|
@ -28,7 +28,7 @@ Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
|
|||
3 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Documentation/devices.txt b/Documentation/devices.txt
|
||||
index 10378cc..04356f5 100644
|
||||
index 10378cc48374..04356f5bc3af 100644
|
||||
--- a/Documentation/devices.txt
|
||||
+++ b/Documentation/devices.txt
|
||||
@@ -353,6 +353,7 @@ Your cooperation is appreciated.
|
||||
|
@ -40,10 +40,10 @@ index 10378cc..04356f5 100644
|
|||
140 = /dev/relay8 Berkshire Products Octal relay card
|
||||
141 = /dev/relay16 Berkshire Products ISO-16 relay card
|
||||
diff --git a/drivers/bluetooth/hci_vhci.c b/drivers/bluetooth/hci_vhci.c
|
||||
index 1ef6990..add1c6a 100644
|
||||
index bbe6643e299d..b9c96a98e8f4 100644
|
||||
--- a/drivers/bluetooth/hci_vhci.c
|
||||
+++ b/drivers/bluetooth/hci_vhci.c
|
||||
@@ -359,7 +359,7 @@ static const struct file_operations vhci_fops = {
|
||||
@@ -360,7 +360,7 @@ static const struct file_operations vhci_fops = {
|
||||
static struct miscdevice vhci_miscdev= {
|
||||
.name = "vhci",
|
||||
.fops = &vhci_fops,
|
||||
|
@ -52,13 +52,13 @@ index 1ef6990..add1c6a 100644
|
|||
};
|
||||
|
||||
static int __init vhci_init(void)
|
||||
@@ -385,3 +385,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
|
||||
@@ -386,3 +386,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
|
||||
MODULE_VERSION(VERSION);
|
||||
MODULE_LICENSE("GPL");
|
||||
MODULE_ALIAS("devname:vhci");
|
||||
+MODULE_ALIAS_MISCDEV(VHCI_MINOR);
|
||||
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
|
||||
index 3737f72..7bb6148 100644
|
||||
index 3737f7218f51..7bb6148d990f 100644
|
||||
--- a/include/linux/miscdevice.h
|
||||
+++ b/include/linux/miscdevice.h
|
||||
@@ -23,6 +23,7 @@
|
||||
|
@ -70,5 +70,5 @@ index 3737f72..7bb6148 100644
|
|||
#define DMAPI_MINOR 140 /* DMAPI */
|
||||
#define NVRAM_MINOR 144
|
||||
--
|
||||
1.9.1
|
||||
2.12.2
|
||||
|
||||
|
|
|
@ -0,0 +1,98 @@
|
|||
From 5b3c92a29bbbcfe5a1ef24422a6b0ff5025b488c Mon Sep 17 00:00:00 2001
|
||||
From: Greg Price <price@MIT.EDU>
|
||||
Date: Fri, 29 Nov 2013 15:02:33 -0500
|
||||
Subject: [PATCH 2/5] random: simplify loop in random_read
|
||||
|
||||
The loop condition never changes until just before a break, so we
|
||||
might as well write it as a constant. Also since a996996dd75a
|
||||
("random: drop weird m_time/a_time manipulation") we don't do anything
|
||||
after the loop finishes, so the 'break's might as well return
|
||||
directly. Some other simplifications.
|
||||
|
||||
There should be no change in behavior introduced by this commit.
|
||||
|
||||
Signed-off-by: Greg Price <price@mit.edu>
|
||||
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
|
||||
---
|
||||
drivers/char/random.c | 57 ++++++++++++++++-----------------------------------
|
||||
1 file changed, 18 insertions(+), 39 deletions(-)
|
||||
|
||||
diff --git a/drivers/char/random.c b/drivers/char/random.c
|
||||
index a35a605c418a..b3b5e036087b 100644
|
||||
--- a/drivers/char/random.c
|
||||
+++ b/drivers/char/random.c
|
||||
@@ -1287,53 +1287,32 @@ void rand_initialize_disk(struct gendisk *disk)
|
||||
static ssize_t
|
||||
random_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
{
|
||||
- ssize_t n, retval = 0, count = 0;
|
||||
+ ssize_t n;
|
||||
|
||||
if (nbytes == 0)
|
||||
return 0;
|
||||
|
||||
- while (nbytes > 0) {
|
||||
- n = nbytes;
|
||||
- if (n > SEC_XFER_SIZE)
|
||||
- n = SEC_XFER_SIZE;
|
||||
-
|
||||
- n = extract_entropy_user(&blocking_pool, buf, n);
|
||||
-
|
||||
- if (n < 0) {
|
||||
- retval = n;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
+ nbytes = min_t(size_t, nbytes, SEC_XFER_SIZE);
|
||||
+ while (1) {
|
||||
+ n = extract_entropy_user(&blocking_pool, buf, nbytes);
|
||||
+ if (n < 0)
|
||||
+ return n;
|
||||
trace_random_read(n*8, (nbytes-n)*8,
|
||||
ENTROPY_BITS(&blocking_pool),
|
||||
ENTROPY_BITS(&input_pool));
|
||||
-
|
||||
- if (n == 0) {
|
||||
- if (file->f_flags & O_NONBLOCK) {
|
||||
- retval = -EAGAIN;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- wait_event_interruptible(random_read_wait,
|
||||
- ENTROPY_BITS(&input_pool) >=
|
||||
- random_read_wakeup_thresh);
|
||||
-
|
||||
- if (signal_pending(current)) {
|
||||
- retval = -ERESTARTSYS;
|
||||
- break;
|
||||
- }
|
||||
-
|
||||
- continue;
|
||||
- }
|
||||
-
|
||||
- count += n;
|
||||
- buf += n;
|
||||
- nbytes -= n;
|
||||
- break; /* This break makes the device work */
|
||||
- /* like a named pipe */
|
||||
+ if (n > 0)
|
||||
+ return n;
|
||||
+ /* Pool is (near) empty. Maybe wait and retry. */
|
||||
+
|
||||
+ if (file->f_flags & O_NONBLOCK)
|
||||
+ return -EAGAIN;
|
||||
+
|
||||
+ wait_event_interruptible(random_read_wait,
|
||||
+ ENTROPY_BITS(&input_pool) >=
|
||||
+ random_read_wakeup_thresh);
|
||||
+ if (signal_pending(current))
|
||||
+ return -ERESTARTSYS;
|
||||
}
|
||||
-
|
||||
- return (count ? count : retval);
|
||||
}
|
||||
|
||||
static ssize_t
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -0,0 +1,328 @@
|
|||
From db593c29763d57807dd66397795631f2d0b6afff Mon Sep 17 00:00:00 2001
|
||||
From: Theodore Ts'o <tytso@mit.edu>
|
||||
Date: Thu, 17 Jul 2014 04:13:05 -0400
|
||||
Subject: [PATCH 3/5] random: introduce getrandom(2) system call
|
||||
|
||||
The getrandom(2) system call was requested by the LibreSSL Portable
|
||||
developers. It is analoguous to the getentropy(2) system call in
|
||||
OpenBSD.
|
||||
|
||||
The rationale of this system call is to provide resiliance against
|
||||
file descriptor exhaustion attacks, where the attacker consumes all
|
||||
available file descriptors, forcing the use of the fallback code where
|
||||
/dev/[u]random is not available. Since the fallback code is often not
|
||||
well-tested, it is better to eliminate this potential failure mode
|
||||
entirely.
|
||||
|
||||
The other feature provided by this new system call is the ability to
|
||||
request randomness from the /dev/urandom entropy pool, but to block
|
||||
until at least 128 bits of entropy has been accumulated in the
|
||||
/dev/urandom entropy pool. Historically, the emphasis in the
|
||||
/dev/urandom development has been to ensure that urandom pool is
|
||||
initialized as quickly as possible after system boot, and preferably
|
||||
before the init scripts start execution.
|
||||
|
||||
This is because changing /dev/urandom reads to block represents an
|
||||
interface change that could potentially break userspace which is not
|
||||
acceptable. In practice, on most x86 desktop and server systems, in
|
||||
general the entropy pool can be initialized before it is needed (and
|
||||
in modern kernels, we will printk a warning message if not). However,
|
||||
on an embedded system, this may not be the case. And so with this new
|
||||
interface, we can provide the functionality of blocking until the
|
||||
urandom pool has been initialized. Any userspace program which uses
|
||||
this new functionality must take care to assure that if it is used
|
||||
during the boot process, that it will not cause the init scripts or
|
||||
other portions of the system startup to hang indefinitely.
|
||||
|
||||
SYNOPSIS
|
||||
#include <linux/random.h>
|
||||
|
||||
int getrandom(void *buf, size_t buflen, unsigned int flags);
|
||||
|
||||
DESCRIPTION
|
||||
The system call getrandom() fills the buffer pointed to by buf
|
||||
with up to buflen random bytes which can be used to seed user
|
||||
space random number generators (i.e., DRBG's) or for other
|
||||
cryptographic uses. It should not be used for Monte Carlo
|
||||
simulations or other programs/algorithms which are doing
|
||||
probabilistic sampling.
|
||||
|
||||
If the GRND_RANDOM flags bit is set, then draw from the
|
||||
/dev/random pool instead of the /dev/urandom pool. The
|
||||
/dev/random pool is limited based on the entropy that can be
|
||||
obtained from environmental noise, so if there is insufficient
|
||||
entropy, the requested number of bytes may not be returned.
|
||||
If there is no entropy available at all, getrandom(2) will
|
||||
either block, or return an error with errno set to EAGAIN if
|
||||
the GRND_NONBLOCK bit is set in flags.
|
||||
|
||||
If the GRND_RANDOM bit is not set, then the /dev/urandom pool
|
||||
will be used. Unlike using read(2) to fetch data from
|
||||
/dev/urandom, if the urandom pool has not been sufficiently
|
||||
initialized, getrandom(2) will block (or return -1 with the
|
||||
errno set to EAGAIN if the GRND_NONBLOCK bit is set in flags).
|
||||
|
||||
The getentropy(2) system call in OpenBSD can be emulated using
|
||||
the following function:
|
||||
|
||||
int getentropy(void *buf, size_t buflen)
|
||||
{
|
||||
int ret;
|
||||
|
||||
if (buflen > 256)
|
||||
goto failure;
|
||||
ret = getrandom(buf, buflen, 0);
|
||||
if (ret < 0)
|
||||
return ret;
|
||||
if (ret == buflen)
|
||||
return 0;
|
||||
failure:
|
||||
errno = EIO;
|
||||
return -1;
|
||||
}
|
||||
|
||||
RETURN VALUE
|
||||
On success, the number of bytes that was filled in the buf is
|
||||
returned. This may not be all the bytes requested by the
|
||||
caller via buflen if insufficient entropy was present in the
|
||||
/dev/random pool, or if the system call was interrupted by a
|
||||
signal.
|
||||
|
||||
On error, -1 is returned, and errno is set appropriately.
|
||||
|
||||
ERRORS
|
||||
EINVAL An invalid flag was passed to getrandom(2)
|
||||
|
||||
EFAULT buf is outside the accessible address space.
|
||||
|
||||
EAGAIN The requested entropy was not available, and
|
||||
getentropy(2) would have blocked if the
|
||||
GRND_NONBLOCK flag was not set.
|
||||
|
||||
EINTR While blocked waiting for entropy, the call was
|
||||
interrupted by a signal handler; see the description
|
||||
of how interrupted read(2) calls on "slow" devices
|
||||
are handled with and without the SA_RESTART flag
|
||||
in the signal(7) man page.
|
||||
|
||||
NOTES
|
||||
For small requests (buflen <= 256) getrandom(2) will not
|
||||
return EINTR when reading from the urandom pool once the
|
||||
entropy pool has been initialized, and it will return all of
|
||||
the bytes that have been requested. This is the recommended
|
||||
way to use getrandom(2), and is designed for compatibility
|
||||
with OpenBSD's getentropy() system call.
|
||||
|
||||
However, if you are using GRND_RANDOM, then getrandom(2) may
|
||||
block until the entropy accounting determines that sufficient
|
||||
environmental noise has been gathered such that getrandom(2)
|
||||
will be operating as a NRBG instead of a DRBG for those people
|
||||
who are working in the NIST SP 800-90 regime. Since it may
|
||||
block for a long time, these guarantees do *not* apply. The
|
||||
user may want to interrupt a hanging process using a signal,
|
||||
so blocking until all of the requested bytes are returned
|
||||
would be unfriendly.
|
||||
|
||||
For this reason, the user of getrandom(2) MUST always check
|
||||
the return value, in case it returns some error, or if fewer
|
||||
bytes than requested was returned. In the case of
|
||||
!GRND_RANDOM and small request, the latter should never
|
||||
happen, but the careful userspace code (and all crypto code
|
||||
should be careful) should check for this anyway!
|
||||
|
||||
Finally, unless you are doing long-term key generation (and
|
||||
perhaps not even then), you probably shouldn't be using
|
||||
GRND_RANDOM. The cryptographic algorithms used for
|
||||
/dev/urandom are quite conservative, and so should be
|
||||
sufficient for all purposes. The disadvantage of GRND_RANDOM
|
||||
is that it can block, and the increased complexity required to
|
||||
deal with partially fulfilled getrandom(2) requests.
|
||||
|
||||
Signed-off-by: Theodore Ts'o <tytso@mit.edu>
|
||||
Reviewed-by: Zach Brown <zab@zabbo.net>
|
||||
---
|
||||
arch/x86/syscalls/syscall_32.tbl | 1 +
|
||||
arch/x86/syscalls/syscall_64.tbl | 1 +
|
||||
drivers/char/random.c | 40 ++++++++++++++++++++++++++++++++++++---
|
||||
include/linux/syscalls.h | 3 +++
|
||||
include/uapi/asm-generic/unistd.h | 4 +++-
|
||||
include/uapi/linux/random.h | 9 +++++++++
|
||||
6 files changed, 54 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/arch/x86/syscalls/syscall_32.tbl b/arch/x86/syscalls/syscall_32.tbl
|
||||
index 96bc506ac6de..c6272a3744a8 100644
|
||||
--- a/arch/x86/syscalls/syscall_32.tbl
|
||||
+++ b/arch/x86/syscalls/syscall_32.tbl
|
||||
@@ -359,3 +359,4 @@
|
||||
350 i386 finit_module sys_finit_module
|
||||
351 i386 sched_setattr sys_sched_setattr
|
||||
352 i386 sched_getattr sys_sched_getattr
|
||||
+355 i386 getrandom sys_getrandom
|
||||
diff --git a/arch/x86/syscalls/syscall_64.tbl b/arch/x86/syscalls/syscall_64.tbl
|
||||
index 7f517ca19d32..32c5f16118a7 100644
|
||||
--- a/arch/x86/syscalls/syscall_64.tbl
|
||||
+++ b/arch/x86/syscalls/syscall_64.tbl
|
||||
@@ -322,6 +322,7 @@
|
||||
313 common finit_module sys_finit_module
|
||||
314 common sched_setattr sys_sched_setattr
|
||||
315 common sched_getattr sys_sched_getattr
|
||||
+318 common getrandom sys_getrandom
|
||||
|
||||
#
|
||||
# x32-specific system call numbers start at 512 to avoid cache impact
|
||||
diff --git a/drivers/char/random.c b/drivers/char/random.c
|
||||
index b3b5e036087b..a3150a06dbba 100644
|
||||
--- a/drivers/char/random.c
|
||||
+++ b/drivers/char/random.c
|
||||
@@ -257,6 +257,8 @@
|
||||
#include <linux/kmemcheck.h>
|
||||
#include <linux/workqueue.h>
|
||||
#include <linux/irq.h>
|
||||
+#include <linux/syscalls.h>
|
||||
+#include <linux/completion.h>
|
||||
|
||||
#include <asm/processor.h>
|
||||
#include <asm/uaccess.h>
|
||||
@@ -401,6 +403,7 @@ static struct poolinfo {
|
||||
*/
|
||||
static DECLARE_WAIT_QUEUE_HEAD(random_read_wait);
|
||||
static DECLARE_WAIT_QUEUE_HEAD(random_write_wait);
|
||||
+static DECLARE_WAIT_QUEUE_HEAD(urandom_init_wait);
|
||||
static struct fasync_struct *fasync;
|
||||
|
||||
/**********************************************************************
|
||||
@@ -657,6 +660,7 @@ retry:
|
||||
r->entropy_total = 0;
|
||||
if (r == &nonblocking_pool) {
|
||||
prandom_reseed_late();
|
||||
+ wake_up_interruptible(&urandom_init_wait);
|
||||
pr_notice("random: %s pool is initialized\n", r->name);
|
||||
}
|
||||
}
|
||||
@@ -1137,13 +1141,14 @@ static ssize_t extract_entropy_user(struct entropy_store *r, void __user *buf,
|
||||
{
|
||||
ssize_t ret = 0, i;
|
||||
__u8 tmp[EXTRACT_SIZE];
|
||||
+ int large_request = (nbytes > 256);
|
||||
|
||||
trace_extract_entropy_user(r->name, nbytes, ENTROPY_BITS(r), _RET_IP_);
|
||||
xfer_secondary_pool(r, nbytes);
|
||||
nbytes = account(r, nbytes, 0, 0);
|
||||
|
||||
while (nbytes) {
|
||||
- if (need_resched()) {
|
||||
+ if (large_request && need_resched()) {
|
||||
if (signal_pending(current)) {
|
||||
if (ret == 0)
|
||||
ret = -ERESTARTSYS;
|
||||
@@ -1285,7 +1290,7 @@ void rand_initialize_disk(struct gendisk *disk)
|
||||
#endif
|
||||
|
||||
static ssize_t
|
||||
-random_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
+_random_read(int nonblock, char __user *buf, size_t nbytes)
|
||||
{
|
||||
ssize_t n;
|
||||
|
||||
@@ -1304,7 +1309,7 @@ random_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
return n;
|
||||
/* Pool is (near) empty. Maybe wait and retry. */
|
||||
|
||||
- if (file->f_flags & O_NONBLOCK)
|
||||
+ if (nonblock)
|
||||
return -EAGAIN;
|
||||
|
||||
wait_event_interruptible(random_read_wait,
|
||||
@@ -1316,6 +1321,12 @@ random_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
}
|
||||
|
||||
static ssize_t
|
||||
+random_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
+{
|
||||
+ return _random_read(file->f_flags & O_NONBLOCK, buf, nbytes);
|
||||
+}
|
||||
+
|
||||
+static ssize_t
|
||||
urandom_read(struct file *file, char __user *buf, size_t nbytes, loff_t *ppos)
|
||||
{
|
||||
static int maxwarn = 10;
|
||||
@@ -1460,6 +1471,29 @@ const struct file_operations urandom_fops = {
|
||||
.llseek = noop_llseek,
|
||||
};
|
||||
|
||||
+SYSCALL_DEFINE3(getrandom, char __user *, buf, size_t, count,
|
||||
+ unsigned int, flags)
|
||||
+{
|
||||
+ if (flags & ~(GRND_NONBLOCK|GRND_RANDOM))
|
||||
+ return -EINVAL;
|
||||
+
|
||||
+ if (count > INT_MAX)
|
||||
+ count = INT_MAX;
|
||||
+
|
||||
+ if (flags & GRND_RANDOM)
|
||||
+ return _random_read(flags & GRND_NONBLOCK, buf, count);
|
||||
+
|
||||
+ if (unlikely(nonblocking_pool.initialized == 0)) {
|
||||
+ if (flags & GRND_NONBLOCK)
|
||||
+ return -EAGAIN;
|
||||
+ wait_event_interruptible(urandom_init_wait,
|
||||
+ nonblocking_pool.initialized);
|
||||
+ if (signal_pending(current))
|
||||
+ return -ERESTARTSYS;
|
||||
+ }
|
||||
+ return urandom_read(NULL, buf, count, NULL);
|
||||
+}
|
||||
+
|
||||
/***************************************************************
|
||||
* Random UUID interface
|
||||
*
|
||||
diff --git a/include/linux/syscalls.h b/include/linux/syscalls.h
|
||||
index fad4082c50d9..7ab57c41c0a5 100644
|
||||
--- a/include/linux/syscalls.h
|
||||
+++ b/include/linux/syscalls.h
|
||||
@@ -855,4 +855,7 @@ asmlinkage long sys_process_vm_writev(pid_t pid,
|
||||
asmlinkage long sys_kcmp(pid_t pid1, pid_t pid2, int type,
|
||||
unsigned long idx1, unsigned long idx2);
|
||||
asmlinkage long sys_finit_module(int fd, const char __user *uargs, int flags);
|
||||
+asmlinkage long sys_getrandom(char __user *buf, size_t count,
|
||||
+ unsigned int flags);
|
||||
+
|
||||
#endif
|
||||
diff --git a/include/uapi/asm-generic/unistd.h b/include/uapi/asm-generic/unistd.h
|
||||
index dde8041f40d2..4555c492684c 100644
|
||||
--- a/include/uapi/asm-generic/unistd.h
|
||||
+++ b/include/uapi/asm-generic/unistd.h
|
||||
@@ -696,9 +696,11 @@ __SYSCALL(__NR_finit_module, sys_finit_module)
|
||||
__SYSCALL(__NR_sched_setattr, sys_sched_setattr)
|
||||
#define __NR_sched_getattr 275
|
||||
__SYSCALL(__NR_sched_getattr, sys_sched_getattr)
|
||||
+#define __NR_getrandom 278
|
||||
+__SYSCALL(__NR_getrandom, sys_getrandom)
|
||||
|
||||
#undef __NR_syscalls
|
||||
-#define __NR_syscalls 276
|
||||
+#define __NR_syscalls 279
|
||||
|
||||
/*
|
||||
* All syscalls below here should go away really,
|
||||
diff --git a/include/uapi/linux/random.h b/include/uapi/linux/random.h
|
||||
index fff3528a078f..3f93d1695e7f 100644
|
||||
--- a/include/uapi/linux/random.h
|
||||
+++ b/include/uapi/linux/random.h
|
||||
@@ -40,4 +40,13 @@ struct rand_pool_info {
|
||||
__u32 buf[0];
|
||||
};
|
||||
|
||||
+/*
|
||||
+ * Flags for getrandom(2)
|
||||
+ *
|
||||
+ * GRND_NONBLOCK Don't block and return EAGAIN instead
|
||||
+ * GRND_RANDOM Use the /dev/random pool instead of /dev/urandom
|
||||
+ */
|
||||
+#define GRND_NONBLOCK 0x0001
|
||||
+#define GRND_RANDOM 0x0002
|
||||
+
|
||||
#endif /* _UAPI_LINUX_RANDOM_H */
|
||||
--
|
||||
2.12.2
|
||||
|
56
core/linux-imx6/0004-ARM-wire-up-getrandom-syscall.patch
Normal file
56
core/linux-imx6/0004-ARM-wire-up-getrandom-syscall.patch
Normal file
|
@ -0,0 +1,56 @@
|
|||
From d17493a9d19e5924cf5a00eb10f4a29c87084800 Mon Sep 17 00:00:00 2001
|
||||
From: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
Date: Fri, 8 Aug 2014 10:56:34 +0100
|
||||
Subject: [PATCH 4/5] ARM: wire up getrandom syscall
|
||||
|
||||
Add the new getrandom syscall for ARM.
|
||||
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/unistd.h | 2 +-
|
||||
arch/arm/include/uapi/asm/unistd.h | 1 +
|
||||
arch/arm/kernel/calls.S | 3 +++
|
||||
3 files changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/unistd.h b/arch/arm/include/asm/unistd.h
|
||||
index 21ca0cebcab0..32640c431a08 100644
|
||||
--- a/arch/arm/include/asm/unistd.h
|
||||
+++ b/arch/arm/include/asm/unistd.h
|
||||
@@ -19,7 +19,7 @@
|
||||
* This may need to be greater than __NR_last_syscall+1 in order to
|
||||
* account for the padding in the syscall table
|
||||
*/
|
||||
-#define __NR_syscalls (384)
|
||||
+#define __NR_syscalls (388)
|
||||
|
||||
/*
|
||||
* *NOTE*: This is a ghost syscall private to the kernel. Only the
|
||||
diff --git a/arch/arm/include/uapi/asm/unistd.h b/arch/arm/include/uapi/asm/unistd.h
|
||||
index c3776331f407..79d451df99a3 100644
|
||||
--- a/arch/arm/include/uapi/asm/unistd.h
|
||||
+++ b/arch/arm/include/uapi/asm/unistd.h
|
||||
@@ -408,6 +408,7 @@
|
||||
#define __NR_finit_module (__NR_SYSCALL_BASE+379)
|
||||
#define __NR_sched_setattr (__NR_SYSCALL_BASE+380)
|
||||
#define __NR_sched_getattr (__NR_SYSCALL_BASE+381)
|
||||
+#define __NR_getrandom (__NR_SYSCALL_BASE+384)
|
||||
|
||||
/*
|
||||
* The following SWIs are ARM private.
|
||||
diff --git a/arch/arm/kernel/calls.S b/arch/arm/kernel/calls.S
|
||||
index 166e945de832..7df289c3507b 100644
|
||||
--- a/arch/arm/kernel/calls.S
|
||||
+++ b/arch/arm/kernel/calls.S
|
||||
@@ -391,6 +391,9 @@
|
||||
CALL(sys_finit_module)
|
||||
/* 380 */ CALL(sys_sched_setattr)
|
||||
CALL(sys_sched_getattr)
|
||||
+ CALL(sys_ni_syscall)
|
||||
+ CALL(sys_ni_syscall)
|
||||
+ CALL(sys_getrandom)
|
||||
#ifndef syscalls_counted
|
||||
.equ syscalls_padding, ((NR_syscalls + 3) & ~3) - NR_syscalls
|
||||
#define syscalls_counted
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -0,0 +1,33 @@
|
|||
From 4d56e2fa3339828c89f640a9a6ffeb7a538c6448 Mon Sep 17 00:00:00 2001
|
||||
From: Herbert Xu <herbert@gondor.apana.org.au>
|
||||
Date: Thu, 21 May 2015 16:19:54 +0800
|
||||
Subject: [PATCH 5/5] random: Wake up all getrandom(2) callers when pool is
|
||||
ready
|
||||
|
||||
If more than one application invokes getrandom(2) before the pool
|
||||
is ready, then all bar one will be stuck forever because we use
|
||||
wake_up_interruptible which wakes up a single task.
|
||||
|
||||
This patch replaces it with wake_up_all.
|
||||
|
||||
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
|
||||
---
|
||||
drivers/char/random.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/char/random.c b/drivers/char/random.c
|
||||
index a3150a06dbba..27eafd7e01f9 100644
|
||||
--- a/drivers/char/random.c
|
||||
+++ b/drivers/char/random.c
|
||||
@@ -660,7 +660,7 @@ retry:
|
||||
r->entropy_total = 0;
|
||||
if (r == &nonblocking_pool) {
|
||||
prandom_reseed_late();
|
||||
- wake_up_interruptible(&urandom_init_wait);
|
||||
+ wake_up_all(&urandom_init_wait);
|
||||
pr_notice("random: %s pool is initialized\n", r->name);
|
||||
}
|
||||
}
|
||||
--
|
||||
2.12.2
|
||||
|
|
@ -14,7 +14,7 @@ _srcname=linux-fslc-sr-${_commit}
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.14
|
||||
pkgver=${_basekernel}.79
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
cryptodev_commit=f116a93224fc7b85f83d2c53f565f8fd86165ecc
|
||||
|
||||
arch=('armv7h')
|
||||
|
@ -26,13 +26,21 @@ source=("linux-${_commit}::https://github.com/moonman/linux-fslc-sr/archive/${_c
|
|||
"cryptodev-${cryptodev_commit}.tar.gz::https://github.com/cryptodev-linux/cryptodev-linux/archive/${cryptodev_commit}.tar.gz"
|
||||
"git://git.code.sf.net/p/aufs/aufs3-standalone#branch=aufs${pkgver:0:4}.40+"
|
||||
'0001-Bluetooth-allocate-static-minor-for-vhci.patch'
|
||||
'0002-random-simplify-loop-in-random_read.patch'
|
||||
'0003-random-introduce-getrandom-2-system-call.patch'
|
||||
'0004-ARM-wire-up-getrandom-syscall.patch'
|
||||
'0005-random-Wake-up-all-getrandom-2-callers-when-pool-is-.patch'
|
||||
'fix_cec.patch'
|
||||
'fix_cec_revb1.patch'
|
||||
'config')
|
||||
md5sums=('696f4bf47c2fd588fd579eec8ebd9159'
|
||||
'bd52f10ced89e663d2f4d138948828fd'
|
||||
'SKIP'
|
||||
'1b276abe16d14e133f3f28d9c9e6bd68'
|
||||
'7d3b27a74bd730debaf842e5d95b8a26'
|
||||
'8bec0f9d7b39ca577a4e77b716a62ab0'
|
||||
'130a1700e96db2168ac78c53d2cf29cb'
|
||||
'cdbb8d3e1ff4935bfb17a623de80b0d0'
|
||||
'a362dcdd9954d8d64740d0a135df1960'
|
||||
'56ca9bd64f5539740ebbcba033dc13fd'
|
||||
'b95d95786c1ffa8f95a1f5e7b4434ba0'
|
||||
'3212b451fb00953863547ee658793a1a')
|
||||
|
@ -49,6 +57,12 @@ prepare() {
|
|||
msg2 "Fix hci_vhci no minor warning"
|
||||
patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch
|
||||
|
||||
msg2 "Backport getrandom syscall"
|
||||
patch -Np1 -i ${srcdir}/0002-random-simplify-loop-in-random_read.patch
|
||||
patch -Np1 -i ${srcdir}/0003-random-introduce-getrandom-2-system-call.patch
|
||||
patch -Np1 -i ${srcdir}/0004-ARM-wire-up-getrandom-syscall.patch
|
||||
patch -Np1 -i ${srcdir}/0005-random-Wake-up-all-getrandom-2-callers-when-pool-is-.patch
|
||||
|
||||
msg2 "Copying aufs3 patches into the kernel source tree"
|
||||
cp -ru "${srcdir}/aufs3-standalone/"{Documentation,fs} "${srcdir}/${_srcname}/"
|
||||
cp -ru "${srcdir}/aufs3-standalone/include/uapi/linux/aufs_type.h" "${srcdir}/${_srcname}/include/"{linux/,uapi/linux/}
|
||||
|
|
Loading…
Reference in a new issue