mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/wolfssl to 5.5.0-1
This commit is contained in:
parent
ad0f8e63ec
commit
d240287957
2 changed files with 25 additions and 5 deletions
|
@ -4,7 +4,7 @@
|
|||
# - cmake with -DWOLFSSL_SHA3=ON, required and not set by default for v7
|
||||
|
||||
pkgname=wolfssl
|
||||
pkgver=5.4.0
|
||||
pkgver=5.5.0
|
||||
pkgrel=1
|
||||
pkgdesc="Lightweight, portable, C-language-based SSL/TLS library"
|
||||
arch=(x86_64)
|
||||
|
@ -17,15 +17,23 @@ options=(debug)
|
|||
source=(
|
||||
$pkgname-$pkgver-stable.tar.gz::https://github.com/$pkgname/$pkgname/archive/refs/tags/v$pkgver-stable.tar.gz
|
||||
https://github.com/$pkgname/$pkgname/releases/download/v$pkgver-stable/$pkgname-$pkgver-stable.tar.gz.asc
|
||||
$pkgname-5.5.0-cmake.patch
|
||||
)
|
||||
sha512sums=('e43560f83f6c62d78b10c4df7db21f02386f22b893688b98d2f3432e3b3946a4e80960c7402404a8c0486c87b1dde5b7a3827f9d4d3be13f87f370dfc1179c78'
|
||||
'SKIP')
|
||||
b2sums=('957ea8233e942c247f06c81a6f95a13320f2cbba8379a95c9568b69f39fcd9ce43f597559df938589f9c91473c54b1df112fd7458eb74fe81932b78ade37624e'
|
||||
'SKIP')
|
||||
sha512sums=('1f9ffd8e83b26f97c3685315790f3f2b451a23e9dad9e2f09142a3e1e136012293ca2d04f46c267f8275ac9e60894c46c7875353765df6d4fdd93ba666228459'
|
||||
'SKIP'
|
||||
'44aef4fc39dc81b113563b78c8732e8d1d6371e1c0ad0e73d8b13115e6623d8d92e6162400453fe36473616e2f6f9a283f8a440c94588860e92b204669672be4')
|
||||
b2sums=('92f2f1c7072cf6bb0ea5007cb4c1662c147534021fe63929202a2c4e46bdd40bc2e61fdec6d3c8720bfd1be8e946588536ba2a7e9c02a84e11be3e01ca2db1c3'
|
||||
'SKIP'
|
||||
'8179223e2536d672896be7b5afab45df3326a14d6330c031d6631bb8075a666c4106d8a47b56d6640254cf91c75b7a4fc3801a1ef5626f847dd90926472c0370')
|
||||
validpgpkeys=(
|
||||
A2A48E7BCB96C5BECB987314EBC80E415CA29677 # wolfSSL <secure@wolfssl.com>
|
||||
)
|
||||
|
||||
prepare() {
|
||||
# -Werror not even once: https://github.com/wolfSSL/wolfssl/issues/5553
|
||||
patch -Np1 -d $pkgname-$pkgver-stable -i ../$pkgname-5.5.0-cmake.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cmake \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
|
|
12
extra/wolfssl/wolfssl-5.5.0-cmake.patch
Normal file
12
extra/wolfssl/wolfssl-5.5.0-cmake.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -ruN a/CMakeLists.txt b/CMakeLists.txt
|
||||
--- a/CMakeLists.txt 2022-08-30 19:35:13.000000000 +0200
|
||||
+++ b/CMakeLists.txt 2022-09-08 23:27:01.798347756 +0200
|
||||
@@ -169,7 +169,7 @@
|
||||
# Example for map file and custom linker script
|
||||
#set(CMAKE_EXE_LINKER_FLAGS " -Xlinker -Map=output.map -T\"${CMAKE_CURRENT_SOURCE_DIR}/linker.ld\"")
|
||||
|
||||
-set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused -Werror ${CMAKE_C_FLAGS}")
|
||||
+set(CMAKE_C_FLAGS "-Wall -Wextra -Wno-unused ${CMAKE_C_FLAGS}")
|
||||
|
||||
####################################################
|
||||
# Build Options
|
Loading…
Reference in a new issue