extra/krita to 4.1.0-2

This commit is contained in:
Kevin Mihelich 2018-07-12 00:16:28 +00:00
parent 629af86907
commit d272aec633
2 changed files with 27 additions and 4 deletions

View file

@ -6,24 +6,28 @@
pkgname=krita
pkgver=4.1.0
pkgrel=1
pkgrel=2
pkgdesc="Edit and paint images"
arch=(x86_64)
url="https://krita.org"
license=(GPL3)
depends=(kio kitemmodels gsl libraw exiv2 openexr fftw curl boost-libs giflib qt5-declarative hicolor-icon-theme)
makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio python-pyqt5 libheif)
makedepends=(extra-cmake-modules kdoctools boost eigen poppler-qt5 opencolorio python-pyqt5 libheif sip python-sip)
optdepends=('poppler-qt5: PDF filter' 'ffmpeg: to save animations' 'opencolorio: for the LUT docker'
"krita-plugin-gmic: G'MIC plugin" 'python-pyqt5: for the Python plugins' 'libheif: HEIF filter')
conflicts=(calligra-krita krita-l10n)
replaces=(calligra-krita krita-l10n)
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig})
source=("https://download.kde.org/stable/krita/$pkgver/$pkgname-$pkgver.tar.gz"{,.sig}
krita-pyqt5.11.patch)
sha256sums=('78792df8165b986b806dcf9960a2679f683f2263e06f3ad5a24b0f78d8f27ed5'
'SKIP')
'SKIP'
'37aa93119c759d80829112f169f64c47450f218e0fe05fc2e16ae54ff8170db2')
validpgpkeys=('05D00A8B73A686789E0A156858B9596C722EA3BD') # Boudewijn Rempt <foundation@krita.org>
prepare() {
mkdir -p build
cd $pkgname-$pkgver
patch -p1 -i ../krita-pyqt5.11.patch # Fix python plugins with PyQt 5.11
}
build() {

View file

@ -0,0 +1,19 @@
diff --git a/plugins/extensions/pykrita/sip/CMakeLists.txt b/plugins/extensions/pykrita/sip/CMakeLists.txt
index 1f47f0af1c..d5a24f86ee 100644
--- a/plugins/extensions/pykrita/sip/CMakeLists.txt
+++ b/plugins/extensions/pykrita/sip/CMakeLists.txt
@@ -12,9 +12,13 @@ set(SIP_INCLUDES
${PYQT_SIP_DIR_OVERRIDE}
./krita)
+if(${PYQT5_VERSION} STRGREATER_EQUAL "050b00")
+ set(SIP_NAME -n PyQt5.sip)
+endif()
+
set(SIP_CONCAT_PARTS 1)
set(SIP_TAGS ALL WS_X11 ${PYQT5_VERSION_TAG})
-set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector)
+set(SIP_EXTRA_OPTIONS -g -x PyKDE_QVector ${SIP_NAME})
set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${LIB_INSTALL_DIR}/krita-python-libs)
file(GLOB PYKRITA_KRITA_sip_files ./krita/*.sip)