extra/gstreamer0.10-bad to 0.10.23-9

This commit is contained in:
Kevin Mihelich 2015-04-21 11:42:34 +00:00
parent 484c977c3c
commit d29e5bb205
3 changed files with 43 additions and 1 deletions

View file

@ -7,13 +7,15 @@
pkgbase=gstreamer0.10-bad
pkgname=('gstreamer0.10-bad' 'gstreamer0.10-bad-plugins')
pkgver=0.10.23
pkgrel=8
pkgrel=9
arch=('i686' 'x86_64')
license=('LGPL' 'GPL')
makedepends=('pkgconfig' 'gstreamer0.10-base>=0.10.36' 'xvidcore' 'libdca' 'bzip2' 'libdc1394' 'neon' 'faac' 'musicbrainz' 'faad2' 'libmms' 'libcdaudio' 'libmpcdec' 'mjpegtools' 'libdvdnav' 'libmodplug' 'jasper' 'liblrdf' 'libofa' 'soundtouch' 'libvdpau' 'schroedinger' 'libass' 'libvpx' 'gsm' 'libgme' 'rtmpdump' 'libsndfile' 'librsvg' 'wildmidi' 'opus' 'git' 'spandsp' 'celt')
url="http://gstreamer.freedesktop.org/"
options=(!libtool !emptydirs)
source=("git://anongit.freedesktop.org/gstreamer-sdk/gst-plugins-bad#commit=57569a4854a0f2d14ef19a8264a4ae9a7a1d1125"
fix-libmodplug-include.patch
drop-vpx-compat-defs.patch
disable-assrender-test.patch
disable-camerabin-test.patch)
sha256sums=('SKIP'
@ -23,6 +25,8 @@ sha256sums=('SKIP'
prepare() {
cd gst-plugins-bad
sed -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' -i configure.ac
patch -Np1 -i ../fix-libmodplug-include.patch
patch -Np1 -i ../drop-vpx-compat-defs.patch
patch -Np1 -i ../disable-assrender-test.patch
patch -Np1 -i ../disable-camerabin-test.patch
}

View file

@ -0,0 +1,26 @@
--- gst-plugins-bad.orig/ext/vp8/gstvp8utils.h 2015-04-21 03:31:33.134952881 +0300
+++ gst-plugins-bad/ext/vp8/gstvp8utils.h 2015-04-21 03:32:45.553520671 +0300
@@ -25,23 +25,6 @@
G_BEGIN_DECLS
-/* Some compatibility defines for older libvpx versions */
-#ifndef VPX_IMG_FMT_I420
-#define VPX_IMG_FMT_I420 IMG_FMT_I420
-#endif
-
-#ifndef VPX_PLANE_Y
-#define VPX_PLANE_Y PLANE_Y
-#endif
-
-#ifndef VPX_PLANE_U
-#define VPX_PLANE_U PLANE_U
-#endif
-
-#ifndef VPX_PLANE_V
-#define VPX_PLANE_V PLANE_V
-#endif
-
const char * gst_vpx_error_name (vpx_codec_err_t status);
G_END_DECLS

View file

@ -0,0 +1,12 @@
diff -uprw gst-plugins-bad.orig/ext/modplug/gstmodplug.cc gst-plugins-bad/ext/modplug/gstmodplug.cc
--- gst-plugins-bad.orig/ext/modplug/gstmodplug.cc 2015-04-21 03:15:25.929456272 +0300
+++ gst-plugins-bad/ext/modplug/gstmodplug.cc 2015-04-21 03:18:54.624976723 +0300
@@ -50,7 +50,7 @@
#define WORDS_BIGENDIAN 0
#endif
-#include <stdafx.h>
+#include <libmodplug/stdafx.h>
#include <libmodplug/sndfile.h>
#include "gstmodplug.h"