mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/qt5 to 5.1.0-2
This commit is contained in:
parent
4661f7dfd8
commit
d32f322286
2 changed files with 48 additions and 4 deletions
|
@ -30,10 +30,10 @@ pkgname=('qt5-base'
|
|||
'qt5-x11extras'
|
||||
'qt5-xmlpatterns')
|
||||
pkgver=5.1.0
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('i686' 'x86_64')
|
||||
url='http://qt-project.org/'
|
||||
license=('GPL3' 'LGPL')
|
||||
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
||||
makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
|
||||
'mesa-libgl' 'at-spi2-core' 'alsa-lib' 'gstreamer0.10-base-plugins'
|
||||
'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
|
||||
|
@ -46,7 +46,8 @@ _pkgfqn="qt-everywhere-opensource-src-${pkgver}"
|
|||
source=("http://download.qt-project.org/official_releases/qt/5.1/${pkgver}/single/${_pkgfqn}.tar.xz"
|
||||
'assistant.desktop' 'designer.desktop' 'linguist.desktop' 'qdbusviewer.desktop'
|
||||
'use-python2.patch'
|
||||
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch')
|
||||
'deppath_gnu.patch' 'rpi.patch' 'undef_B0.patch'
|
||||
'bison3.patch')
|
||||
md5sums=('44a507beebef73eb364b5a2ec7bbe090'
|
||||
'b2897dd6a2967bccf8f10e397aafee55'
|
||||
'9638a78e502719ef8fe5f8d10d0361a9'
|
||||
|
@ -55,7 +56,8 @@ md5sums=('44a507beebef73eb364b5a2ec7bbe090'
|
|||
'92831f79144d5cb8121915423ba47575'
|
||||
'21e4389ed0dd9c37e7cb48712d3bff91'
|
||||
'3f8d2f8fb4e5715f7ce79950fac3c31f'
|
||||
'8a9ba2d990d8840a2114fcffb9f9d2a4')
|
||||
'8a9ba2d990d8840a2114fcffb9f9d2a4'
|
||||
'6b162cd2bc104f0ae83ca039401be7bf')
|
||||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
|
@ -80,6 +82,10 @@ prepare() {
|
|||
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
|
||||
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
|
||||
$(find . -name '*.py')
|
||||
|
||||
# Fix build with bison 3.x
|
||||
cd qtwebkit
|
||||
patch -p1 -i "${srcdir}"/bison3.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
38
extra/qt5/bison3.patch
Normal file
38
extra/qt5/bison3.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
From 60ba8bd5b3575d0c7740571fbb4e681b21a49a82 Mon Sep 17 00:00:00 2001
|
||||
From: Allan Sandfeld Jensen <allan.jensen@digia.com>
|
||||
Date: Fri, 16 Aug 2013 18:27:07 +0200
|
||||
Subject: [PATCH] ANGLE doesn't build with bison 3.0
|
||||
|
||||
https://bugs.webkit.org/show_bug.cgi?id=119798
|
||||
|
||||
Reviewed by Antti Koivisto.
|
||||
|
||||
Make glslang.y compatible with bison 3.0
|
||||
by using %lex-param to set YYLEX_PARAM.
|
||||
|
||||
* src/compiler/glslang.y:
|
||||
|
||||
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@154109 268f45cc-cd09-0410-ab3c-d52691b4dbfc
|
||||
|
||||
Task-number: QTBUG-32913
|
||||
Change-Id: I15505d31f0588c4d558b73befdb9d2358e29c1a3
|
||||
Reviewed-by: Jocelyn Turcotte <jocelyn.turcotte@digia.com>
|
||||
---
|
||||
Source/ThirdParty/ANGLE/src/compiler/glslang.y | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/Source/ThirdParty/ANGLE/src/compiler/glslang.y b/Source/ThirdParty/ANGLE/src/compiler/glslang.y
|
||||
index 3cad335..b41e95a 100644
|
||||
--- a/Source/ThirdParty/ANGLE/src/compiler/glslang.y
|
||||
+++ b/Source/ThirdParty/ANGLE/src/compiler/glslang.y
|
||||
@@ -47,6 +47,7 @@ WHICH GENERATES THE GLSL ES PARSER (glslang_tab.cpp AND glslang_tab.h).
|
||||
%expect 1 /* One shift reduce conflict because of if | else */
|
||||
%pure-parser
|
||||
%parse-param {TParseContext* context}
|
||||
+%lex-param {YYLEX_PARAM}
|
||||
|
||||
%union {
|
||||
struct {
|
||||
--
|
||||
1.7.1
|
||||
|
Loading…
Reference in a new issue