removed extra/js68

This commit is contained in:
Kevin Mihelich 2022-02-17 14:21:17 +00:00
parent 958b80b90e
commit d34b90a54c
3 changed files with 0 additions and 120 deletions

View file

@ -1,94 +0,0 @@
# Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - configure with --disable-lto
# - patch to fix build on ARM
# - patch to remove unnecessary rust build dependencies, removed rust from makedepends
pkgname=js68
pkgver=68.12.0
pkgrel=1
pkgdesc="JavaScript interpreter and libraries - Version 68"
arch=(x86_64)
url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/SpiderMonkey"
license=(MPL)
depends=(gcc-libs readline zlib sh)
makedepends=(python2 zip autoconf2.13 python llvm clang)
checkdepends=(mercurial git)
_relver=${pkgver}esr
source=(https://archive.mozilla.org/pub/firefox/releases/$_relver/source/firefox-$_relver.source.tar.xz{,.asc}
arm.patch
remove-rust.patch)
sha256sums=('ae692bf2a15908cacbb9d4c7ccf78525a87410ff3f13befedc1926f849bc27cc'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'78158bfe379801c075747d739144c5817a901f0ac7e584ea14d21f49861fa805')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Make sure the duplication between bin and lib is found
COMPRESSZST+=(--long)
prepare() {
cd firefox-$pkgver
mkdir obj
patch -p1 -i ../arm.patch
patch -p1 -i ../remove-rust.patch
}
build() {
local configure_args=(
--prefix=/usr
--disable-debug
--disable-debug-symbols
--disable-jemalloc
--disable-strip
--enable-hardening
--disable-lto
--enable-optimize
--enable-posix-nspr-emulation
--enable-readline
--enable-release
--enable-shared-js
--enable-tests
--enable-unaligned-private-values
--with-intl-api
--with-system-zlib
--without-system-icu
)
export AR=llvm-ar
export NM=llvm-nm
export RANLIB=llvm-ranlib
cd firefox-$pkgver/obj
sh ../js/src/configure "${configure_args[@]}"
make
}
check() {
local jstests_extra_args=(
--format=none
--exclude-random
) jittest_extra_args=(
--format=none
--timeout 300
) jittest_test_args=(
basic
)
cd firefox-$pkgver/obj
make -C js/src check-jstests check-jit-test \
JSTESTS_EXTRA_ARGS="${jstests_extra_args[*]}" \
JITTEST_EXTRA_ARGS="${jittest_extra_args[*]}" \
JITTEST_TEST_ARGS="${jittest_test_args[*]}"
}
package() {
cd firefox-$pkgver/obj
make DESTDIR="$pkgdir" install
rm "$pkgdir"/usr/lib/*.ajs
find "$pkgdir"/usr/{lib/pkgconfig,include} -type f -exec chmod -c a-x {} +
}
# vim:set ts=2 sw=2 et:

View file

@ -1,15 +0,0 @@
https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
diff --git a/js/src/wasm/WasmSignalHandlers.cpp.orig b/js/src/wasm/WasmSignalHandlers.cpp
index 636537f..0f3461a 100644
--- a/js/src/wasm/WasmSignalHandlers.cpp.orig
+++ b/js/src/wasm/WasmSignalHandlers.cpp
@@ -244,7 +244,7 @@ using mozilla::DebugOnly;
// emulation here.
#if defined(__linux__) && defined(__arm__)
-# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
+//# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
#endif
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS

View file

@ -1,11 +0,0 @@
--- a/js/moz.configure 2020-07-20 15:02:46.000000000 -0600
+++ b/js/moz.configure 2020-08-08 15:55:33.771501779 -0600
@@ -18,8 +18,6 @@
option(env='JS_STANDALONE', default=building_js,
help='Reserved for internal use')
-include('../build/moz.configure/rust.configure',
- when='--enable-compile-environment')
include('../build/moz.configure/bindgen.configure',
when='--enable-compile-environment')