mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
linux-kirkwood-dt: kernel-CVE-2016-0728.patch
This commit is contained in:
parent
cbf6aacea7
commit
d3b55f3836
2 changed files with 85 additions and 1 deletions
|
@ -8,7 +8,7 @@ _kernelname=${pkgbase#linux}
|
||||||
_desc="Marvell Kirkwood DT"
|
_desc="Marvell Kirkwood DT"
|
||||||
pkgver=4.3.3
|
pkgver=4.3.3
|
||||||
srcver=${pkgver%.0}
|
srcver=${pkgver%.0}
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
cryptodev_commit=bc67142c57eadc0aafd0323ec527849012786643
|
cryptodev_commit=bc67142c57eadc0aafd0323ec527849012786643
|
||||||
bfqver=v7r8
|
bfqver=v7r8
|
||||||
|
|
||||||
|
@ -38,6 +38,7 @@ source=("https://kernel.org/pub/linux/kernel/v4.x/linux-${srcver}.tar.xz"
|
||||||
'goflexhome_fdt.patch'
|
'goflexhome_fdt.patch'
|
||||||
'pogoplugv4_fdt.patch'
|
'pogoplugv4_fdt.patch'
|
||||||
'nsa325_fdt.patch'
|
'nsa325_fdt.patch'
|
||||||
|
'kernel-CVE-2016-0728.patch'
|
||||||
'linux.preset')
|
'linux.preset')
|
||||||
|
|
||||||
md5sums=('f3068333fa524ff98914cf751d0b5710'
|
md5sums=('f3068333fa524ff98914cf751d0b5710'
|
||||||
|
@ -52,6 +53,7 @@ md5sums=('f3068333fa524ff98914cf751d0b5710'
|
||||||
'ce1975f40c48ec1b08dd09447ab043ca'
|
'ce1975f40c48ec1b08dd09447ab043ca'
|
||||||
'7efecf23dbebc1ee2e2ccb527c8579c0'
|
'7efecf23dbebc1ee2e2ccb527c8579c0'
|
||||||
'8ac6e9bb64a482925a5192e4d1d570f8'
|
'8ac6e9bb64a482925a5192e4d1d570f8'
|
||||||
|
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||||
'959e49540dac4c5e689ad9037150a360')
|
'959e49540dac4c5e689ad9037150a360')
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
|
@ -76,6 +78,7 @@ prepare() {
|
||||||
patch -Np1 -i "${srcdir}/goflexhome_fdt.patch"
|
patch -Np1 -i "${srcdir}/goflexhome_fdt.patch"
|
||||||
patch -Np1 -i "${srcdir}/pogoplugv4_fdt.patch"
|
patch -Np1 -i "${srcdir}/pogoplugv4_fdt.patch"
|
||||||
patch -Np1 -i "${srcdir}/nsa325_fdt.patch"
|
patch -Np1 -i "${srcdir}/nsa325_fdt.patch"
|
||||||
|
patch -Np1 -i "${srcdir}/kernel-CVE-2016-0728.patch"
|
||||||
|
|
||||||
msg2 "Add BFQ patches"
|
msg2 "Add BFQ patches"
|
||||||
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.patch"
|
patch -Np1 -i "${srcdir}/0001-block-cgroups-kconfig-build-bits-for-BFQ-${bfqver}-${bfqkern}.patch"
|
||||||
|
|
81
core/linux-kirkwood-dt/kernel-CVE-2016-0728.patch
Normal file
81
core/linux-kirkwood-dt/kernel-CVE-2016-0728.patch
Normal file
|
@ -0,0 +1,81 @@
|
||||||
|
From 23567fd052a9abb6d67fe8e7a9ccdd9800a540f2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yevgeny Pats <yevgeny@perception-point.io>
|
||||||
|
Date: Tue, 19 Jan 2016 22:09:04 +0000
|
||||||
|
Subject: KEYS: Fix keyring ref leak in join_session_keyring()
|
||||||
|
|
||||||
|
This fixes CVE-2016-0728.
|
||||||
|
|
||||||
|
If a thread is asked to join as a session keyring the keyring that's already
|
||||||
|
set as its session, we leak a keyring reference.
|
||||||
|
|
||||||
|
This can be tested with the following program:
|
||||||
|
|
||||||
|
#include <stddef.h>
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <keyutils.h>
|
||||||
|
|
||||||
|
int main(int argc, const char *argv[])
|
||||||
|
{
|
||||||
|
int i = 0;
|
||||||
|
key_serial_t serial;
|
||||||
|
|
||||||
|
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||||
|
"leaked-keyring");
|
||||||
|
if (serial < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
if (keyctl(KEYCTL_SETPERM, serial,
|
||||||
|
KEY_POS_ALL | KEY_USR_ALL) < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
for (i = 0; i < 100; i++) {
|
||||||
|
serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
|
||||||
|
"leaked-keyring");
|
||||||
|
if (serial < 0) {
|
||||||
|
perror("keyctl");
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
return 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
If, after the program has run, there something like the following line in
|
||||||
|
/proc/keys:
|
||||||
|
|
||||||
|
3f3d898f I--Q--- 100 perm 3f3f0000 0 0 keyring leaked-keyring: empty
|
||||||
|
|
||||||
|
with a usage count of 100 * the number of times the program has been run,
|
||||||
|
then the kernel is malfunctioning. If leaked-keyring has zero usages or
|
||||||
|
has been garbage collected, then the problem is fixed.
|
||||||
|
|
||||||
|
Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
|
||||||
|
Signed-off-by: David Howells <dhowells@redhat.com>
|
||||||
|
Acked-by: Don Zickus <dzickus@redhat.com>
|
||||||
|
Acked-by: Prarit Bhargava <prarit@redhat.com>
|
||||||
|
Acked-by: Jarod Wilson <jarod@redhat.com>
|
||||||
|
Signed-off-by: James Morris <james.l.morris@oracle.com>
|
||||||
|
---
|
||||||
|
security/keys/process_keys.c | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
|
||||||
|
index a3f85d2..e6d50172 100644
|
||||||
|
--- a/security/keys/process_keys.c
|
||||||
|
+++ b/security/keys/process_keys.c
|
||||||
|
@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
|
||||||
|
ret = PTR_ERR(keyring);
|
||||||
|
goto error2;
|
||||||
|
} else if (keyring == new->session_keyring) {
|
||||||
|
+ key_put(keyring);
|
||||||
|
ret = 0;
|
||||||
|
goto error2;
|
||||||
|
}
|
||||||
|
--
|
||||||
|
cgit v0.12
|
||||||
|
|
Loading…
Reference in a new issue