mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added community/unittestpp
This commit is contained in:
parent
ee9278206d
commit
d3e32cb049
3 changed files with 96 additions and 0 deletions
|
@ -0,0 +1,27 @@
|
||||||
|
#! /bin/sh /usr/share/dpatch/dpatch-run
|
||||||
|
## 20_test_runner_bad_virtual_method_arg.dpatch by <proppy@yada>
|
||||||
|
##
|
||||||
|
## All lines beginning with `## DP:' are a description of the patch.
|
||||||
|
## DP: No description.
|
||||||
|
|
||||||
|
@DPATCH@
|
||||||
|
diff -urNad unittest++-1.4.0~/src/tests/TestTestRunner.cpp unittest++-1.4.0/src/tests/TestTestRunner.cpp
|
||||||
|
--- unittest++-1.4.0~/src/tests/TestTestRunner.cpp 2008-10-30 15:27:42.000000000 +0100
|
||||||
|
+++ unittest++-1.4.0/src/tests/TestTestRunner.cpp 2009-07-10 23:25:53.000000000 +0200
|
||||||
|
@@ -20,14 +20,14 @@
|
||||||
|
{
|
||||||
|
}
|
||||||
|
|
||||||
|
- virtual void RunImpl(TestResults& testResults_) const
|
||||||
|
+ virtual void RunImpl() const
|
||||||
|
{
|
||||||
|
for (int i=0; i < count; ++i)
|
||||||
|
{
|
||||||
|
if (asserted)
|
||||||
|
ReportAssert("desc", "file", 0);
|
||||||
|
else if (!success)
|
||||||
|
- testResults_.OnTestFailure(m_details, "message");
|
||||||
|
+ CurrentTest::Results()->OnTestFailure(m_details, "message");
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
55
community/unittestpp/PKGBUILD
Normal file
55
community/unittestpp/PKGBUILD
Normal file
|
@ -0,0 +1,55 @@
|
||||||
|
# $Id:
|
||||||
|
# Maintainer : Martin Wimpress <code@flexion.org>
|
||||||
|
# Contributor: Jorge Araya Navarro <elcorreo@deshackra.com>
|
||||||
|
# Contributor: Piotr Beling <qwak@w8.pl>
|
||||||
|
# Contributor: Vianney le Clément <vleclement AT gmail · com>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
# - patch to fix build
|
||||||
|
|
||||||
|
pkgname=unittestpp
|
||||||
|
pkgver=1.4
|
||||||
|
pkgrel=6
|
||||||
|
pkgdesc="A lightweight unit testing framework for C++"
|
||||||
|
arch=('i686' 'x86_64')
|
||||||
|
url="http://unittest-cpp.sourceforge.net/"
|
||||||
|
depends=('gcc-libs')
|
||||||
|
source=("http://downloads.sourceforge.net/project/unittest-cpp/UnitTest%2B%2B/$pkgver/unittest-cpp-$pkgver.zip"
|
||||||
|
'unittest++.pc'
|
||||||
|
'20_test_runner_bad_virtual_method_arg.dpatch')
|
||||||
|
md5sums=('bd373a53403ed51ea1bbb60b1952d7e3'
|
||||||
|
'fa35c8a0274264dcb75e5106c5b3deb7'
|
||||||
|
'b2721cb13e8e74143d05662eba0d97f8')
|
||||||
|
license=('MIT')
|
||||||
|
options=('staticlibs')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${srcdir}/UnitTest++"
|
||||||
|
patch -p1 -i ../20_test_runner_bad_virtual_method_arg.dpatch
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "${srcdir}/UnitTest++"
|
||||||
|
make all
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
install -dm755 "${pkgdir}/usr/lib/pkgconfig"
|
||||||
|
install -m644 unittest++.pc "${pkgdir}/usr/lib/pkgconfig"
|
||||||
|
|
||||||
|
cd "${srcdir}/UnitTest++"
|
||||||
|
|
||||||
|
install -dm755 "${pkgdir}/usr/include/unittest++/Posix"
|
||||||
|
install -m644 src/*.h "${pkgdir}/usr/include/unittest++"
|
||||||
|
install -m644 src/Posix/*.h "${pkgdir}/usr/include/unittest++/Posix"
|
||||||
|
|
||||||
|
install -dm755 "${pkgdir}/usr/lib"
|
||||||
|
install -m644 libUnitTest++.a "${pkgdir}/usr/lib"
|
||||||
|
ln -s libUnitTest++.a "${pkgdir}/usr/lib/libunittest++.a"
|
||||||
|
|
||||||
|
install -dm755 "${pkgdir}/usr/share/licenses/unittestpp"
|
||||||
|
install -m644 COPYING "${pkgdir}/usr/share/licenses/unittestpp/LICENSE"
|
||||||
|
install -dm755 "${pkgdir}/usr/share/doc/unittestpp"
|
||||||
|
install -m644 README "${pkgdir}/usr/share/doc/unittestpp/README"
|
||||||
|
install -m644 docs/UnitTest++.html "${pkgdir}/usr/share/doc/unittestpp/UnitTest++.html"
|
||||||
|
}
|
14
community/unittestpp/unittest++.pc
Normal file
14
community/unittestpp/unittest++.pc
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
# pkg-config source file
|
||||||
|
|
||||||
|
prefix=/usr
|
||||||
|
exec_prefix=${prefix}
|
||||||
|
libdir=${exec_prefix}/lib
|
||||||
|
includedir=${prefix}/include
|
||||||
|
|
||||||
|
Name: unittest++
|
||||||
|
Description: UnitTest++ is a unit testing framework for C++
|
||||||
|
Version: 1.4
|
||||||
|
Requires:
|
||||||
|
Conflicts:
|
||||||
|
Libs: -L${libdir} -lUnitTest++
|
||||||
|
Cflags: -I${includedir}/unittest++
|
Loading…
Reference in a new issue