extra/ffmpeg to 4.2.2-8

This commit is contained in:
Kevin Mihelich 2020-05-11 15:00:39 +00:00
parent 077eb20f1c
commit d40ddaa7c2
2 changed files with 20 additions and 3 deletions

View file

@ -13,7 +13,7 @@
pkgname=ffmpeg
pkgver=4.2.2
pkgrel=7
pkgrel=8
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video'
arch=(x86_64)
@ -86,8 +86,10 @@ provides=(
libswresample.so
libswscale.so
)
source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=192d1d34eb3668fa27f433e96036340e1e5077a0)
sha256sums=(SKIP)
source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=192d1d34eb3668fa27f433e96036340e1e5077a0
vmaf-model-path.patch)
sha256sums=('SKIP'
'8dff51f84a5f7460f8893f0514812f5d2bd668c3276ef7ab7713c99b71d7bd8d')
pkgver() {
cd ffmpeg
@ -99,6 +101,8 @@ prepare() {
cd ffmpeg
git cherry-pick -n dc0806dd25882f41f6085c8356712f95fded56c7
patch -Np1 -i "${srcdir}/vmaf-model-path.patch"
}
build() {

View file

@ -0,0 +1,13 @@
diff --git a/libavfilter/vf_libvmaf.c b/libavfilter/vf_libvmaf.c
index 249e50c720..9b791e19b1 100644
--- a/libavfilter/vf_libvmaf.c
+++ b/libavfilter/vf_libvmaf.c
@@ -72,7 +72,7 @@ typedef struct LIBVMAFContext {
#define FLAGS AV_OPT_FLAG_FILTERING_PARAM|AV_OPT_FLAG_VIDEO_PARAM
static const AVOption libvmaf_options[] = {
- {"model_path", "Set the model to be used for computing vmaf.", OFFSET(model_path), AV_OPT_TYPE_STRING, {.str="/usr/local/share/model/vmaf_v0.6.1.pkl"}, 0, 1, FLAGS},
+ {"model_path", "Set the model to be used for computing vmaf.", OFFSET(model_path), AV_OPT_TYPE_STRING, {.str="/usr/share/model/vmaf_v0.6.1.pkl"}, 0, 1, FLAGS},
{"log_path", "Set the file path to be used to store logs.", OFFSET(log_path), AV_OPT_TYPE_STRING, {.str=NULL}, 0, 1, FLAGS},
{"log_fmt", "Set the format of the log (xml or json).", OFFSET(log_fmt), AV_OPT_TYPE_STRING, {.str=NULL}, 0, 1, FLAGS},
{"enable_transform", "Enables transform for computing vmaf.", OFFSET(enable_transform), AV_OPT_TYPE_BOOL, {.i64=0}, 0, 1, FLAGS},