mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
removed aur/lightdm-gtk-greeter
This commit is contained in:
parent
98eeb2ad45
commit
d41656fc77
4 changed files with 0 additions and 98 deletions
|
@ -1,50 +0,0 @@
|
|||
# Maintainer: Padfoot <padfoot at exemail dot com dot au>
|
||||
|
||||
pkgname=lightdm-gtk-greeter
|
||||
pkgver=1.5.0
|
||||
pkgrel=2
|
||||
pkgdesc="GTK+ greeter for LightDM"
|
||||
arch=('i686'
|
||||
'x86_64')
|
||||
url="https://launchpad.net/lightdm-gtk-greeter"
|
||||
license=('GPL3'
|
||||
'LGPL3')
|
||||
depends=('lightdm'
|
||||
'gtk3')
|
||||
makedepends=('gtk-doc'
|
||||
'gnome-common'
|
||||
'gnome-doc-utils'
|
||||
'gobject-introspection'
|
||||
'intltool')
|
||||
conflicts=('lightdm-gtk-greeter-osk'
|
||||
'lightdm-gtk-greeter-bzr')
|
||||
backup=('etc/lightdm/lightdm-gtk-greeter.conf')
|
||||
install='lightdm-gtk-greeter.install'
|
||||
source=("https://launchpad.net/$pkgname/1.6/$pkgver/+download/$pkgname-$pkgver.tar.gz"
|
||||
"lightdm-gtk-greeter.conf"
|
||||
"lightdm-gtk-greeter.patch")
|
||||
md5sums=('226fbc12594cca01d5decabde1d42f2d'
|
||||
'76b48440baf59713304d6ea71ecdc325'
|
||||
'80555121f1f6b7b284308cb8122128fc')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
export AUTOMAKE=automake
|
||||
|
||||
patch -p1 -i $srcdir/lightdm-gtk-greeter.patch
|
||||
|
||||
./autogen.sh --prefix=/usr \
|
||||
--sysconfdir=/etc \
|
||||
--libexecdir=/usr/lib/lightdm \
|
||||
--disable-static
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
cp ../lightdm-gtk-greeter.conf $pkgdir/etc/lightdm
|
||||
}
|
|
@ -1,23 +0,0 @@
|
|||
#
|
||||
# logo = Logo file to use, either an image absolute path, or a path relative to the greeter data directory
|
||||
# background = Background file to use, either an image path or a color (e.g. #772953)
|
||||
# theme-name = GTK+ theme to use
|
||||
# icon-theme-name = Icon theme to use
|
||||
# font-name = Font to use
|
||||
# xft-antialias = Whether to antialias Xft fonts (true or false)
|
||||
# xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
|
||||
# xft-hintstyle = What degree of hinting to use (hintnone, hintslight, hintmedium, or hintfull)
|
||||
# xft-rgba = Type of subpixel antialiasing (none, rgb, bgr, vrgb or vbgr)
|
||||
# show-language-selector (true or false)
|
||||
#
|
||||
[greeter]
|
||||
#logo=
|
||||
background=#000000
|
||||
theme-name=default
|
||||
icon-theme-name=default
|
||||
font-name=Sans Regular 11
|
||||
xft-antialias=true
|
||||
xft-dpi=96
|
||||
xft-hintstyle=slight
|
||||
xft-rgba=rgb
|
||||
show-language-selector=true
|
|
@ -1,14 +0,0 @@
|
|||
_install_notes() {
|
||||
echo
|
||||
echo 'Theme lightdm-gtk-greeter by editing /etc/lightdm/lighdm-gtk-greeter.conf'
|
||||
echo
|
||||
}
|
||||
|
||||
post_install() {
|
||||
_install_notes
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
_install_notes
|
||||
}
|
||||
|
|
@ -1,11 +0,0 @@
|
|||
diff -aur lightdm-gtk-greeter-1.5.0.src/src/lightdm-gtk-greeter.c lightdm-gtk-greeter-1.5.0.patch/src/lightdm-gtk-greeter.c
|
||||
--- lightdm-gtk-greeter-1.5.0.src/src/lightdm-gtk-greeter.c 2013-01-25 01:31:00.000000000 +1100
|
||||
+++ lightdm-gtk-greeter-1.5.0.patch/src/lightdm-gtk-greeter.c 2013-01-30 19:42:27.612325811 +1100
|
||||
@@ -872,6 +872,7 @@
|
||||
g_warning ("Failed to load background: %s", error->message);
|
||||
g_clear_error (&error);
|
||||
g_free (path);
|
||||
+ default_background_pixbuf=gdk_pixbuf_add_alpha (default_background_pixbuf,FALSE,255,255,255);
|
||||
}
|
||||
else
|
||||
{
|
Loading…
Reference in a new issue