extra/cups to 2.4.2-2

This commit is contained in:
Kevin Mihelich 2022-06-09 18:21:01 +00:00
parent c96cc61546
commit d41c8ccd56
2 changed files with 25 additions and 2 deletions

View file

@ -0,0 +1,17 @@
From c0c403744b1bf4a9790a8fcaabcd60970cbefe06 Mon Sep 17 00:00:00 2001
From: Michael R Sweet <michael.r.sweet@gmail.com>
Date: Tue, 7 Jun 2022 13:45:29 -0400
Subject: [PATCH] Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
freeing it (Issue #409)
diff --git a/cups/tls-openssl.c b/cups/tls-openssl.c
index c3e57742e..6db9f8a9c 100644
--- a/cups/tls-openssl.c
+++ b/cups/tls-openssl.c
@@ -1152,6 +1152,8 @@ _httpTLSStop(http_t *http) // I - Connection to server
SSL_shutdown(http->tls);
SSL_CTX_free(context);
SSL_free(http->tls);
+
+ http->tls = NULL;
}

View file

@ -6,7 +6,7 @@
pkgbase="cups" pkgbase="cups"
pkgname=('libcups' 'cups') pkgname=('libcups' 'cups')
pkgver=2.4.2 pkgver=2.4.2
pkgrel=1 pkgrel=2
epoch=1 epoch=1
arch=('x86_64') arch=('x86_64')
license=('Apache' 'custom') license=('Apache' 'custom')
@ -24,6 +24,7 @@ source=(https://github.com/OpenPrinting/cups/releases/download/v${pkgver}/cups-$
# bugfixes # bugfixes
cups-freebind.patch cups-freebind.patch
guid.patch guid.patch
0001_Fix_OpenSSL_crash_bug.patch
) )
sha256sums=('f03ccb40b087d1e30940a40e0141dcbba263f39974c20eb9f2521066c9c6c908' sha256sums=('f03ccb40b087d1e30940a40e0141dcbba263f39974c20eb9f2521066c9c6c908'
'SKIP' 'SKIP'
@ -32,7 +33,8 @@ sha256sums=('f03ccb40b087d1e30940a40e0141dcbba263f39974c20eb9f2521066c9c6c908'
'06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2' '06173dfaea37bdd9b39b3e09aba98c34ae7112a2f521db45a688907d8848caa2'
'f0b15192952c151b1843742c87850ff3a7d0f3ba5dd236ed16623ef908472ad7' 'f0b15192952c151b1843742c87850ff3a7d0f3ba5dd236ed16623ef908472ad7'
'3385047b9ac8a7b13aeb8f0ca55d15f793ce7283516db0155fe28a67923c592d' '3385047b9ac8a7b13aeb8f0ca55d15f793ce7283516db0155fe28a67923c592d'
'0bf6a75ba1b051771f155d9a5d36b307a6d40c6857d645b250fe93f3fb713474') '0bf6a75ba1b051771f155d9a5d36b307a6d40c6857d645b250fe93f3fb713474'
'632faf08bfd1863e9ad6807aff766983e84030a0e4df441167f17de7266ca152')
#validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org> #validpgpkeys=('3737FD0D0E63B30172440D2DDBA3A7AB08D76223') # CUPS.org (CUPS.org PGP key) <security@cups.org>
#validpgpkeys+=('45D083946E3035282B3CCA9AF434104235DA97EB') # "CUPS.org <security@cups.org>" #validpgpkeys+=('45D083946E3035282B3CCA9AF434104235DA97EB') # "CUPS.org <security@cups.org>"
#validpgpkeys+=('845464660B686AAB36540B6F999559A027815955') # "Michael R Sweet <michael.r.sweet@gmail.com>" #validpgpkeys+=('845464660B686AAB36540B6F999559A027815955') # "Michael R Sweet <michael.r.sweet@gmail.com>"
@ -55,6 +57,10 @@ prepare() {
# FS#56818 - https://github.com/apple/cups/issues/5236 # FS#56818 - https://github.com/apple/cups/issues/5236
patch -Np1 -i "${srcdir}"/guid.patch patch -Np1 -i "${srcdir}"/guid.patch
# FS#75005 - Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
# Fix OpenSSL crash bug - "tls" pointer wasn't cleared after
patch -Np1 -i "${srcdir}"/0001_Fix_OpenSSL_crash_bug.patch
# Rebuild configure script # Rebuild configure script
aclocal -I config-scripts aclocal -I config-scripts
autoconf -I config-scripts autoconf -I config-scripts