mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/mesa to 11.0.4-1
This commit is contained in:
parent
818efadb26
commit
d422e3ab81
2 changed files with 4 additions and 42 deletions
|
@ -1,33 +0,0 @@
|
|||
From e2a696a4cd93c2dbe445243de48ed478fbdb8009 Mon Sep 17 00:00:00 2001
|
||||
From: Chris Wilson <chris@chris-wilson.co.uk>
|
||||
Date: Fri, 10 Jul 2015 10:41:35 +0100
|
||||
Subject: [PATCH] i965: Remove early release of DRI2 miptree
|
||||
|
||||
intel_update_winsys_renderbuffer_miptree() will release the existing
|
||||
miptree when wrapping a new DRI2 buffer, so we can remove the early
|
||||
release and so prevent a NULL mt dereference should importing the new
|
||||
DRI2 name fail for any reason. (Reusing the old DRI2 name will result
|
||||
in the rendering going astray, to a stale buffer, and not shown on the
|
||||
screen, but it allows us to issue a warning and not crash much later in
|
||||
innocent code.)
|
||||
|
||||
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
|
||||
---
|
||||
src/mesa/drivers/dri/i965/brw_context.c | 1 -
|
||||
1 file changed, 1 deletion(-)
|
||||
|
||||
diff --git a/src/mesa/drivers/dri/i965/brw_context.c b/src/mesa/drivers/dri/i965/brw_context.c
|
||||
index e8d1396..72f3897 100644
|
||||
--- a/src/mesa/drivers/dri/i965/brw_context.c
|
||||
+++ b/src/mesa/drivers/dri/i965/brw_context.c
|
||||
@@ -1388,7 +1388,6 @@ intel_process_dri2_buffer(struct brw_context *brw,
|
||||
buffer->cpp, buffer->pitch);
|
||||
}
|
||||
|
||||
- intel_miptree_release(&rb->mt);
|
||||
bo = drm_intel_bo_gem_create_from_name(brw->bufmgr, buffer_name,
|
||||
buffer->name);
|
||||
if (!bo) {
|
||||
--
|
||||
2.5.0
|
||||
|
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgbase=mesa
|
||||
pkgname=('mesa' 'mesa-libgl' 'libva-mesa-driver')
|
||||
pkgver=11.0.3
|
||||
pkgver=11.0.4
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
|
@ -19,20 +19,15 @@ url="http://mesa3d.sourceforge.net"
|
|||
license=('custom')
|
||||
options=('!libtool')
|
||||
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz{,.sig}
|
||||
LICENSE
|
||||
0001-i965-Remove-early-release-of-DRI2-miptree.patch)
|
||||
sha256sums=('ab2992eece21adc23c398720ef8c6933cb69ea42e1b2611dc09d031e17e033d6'
|
||||
LICENSE)
|
||||
sha256sums=('40201bf7fc6fa12a6d9edfe870b41eb4dd6669154e3c42c48a96f70805f5483d'
|
||||
'SKIP'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||
'a3f520ea13c923841c646a5b1627927744938ff691aa08e1aeaf14cce12bd1f7')
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
|
||||
prepare() {
|
||||
cd ${srcdir}/?esa-*
|
||||
|
||||
# Should fix FS#45750, tested by heftig - Not merged upstream
|
||||
patch -Np1 -i ../0001-i965-Remove-early-release-of-DRI2-miptree.patch
|
||||
|
||||
# Fix detection of libLLVM when built with CMake
|
||||
sed -i 's/LLVM_SO_NAME=.*/LLVM_SO_NAME=LLVM/' configure
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue