mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added extra/jack
This commit is contained in:
parent
ea3f67bcc2
commit
d466cdbfe7
5 changed files with 140 additions and 0 deletions
2
extra/jack/40-hpet-permissions.rules
Normal file
2
extra/jack/40-hpet-permissions.rules
Normal file
|
@ -0,0 +1,2 @@
|
|||
KERNEL=="rtc0", GROUP="audio"
|
||||
KERNEL=="hpet", GROUP="audio"
|
2
extra/jack/99-audio.conf
Normal file
2
extra/jack/99-audio.conf
Normal file
|
@ -0,0 +1,2 @@
|
|||
@audio - rtprio 99
|
||||
@audio - memlock unlimited
|
68
extra/jack/PKGBUILD
Normal file
68
extra/jack/PKGBUILD
Normal file
|
@ -0,0 +1,68 @@
|
|||
# $Id$
|
||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
||||
# Contributor: tobias <tobias@archlinux.net>
|
||||
# Contributor: Robert Emil Berge <robert@rebi.no>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to not use packed structures on ARM
|
||||
|
||||
pkgname=jack
|
||||
_longname=jack-audio-connection-kit
|
||||
pkgver=0.124.1
|
||||
pkgrel=1.1
|
||||
pkgdesc="A low-latency audio server"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL')
|
||||
depends=('libsamplerate' 'readline')
|
||||
makedepends=('doxygen' 'libffado' 'celt')
|
||||
optdepends=('libffado: FireWire support'
|
||||
'celt: NetJACK driver')
|
||||
url="http://jackaudio.org/"
|
||||
backup=(etc/security/limits.d/99-audio.conf)
|
||||
provides=("$_longname=$pkgver")
|
||||
conflicts=("$_longname")
|
||||
replaces=("$_longname")
|
||||
install=$pkgname.install
|
||||
source=("http://jackaudio.org/downloads/$_longname-$pkgver.tar.gz"
|
||||
'99-audio.conf'
|
||||
'40-hpet-permissions.rules'
|
||||
'arm.patch')
|
||||
md5sums=('d64e90121be8a54860b870a726fb5b5d'
|
||||
'ae65b7c9ebe0fff6c918ba9d97ae342d'
|
||||
'471aad533ff56c5d3cbbf65ce32cadef'
|
||||
'62253d27e5342b98dacf8b8f8c3f9c1d')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/$_longname-$pkgver"
|
||||
|
||||
patch -p1 -i ../arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$_longname-$pkgver"
|
||||
|
||||
./configure --prefix=/usr \
|
||||
--libdir=/usr/lib
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$srcdir/$_longname-$pkgver"
|
||||
|
||||
make DESTDIR="$pkgdir" install
|
||||
|
||||
# configure realtime access/scheduling
|
||||
# see https://bugs.archlinux.org/task/26343
|
||||
install -Dm644 "$srcdir/99-audio.conf" \
|
||||
"$pkgdir/etc/security/limits.d/99-audio.conf"
|
||||
|
||||
install -Dm644 "$srcdir/40-hpet-permissions.rules" \
|
||||
"$pkgdir/usr/lib/udev/rules.d/40-hpet-permissions.rules"
|
||||
|
||||
# install a missing header forgotten by upstream
|
||||
# see https://bugs.archlinux.org/task/26865
|
||||
#install -Dm644 "$srcdir/$_longname-$pkgver/jack/jslist.h" \
|
||||
# "$pkgdir/usr/include/jack/jslist.h"
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
63
extra/jack/arm.patch
Normal file
63
extra/jack/arm.patch
Normal file
|
@ -0,0 +1,63 @@
|
|||
diff -urN a/include/internal.h b/include/internal.h
|
||||
--- a/include/internal.h 2013-10-11 18:51:57.000000000 -0600
|
||||
+++ b/include/internal.h 2014-08-29 10:44:56.347765456 -0600
|
||||
@@ -36,6 +36,7 @@
|
||||
|
||||
#ifndef POST_PACKED_STRUCTURE
|
||||
#ifdef __GNUC__
|
||||
+#ifndef __arm__
|
||||
/* POST_PACKED_STRUCTURE needs to be a macro which
|
||||
expands into a compiler directive. The directive must
|
||||
tell the compiler to arrange the preceding structure
|
||||
@@ -44,6 +45,9 @@
|
||||
compiler.
|
||||
*/
|
||||
#define POST_PACKED_STRUCTURE __attribute__((__packed__))
|
||||
+#else
|
||||
+#define POST_PACKED_STRUCTURE
|
||||
+#endif
|
||||
#else
|
||||
/* Add other things here for non-gcc platforms */
|
||||
#endif
|
||||
diff -urN a/include/port.h b/include/port.h
|
||||
--- a/include/port.h 2013-10-06 09:34:42.000000000 -0600
|
||||
+++ b/include/port.h 2014-08-29 10:45:25.257670204 -0600
|
||||
@@ -56,6 +56,7 @@
|
||||
|
||||
#ifndef POST_PACKED_STRUCTURE
|
||||
#ifdef __GNUC__
|
||||
+#ifndef __arm__
|
||||
/* POST_PACKED_STRUCTURE needs to be a macro which
|
||||
expands into a compiler directive. The directive must
|
||||
tell the compiler to arrange the preceding structure
|
||||
@@ -64,6 +65,9 @@
|
||||
compiler.
|
||||
*/
|
||||
#define POST_PACKED_STRUCTURE __attribute__((__packed__))
|
||||
+#else
|
||||
+#define POST_PACKED_STRUCTURE
|
||||
+#endif
|
||||
#else
|
||||
/* Add other things here for non-gcc platforms */
|
||||
#endif
|
||||
diff -urN a/jack/transport.h b/jack/transport.h
|
||||
--- a/jack/transport.h 2013-10-03 18:46:00.000000000 -0600
|
||||
+++ b/jack/transport.h 2014-08-29 10:45:09.652721584 -0600
|
||||
@@ -30,6 +30,7 @@
|
||||
|
||||
#ifndef POST_PACKED_STRUCTURE
|
||||
#ifdef __GNUC__
|
||||
+#ifndef __arm__
|
||||
/* POST_PACKED_STRUCTURE needs to be a macro which
|
||||
expands into a compiler directive. The directive must
|
||||
tell the compiler to arrange the preceding structure
|
||||
@@ -39,6 +40,9 @@
|
||||
*/
|
||||
#define POST_PACKED_STRUCTURE __attribute__((__packed__))
|
||||
#else
|
||||
+#define POST_PACKED_STRUCTURE
|
||||
+#endif
|
||||
+#else
|
||||
/* Add other things here for non-gcc platforms */
|
||||
#endif
|
||||
#endif
|
5
extra/jack/jack.install
Normal file
5
extra/jack/jack.install
Normal file
|
@ -0,0 +1,5 @@
|
|||
post_upgrade() {
|
||||
rm -f etc/security/limits.d/99-realtime.conf
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
Loading…
Reference in a new issue