mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
core/libtool to 2.4.7+4+g1ec8fa28-1
This commit is contained in:
parent
a612c5e9b3
commit
d478f2ad2b
2 changed files with 32 additions and 10 deletions
|
@ -14,9 +14,10 @@
|
||||||
noautobuild=1
|
noautobuild=1
|
||||||
|
|
||||||
pkgname=libtool
|
pkgname=libtool
|
||||||
pkgver=2.4.7
|
_commit=1ec8fa28dcb29500d485c136db28315671ec4c3b
|
||||||
pkgrel=5
|
pkgver=2.4.7+4+g1ec8fa28
|
||||||
_gccver=12.2.0
|
pkgrel=1
|
||||||
|
_gccver=12.2.1
|
||||||
pkgdesc='A generic library support script'
|
pkgdesc='A generic library support script'
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://www.gnu.org/software/libtool'
|
url='https://www.gnu.org/software/libtool'
|
||||||
|
@ -29,19 +30,19 @@ provides=("libltdl=$pkgver")
|
||||||
conflicts=(libltdl)
|
conflicts=(libltdl)
|
||||||
replaces=(libltdl)
|
replaces=(libltdl)
|
||||||
options=(!distcc)
|
options=(!distcc)
|
||||||
options=(debug)
|
|
||||||
_commit=6d7ce133ce54898cf28abd89d167cccfbc3c9b2b
|
|
||||||
source=(git+https://git.savannah.gnu.org/git/libtool.git#commit=$_commit
|
source=(git+https://git.savannah.gnu.org/git/libtool.git#commit=$_commit
|
||||||
git+https://git.savannah.gnu.org/git/gnulib.git
|
git+https://git.savannah.gnu.org/git/gnulib.git
|
||||||
gnulib-bootstrap::git+https://github.com/gnulib-modules/bootstrap.git
|
gnulib-bootstrap::git+https://github.com/gnulib-modules/bootstrap.git
|
||||||
no_hostname.patch
|
no_hostname.patch
|
||||||
disable-lto-link-order2.patch
|
disable-lto-link-order2.patch
|
||||||
|
grep_3.8_fix.patch
|
||||||
armv7h-nopic.patch)
|
armv7h-nopic.patch)
|
||||||
sha256sums=('SKIP'
|
sha256sums=('SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'SKIP'
|
'SKIP'
|
||||||
'693aabb24a6e7ce21fe0b5d14394e19edcb8476663b5afa4463f9fa0df24d946'
|
'693aabb24a6e7ce21fe0b5d14394e19edcb8476663b5afa4463f9fa0df24d946'
|
||||||
'b6dce6681f223b18a90614edbcdeb00f228abd1216e22c4bd07285321cd2ceb7'
|
'b6dce6681f223b18a90614edbcdeb00f228abd1216e22c4bd07285321cd2ceb7'
|
||||||
|
'0a31d3ed91d97a18e17942c85018899c0233493a54c885f4c133454de522ef50'
|
||||||
'0e19dec2dabc958ef5d1bcfd0879174766c5783032319fc17d5d6692b2b397c8')
|
'0e19dec2dabc958ef5d1bcfd0879174766c5783032319fc17d5d6692b2b397c8')
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
|
@ -52,17 +53,21 @@ pkgver() {
|
||||||
prepare() {
|
prepare() {
|
||||||
cd libtool
|
cd libtool
|
||||||
|
|
||||||
patch -Np1 -i ${srcdir}/no_hostname.patch
|
patch -Np1 -i "${srcdir}"/no_hostname.patch
|
||||||
|
|
||||||
# test 67 is broken with lto
|
# test 67 is broken with lto
|
||||||
# this patch removes the -flto flag for this very test
|
# this patch removes the -flto flag for this very test
|
||||||
# adapt when -ffat-lto-objects is enabled by Arch
|
# adapt when -ffat-lto-objects is enabled by Arch
|
||||||
patch -Np1 -i ${srcdir}/disable-lto-link-order2.patch
|
patch -Np1 -i "${srcdir}"/disable-lto-link-order2.patch
|
||||||
|
|
||||||
|
# test 66 is broken with grep 3.8
|
||||||
|
# see https://bugzilla.opensuse.org/show_bug.cgi?id=1203097
|
||||||
|
patch -Np1 -i "${srcdir}"/grep_3.8_fix.patch
|
||||||
|
|
||||||
git submodule init
|
git submodule init
|
||||||
git config --local submodule.gnulib.url "$srcdir/gnulib"
|
git config --local submodule.gnulib.url "${srcdir}"/gnulib
|
||||||
git config --local submodule.gl-mod/bootstrap.url "$srcdir/gnulib-bootstrap"
|
git config --local submodule.gl-mod/bootstrap.url "${srcdir}"/gnulib-bootstrap
|
||||||
git submodule update
|
git -c protocol.file.allow=always submodule update
|
||||||
|
|
||||||
patch -p1 -i ../armv7h-nopic.patch
|
patch -p1 -i ../armv7h-nopic.patch
|
||||||
./bootstrap
|
./bootstrap
|
||||||
|
|
17
core/libtool/grep_3.8_fix.patch
Normal file
17
core/libtool/grep_3.8_fix.patch
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
--- libtool-2.4.7/tests/link-order.at
|
||||||
|
+++ libtool-2.4.7/tests/link-order.at
|
||||||
|
@@ -99,12 +99,12 @@ aix* | interix*) ;; # These systems hav
|
||||||
|
case $hardcode_direct$hardcode_direct_absolute in
|
||||||
|
yesno)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
|
||||||
|
+ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
AT_CHECK([if $EGREP relinking stderr; then
|
||||||
|
- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
|
||||||
|
+ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
|
||||||
|
else :; fi], [0], [ignore], [], [echo "wrong link order"])
|
||||||
|
;;
|
||||||
|
esac
|
Loading…
Reference in a new issue