removed community/feedreader

This commit is contained in:
Kevin Mihelich 2019-03-08 19:53:16 +00:00
parent 1e5f8bfb48
commit d49beeacb1
2 changed files with 0 additions and 74 deletions

View file

@ -1,25 +0,0 @@
From 08b46bf4e228377f59d3ac377203fec383ffb825 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 30 Aug 2018 07:53:58 -0600
Subject: [PATCH] fix finding curl
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 1663b03e..bcd87e86 100644
--- a/meson.build
+++ b/meson.build
@@ -46,7 +46,7 @@ gstreamer_pbutils = dependency('gstreamer-pbutils-1.0')
gtk = dependency('gtk+-3.0', version: '>=3.22')
gumbo = dependency('gumbo')
json_glib = dependency('json-glib-1.0')
-libcurl = c_compiler.find_library('libcurl')
+libcurl = c_compiler.find_library('curl')
libnotify = dependency('libnotify')
libpeas = dependency('libpeas-1.0')
libsecret = dependency('libsecret-1')
--
2.18.0

View file

@ -1,49 +0,0 @@
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
# Contributor: Andrew O'Neill <andrew at meanjollies dot com>
# Contributor: poisonby <poisonby@tutanota.com>
# Contributor: Jason Scurtu (scujas) <jscurtu@gmail.com>
# Contributor: Marcin Tydelski <marcin.tydelski@gmail.com>
# Contributor: Jan Lukas Gernert (JeanLuc) <https://launchpad.net/~eviltwin1>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix finding libcurl on arm
pkgname=feedreader
_pkgname=FeedReader
pkgver=2.6.1
pkgrel=2
pkgdesc="Modern desktop application designed to complement existing web-based RSS accounts"
arch=(x86_64)
url="https://jangernert.github.io/FeedReader/"
license=(GPL3)
depends=(curl gnome-keyring gnome-online-accounts gumbo-parser libgee libpeas)
makedepends=(git gobject-introspection meson vala)
_commit=3cc7df1812ddbd484ac1493d178d1ad58b389d4b # tags/v2.6.1
source=("git+https://github.com/jangernert/$_pkgname#commit=$_commit"
'0001-fix-finding-curl.patch')
sha256sums=('SKIP'
'e6a2c27346d8679d11c09890ad38971ea640254537a3b2ac12beb84f393d04ef')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
cd $_pkgname
# Don't use legacy path for AppStream metainfo file
# https://github.com/jangernert/FeedReader/pull/822
sed -i "s/install_dir: join_paths(SHARE_DIR, 'appdata')/install_dir: join_paths(SHARE_DIR, 'metainfo')/" data/meson.build
patch -p1 -i ../0001-fix-finding-curl.patch
}
build() {
arch-meson $_pkgname build
ninja -C build
}
package() {
DESTDIR="$pkgdir" ninja -C build install
}