extra/vlc to 3.0.11.1-4

This commit is contained in:
Kevin Mihelich 2020-10-02 01:40:34 +00:00
parent e4c5742623
commit d4b66d8006
2 changed files with 35 additions and 8 deletions

View file

@ -11,17 +11,18 @@ _vlcver=3.0.11.1
# optional fixup version including hyphen
_vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r}
pkgrel=3
pkgrel=4
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
license=('LGPL2.1' 'GPL2')
depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy' 'lua52' 'libidn'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp' 'libmad'
'libmatroska' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libmad'
'libmpeg2' 'xcb-util-keysyms' 'libtar' 'libxinerama' 'libsecret'
'libarchive' 'qt5-base' 'qt5-x11extras' 'qt5-svg' 'freetype2'
'fribidi' 'harfbuzz' 'fontconfig' 'libxml2' 'gnutls' 'libplacebo'
'wayland-protocols' 'aribb24')
'libupnp' 'libixml.so' 'libupnp.so' 'libarchive' 'qt5-base'
'qt5-x11extras' 'qt5-svg' 'freetype2' 'fribidi' 'harfbuzz'
'fontconfig' 'libxml2' 'gnutls' 'libplacebo' 'wayland-protocols'
'aribb24')
makedepends=('gst-plugins-base-libs' 'live-media' 'libnotify' 'libbluray'
'flac' 'libdc1394' 'libavc1394' 'libcaca' 'gtk3'
'librsvg' 'libgme' 'xosd' 'twolame' 'aalib' 'avahi' 'systemd-libs'
@ -100,11 +101,13 @@ replaces=('vlc-plugin')
options=('!emptydirs')
source=(https://download.videolan.org/${pkgname}/${_vlcver}/${pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
update-vlc-plugin-cache.hook
qt_5_15.patch)
qt_5_15.patch
vlc-3.0.11.1-srt_1.4.2.patch)
sha512sums=('8ce1e2f11aabf847dc5c55cf21ce6d7c0419a1051b5f4795e36cd060eab82d5056e44b4c070b80af56744e6aa841ef538386d08bc3b397a444e7258b2ba3f76b'
'SKIP'
'b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3'
'43446257248461e7e6c237dbc63d58b994f4ce527573ff67437e3bade6ffb752aad94de19309c9cdca5f513e5c42f9d0c8b1db36198af6d41e18d3634c08761f')
'43446257248461e7e6c237dbc63d58b994f4ce527573ff67437e3bade6ffb752aad94de19309c9cdca5f513e5c42f9d0c8b1db36198af6d41e18d3634c08761f'
'090c75878894f89184179f534da503a78234cf4f0f5af602873ea2ba6b68326afed71ef6160d1352bdd5c05e45b36bfcd23b7286d5111a900b7c11829642ae0d')
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
prepare() {
@ -118,7 +121,7 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
msg2 "Applying patch $src..."
echo "Applying patch $src..."
patch -Np1 < "../$src"
done
}

View file

@ -0,0 +1,24 @@
diff -ruN a/modules/access/srt.c b/modules/access/srt.c
--- a/modules/access/srt.c 2018-04-23 10:03:39.000000000 +0200
+++ b/modules/access/srt.c 2020-09-26 10:35:18.830149487 +0200
@@ -165,7 +165,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_stream, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
psz_passphrase = var_InheritString( p_stream, "passphrase" );
diff -ruN a/modules/access_output/srt.c b/modules/access_output/srt.c
--- a/modules/access_output/srt.c 2018-04-06 11:22:51.000000000 +0200
+++ b/modules/access_output/srt.c 2020-09-26 10:35:03.386828120 +0200
@@ -162,7 +162,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_access, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
if ( psz_passphrase != NULL && psz_passphrase[0] != '\0')