mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
parent
9af244764b
commit
d4c96f9997
5 changed files with 223 additions and 5 deletions
|
@ -0,0 +1,97 @@
|
|||
From 0d2205e75980852690df1e64aac96b01213f02d8 Mon Sep 17 00:00:00 2001
|
||||
From: Sasha Levin <sasha.levin@oracle.com>
|
||||
Date: Mon, 13 Oct 2014 15:51:05 -0700
|
||||
Subject: [PATCH 1/3] kernel: add support for gcc 5
|
||||
|
||||
We're missing include/linux/compiler-gcc5.h which is required now
|
||||
because gcc branched off to v5 in trunk.
|
||||
|
||||
Just copy the relevant bits out of include/linux/compiler-gcc4.h,
|
||||
no new code is added as of now.
|
||||
|
||||
This fixes a build error when using gcc 5.
|
||||
|
||||
Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
|
||||
Cc: <stable@vger.kernel.org>
|
||||
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
|
||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
---
|
||||
include/linux/compiler-gcc5.h | 66 +++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 66 insertions(+)
|
||||
create mode 100644 include/linux/compiler-gcc5.h
|
||||
|
||||
diff --git a/include/linux/compiler-gcc5.h b/include/linux/compiler-gcc5.h
|
||||
new file mode 100644
|
||||
index 0000000..cdd1cc2
|
||||
--- /dev/null
|
||||
+++ b/include/linux/compiler-gcc5.h
|
||||
@@ -0,0 +1,66 @@
|
||||
+#ifndef __LINUX_COMPILER_H
|
||||
+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
|
||||
+#endif
|
||||
+
|
||||
+#define __used __attribute__((__used__))
|
||||
+#define __must_check __attribute__((warn_unused_result))
|
||||
+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
|
||||
+
|
||||
+/* Mark functions as cold. gcc will assume any path leading to a call
|
||||
+ to them will be unlikely. This means a lot of manual unlikely()s
|
||||
+ are unnecessary now for any paths leading to the usual suspects
|
||||
+ like BUG(), printk(), panic() etc. [but let's keep them for now for
|
||||
+ older compilers]
|
||||
+
|
||||
+ Early snapshots of gcc 4.3 don't support this and we can't detect this
|
||||
+ in the preprocessor, but we can live with this because they're unreleased.
|
||||
+ Maketime probing would be overkill here.
|
||||
+
|
||||
+ gcc also has a __attribute__((__hot__)) to move hot functions into
|
||||
+ a special section, but I don't see any sense in this right now in
|
||||
+ the kernel context */
|
||||
+#define __cold __attribute__((__cold__))
|
||||
+
|
||||
+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
|
||||
+
|
||||
+#ifndef __CHECKER__
|
||||
+# define __compiletime_warning(message) __attribute__((warning(message)))
|
||||
+# define __compiletime_error(message) __attribute__((error(message)))
|
||||
+#endif /* __CHECKER__ */
|
||||
+
|
||||
+/*
|
||||
+ * Mark a position in code as unreachable. This can be used to
|
||||
+ * suppress control flow warnings after asm blocks that transfer
|
||||
+ * control elsewhere.
|
||||
+ *
|
||||
+ * Early snapshots of gcc 4.5 don't support this and we can't detect
|
||||
+ * this in the preprocessor, but we can live with this because they're
|
||||
+ * unreleased. Really, we need to have autoconf for the kernel.
|
||||
+ */
|
||||
+#define unreachable() __builtin_unreachable()
|
||||
+
|
||||
+/* Mark a function definition as prohibited from being cloned. */
|
||||
+#define __noclone __attribute__((__noclone__))
|
||||
+
|
||||
+/*
|
||||
+ * Tell the optimizer that something else uses this function or variable.
|
||||
+ */
|
||||
+#define __visible __attribute__((externally_visible))
|
||||
+
|
||||
+/*
|
||||
+ * GCC 'asm goto' miscompiles certain code sequences:
|
||||
+ *
|
||||
+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
|
||||
+ *
|
||||
+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
|
||||
+ * Fixed in GCC 4.8.2 and later versions.
|
||||
+ *
|
||||
+ * (asm goto is automatically volatile - the naming reflects this.)
|
||||
+ */
|
||||
+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
|
||||
+
|
||||
+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
|
||||
+#define __HAVE_BUILTIN_BSWAP32__
|
||||
+#define __HAVE_BUILTIN_BSWAP64__
|
||||
+#define __HAVE_BUILTIN_BSWAP16__
|
||||
+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -0,0 +1,52 @@
|
|||
From 1888d0f464d1be8e42f49dc083bff6eb859dc590 Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Wed, 24 Sep 2014 01:06:46 +0100
|
||||
Subject: [PATCH 2/3] ARM: 8158/1: LLVMLinux: use static inline in ARM ftrace.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). In this case using static inline
|
||||
and removing the NULL version of return_address in return_address.c does
|
||||
the right thing.
|
||||
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
Acked-by: Steven Rostedt <rostedt@goodmis.org>
|
||||
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
|
||||
---
|
||||
arch/arm/include/asm/ftrace.h | 2 +-
|
||||
arch/arm/kernel/return_address.c | 5 -----
|
||||
2 files changed, 1 insertion(+), 6 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/ftrace.h b/arch/arm/include/asm/ftrace.h
|
||||
index f89515a..2bb8cac 100644
|
||||
--- a/arch/arm/include/asm/ftrace.h
|
||||
+++ b/arch/arm/include/asm/ftrace.h
|
||||
@@ -45,7 +45,7 @@ void *return_address(unsigned int);
|
||||
|
||||
#else
|
||||
|
||||
-extern inline void *return_address(unsigned int level)
|
||||
+static inline void *return_address(unsigned int level)
|
||||
{
|
||||
return NULL;
|
||||
}
|
||||
diff --git a/arch/arm/kernel/return_address.c b/arch/arm/kernel/return_address.c
|
||||
index fafedd8..f6aa84d 100644
|
||||
--- a/arch/arm/kernel/return_address.c
|
||||
+++ b/arch/arm/kernel/return_address.c
|
||||
@@ -63,11 +63,6 @@ void *return_address(unsigned int level)
|
||||
#warning "TODO: return_address should use unwind tables"
|
||||
#endif
|
||||
|
||||
-void *return_address(unsigned int level)
|
||||
-{
|
||||
- return NULL;
|
||||
-}
|
||||
-
|
||||
#endif /* if defined(CONFIG_FRAME_POINTER) && !defined(CONFIG_ARM_UNWIND) / else */
|
||||
|
||||
EXPORT_SYMBOL_GPL(return_address);
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -0,0 +1,59 @@
|
|||
From 8eb4b07320f7e1bda0ffad2535fd17fc95b6d63a Mon Sep 17 00:00:00 2001
|
||||
From: Behan Webster <behanw@converseincode.com>
|
||||
Date: Tue, 3 Sep 2013 22:27:26 -0400
|
||||
Subject: [PATCH 3/3] ARM: LLVMLinux: Change "extern inline" to "static inline"
|
||||
in glue-cache.h
|
||||
|
||||
With compilers which follow the C99 standard (like modern versions of gcc and
|
||||
clang), "extern inline" does the wrong thing (emits code for an externally
|
||||
linkable version of the inline function). "static inline" is the correct choice
|
||||
instead.
|
||||
|
||||
Author: Behan Webster <behanw@converseincode.com>
|
||||
Signed-off-by: Behan Webster <behanw@converseincode.com>
|
||||
Reviewed-by: Mark Charlebois <charlebm@gmail.com>
|
||||
---
|
||||
arch/arm/include/asm/glue-cache.h | 22 +++++++++++-----------
|
||||
1 file changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/arch/arm/include/asm/glue-cache.h b/arch/arm/include/asm/glue-cache.h
|
||||
index c81adc0..a3c24cd 100644
|
||||
--- a/arch/arm/include/asm/glue-cache.h
|
||||
+++ b/arch/arm/include/asm/glue-cache.h
|
||||
@@ -130,22 +130,22 @@
|
||||
#endif
|
||||
|
||||
#ifndef __ASSEMBLER__
|
||||
-extern inline void nop_flush_icache_all(void) { }
|
||||
-extern inline void nop_flush_kern_cache_all(void) { }
|
||||
-extern inline void nop_flush_kern_cache_louis(void) { }
|
||||
-extern inline void nop_flush_user_cache_all(void) { }
|
||||
-extern inline void nop_flush_user_cache_range(unsigned long a,
|
||||
+static inline void nop_flush_icache_all(void) { }
|
||||
+static inline void nop_flush_kern_cache_all(void) { }
|
||||
+static inline void nop_flush_kern_cache_louis(void) { }
|
||||
+static inline void nop_flush_user_cache_all(void) { }
|
||||
+static inline void nop_flush_user_cache_range(unsigned long a,
|
||||
unsigned long b, unsigned int c) { }
|
||||
|
||||
-extern inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
|
||||
-extern inline int nop_coherent_user_range(unsigned long a,
|
||||
+static inline void nop_coherent_kern_range(unsigned long a, unsigned long b) { }
|
||||
+static inline int nop_coherent_user_range(unsigned long a,
|
||||
unsigned long b) { return 0; }
|
||||
-extern inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
|
||||
+static inline void nop_flush_kern_dcache_area(void *a, size_t s) { }
|
||||
|
||||
-extern inline void nop_dma_flush_range(const void *a, const void *b) { }
|
||||
+static inline void nop_dma_flush_range(const void *a, const void *b) { }
|
||||
|
||||
-extern inline void nop_dma_map_area(const void *s, size_t l, int f) { }
|
||||
-extern inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
|
||||
+static inline void nop_dma_map_area(const void *s, size_t l, int f) { }
|
||||
+static inline void nop_dma_unmap_area(const void *s, size_t l, int f) { }
|
||||
#endif
|
||||
|
||||
#ifndef MULTI_CACHE
|
||||
--
|
||||
2.4.3
|
||||
|
|
@ -14,20 +14,30 @@ pkgrel=1
|
|||
arch=('armv7h')
|
||||
url="https://github.com/parallella/parallella-linux"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-tools' 'git')
|
||||
options=('!strip')
|
||||
source=("https://github.com/parallella/parallella-linux/archive/${_commit}.tar.gz"
|
||||
'0001-kernel-add-support-for-gcc-5.patch'
|
||||
'0002-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch'
|
||||
'0003-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch'
|
||||
'config')
|
||||
sha256sums=('4b19478f7932294c92c749843c7f68c3d35deb28937f76f4154bec68f83076eb'
|
||||
'8bb191e1ac181b0c0fa2ed0a64cf1e367d291f0f4045c000634f40b6c06d970d')
|
||||
'caac03c6d5f8563c80ac7149565c78ee8e452b5a26b97142f98f5951d609eb1d'
|
||||
'b2056fd871ce391de06cefdb71cdd82f21e4e12694492345e8b89c12d5186611'
|
||||
'63cf874b765bb8981f15a83a53eb069ee2824f37dbbb4eedce63dbbde0bfb6f8'
|
||||
'22ae77f1912b90b4efd38d1dbd417b35111c53bc2dc29c0e89ef17fb2577091b')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
git apply ../0001-kernel-add-support-for-gcc-5.patch
|
||||
git apply ../0002-ARM-8158-1-LLVMLinux-use-static-inline-in-ARM-ftrace.patch
|
||||
git apply ../0003-ARM-LLVMLinux-Change-extern-inline-to-static-inline-.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
# add pkgrel to extraversion
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 -${pkgrel}|" Makefile
|
||||
|
||||
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.14.12-parallella-2 Kernel Configuration
|
||||
# Linux/arm 3.14.12-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_MIGHT_HAVE_PCI=y
|
||||
|
@ -3693,7 +3693,7 @@ CONFIG_RTLLIB_CRYPTO_CCMP=m
|
|||
CONFIG_RTLLIB_CRYPTO_TKIP=m
|
||||
CONFIG_RTLLIB_CRYPTO_WEP=m
|
||||
# CONFIG_RTL8192E is not set
|
||||
CONFIG_R8712U=m
|
||||
# CONFIG_R8712U is not set
|
||||
CONFIG_R8188EU=m
|
||||
CONFIG_88EU_AP_MODE=y
|
||||
CONFIG_88EU_P2P=y
|
||||
|
|
Loading…
Reference in a new issue