extra/vlc to 3.0.17.3-1

This commit is contained in:
Kevin Mihelich 2022-03-13 22:23:43 +00:00
parent 7366e06183
commit d4d5a5db37
2 changed files with 3 additions and 41 deletions

View file

@ -7,11 +7,11 @@
# - enable gles2
pkgname=vlc
_vlcver=3.0.16
_vlcver=3.0.17.3
# optional fixup version including hyphen
_vlcfixupver=
pkgver=${_vlcver}${_vlcfixupver//-/.r}
pkgrel=8
pkgrel=1
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
url='https://www.videolan.org/vlc/'
arch=('x86_64')
@ -106,13 +106,11 @@ options=(debug '!emptydirs')
source=(https://download.videolan.org/${pkgname}/${_vlcver}/${pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
update-vlc-plugin-cache.hook
caca-fix-to-newer-version.patch
vlc-3.0.11.1-srt_1.4.2.patch
vlc-live-media-2021.patch)
sha512sums=('35cdf191071224d0cf1b5a83c00773ff87b9e5bfcf0f5523f7edd53f75b23eda6b27bb49ffa97d69a1d176b8fe4786d959aeeb00d4380beab71c9f7e6b7c7298'
sha512sums=('99095b39ed600c3a89ebc0d377a2fc2522b3623a56b0f6de2df50a3c6e0148c67c28c0f2d8dec28bbdf5c62cf29b3579429a79ed00440570643778a9871022b6'
'SKIP'
'b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3'
'ef479a246dc98f882a05ca56a1c2872cc67ced154c625790070b887858ddc250d55b1295db82c9122e5ecd3c2c9c712ec9718e28d0a9d21ff6a230eb6c5010ce'
'ac1d33d434aca2a0ad6e70800073deeaefc02b8fd72656b682ca833ee0cffe10dfa19a9355388700cab46ffbf9421c007d00ed04c7fa562698ff81e70db5f283'
'ad17d6f4f2cc83841c1c89623c339ec3ee94f6084ea980e2c8cbc3903854c85e5396e31bfd8dc90745b41794670903d854c4d282d8adec263087a9d47b226ccc')
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key

View file

@ -1,36 +0,0 @@
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
+++ vlc-3.0.13/configure.ac 2021-05-03 16:10:00.342592591 +0200
@@ -4016,7 +4016,7 @@
dnl
dnl SRT plugin
dnl
-PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2 srt < 1.3.0], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
+PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
EXTEND_HELP_STRING([Visualisations and Video filter plugins:])
dnl
diff -ruN a/modules/access/srt.c b/modules/access/srt.c
--- a/modules/access/srt.c 2018-04-23 10:03:39.000000000 +0200
+++ b/modules/access/srt.c 2020-09-26 10:35:18.830149487 +0200
@@ -165,7 +165,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_stream, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
psz_passphrase = var_InheritString( p_stream, "passphrase" );
diff -ruN a/modules/access_output/srt.c b/modules/access_output/srt.c
--- a/modules/access_output/srt.c 2018-04-06 11:22:51.000000000 +0200
+++ b/modules/access_output/srt.c 2020-09-26 10:35:03.386828120 +0200
@@ -162,7 +162,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_access, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
if ( psz_passphrase != NULL && psz_passphrase[0] != '\0')