core/systemd to 217-7

This commit is contained in:
Kevin Mihelich 2014-11-22 16:06:32 +00:00
parent f1d7bdaaf2
commit d4ed747745
3 changed files with 37 additions and 3 deletions

View file

@ -0,0 +1,32 @@
From 8232e39e7cf32071e11b3b04839e6c98fbc81d0f Mon Sep 17 00:00:00 2001
From: Colin Guthrie <colin@mageia.org>
Date: Wed, 5 Nov 2014 15:29:41 +0000
Subject: [PATCH] udev hwdb: Change error message regarding missing hwdb.bin
back to debug.
When used in an initramfs, it's expected that the hwdb.bin file is
not present (it makes for a very large initramfs otherwise).
While it's nice to tell the user about this, as it's not strictly
speaking an error we really shouldn't be so forceful in our
reporting.
---
src/libudev/libudev-hwdb.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/libudev/libudev-hwdb.c b/src/libudev/libudev-hwdb.c
index a1cfc0b..0716072 100644
--- a/src/libudev/libudev-hwdb.c
+++ b/src/libudev/libudev-hwdb.c
@@ -296,7 +296,7 @@ _public_ struct udev_hwdb *udev_hwdb_new(struct udev *udev) {
}
if (!hwdb->f) {
- udev_err(udev, "hwdb.bin does not exist, please run udevadm hwdb --update");
+ udev_dbg(udev, "hwdb.bin does not exist, please run udevadm hwdb --update");
udev_hwdb_unref(hwdb);
return NULL;
}
--
2.1.3

View file

@ -7,7 +7,7 @@
pkgbase=systemd
pkgname=('systemd' 'libsystemd' 'systemd-sysvcompat')
pkgver=217
pkgrel=6
pkgrel=7
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/systemd"
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gobject-introspection' 'gperf'
@ -24,6 +24,7 @@ source=("http://www.freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz"
'0001-units-order-sd-journal-flush-after-sd-remount-fs.patch'
'0001-units-make-systemd-journald.service-Type-notify.patch'
'0001-shutdown-fix-arguments-to-run-initramfs-shutdown.patch'
'0001-udev-hwdb-Change-error-message-regarding-missing-hwd.patch'
'initcpio-hook-udev'
'initcpio-install-systemd'
'initcpio-install-udev')
@ -36,7 +37,8 @@ md5sums=('e68dbff3cc19f66e341572d9fb2ffa89'
'92497d06e0af615be4b368fe615109c0'
'a321d62d6ffada9e6976bdd339fa3219'
'f72e8d086172177c224f0ce48ef54222'
'29245f7a240bfba66e2b1783b63b6b40'
'6326988822e9d18217525b2cb25cec1d'
'90ea67a7bb237502094914622a39e281'
'107c489f27c667be4101aecd3369b355'
'bde43090d4ac0ef048e3eaee8202a407')

View file

@ -2,7 +2,7 @@
run_earlyhook() {
kmod static-nodes --format=tmpfiles --output=/run/tmpfiles.d/kmod.conf
systemd-tmpfiles --prefix=/dev --create
systemd-tmpfiles --prefix=/dev --create --boot
/usr/lib/systemd/systemd-udevd --daemon --resolve-names=never
udevd_running=1
}