mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-armv5-rc to 4.8.rc5-1
This commit is contained in:
parent
6e9807fdb5
commit
d4fc60b809
6 changed files with 13 additions and 62 deletions
|
@ -1,7 +1,7 @@
|
|||
From 1e1f9bd80a6175639d9eacd7619df85eae120f9f Mon Sep 17 00:00:00 2001
|
||||
From 379e520446260307da5e76fb750edfe84ab12703 Mon Sep 17 00:00:00 2001
|
||||
From: Douglas Gilbert <[mailto:dgilbert@interlog.com]>
|
||||
Date: Mon, 12 Aug 2013 10:36:25 -0500
|
||||
Subject: [PATCH 1/4] at91: ariag25 updates
|
||||
Subject: [PATCH 1/3] at91: ariag25 updates
|
||||
|
||||
v2: dropped at91sam9x5 usart fix, as merged mainline
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From d19d5b3ba0d66be4b321995019c92ee6603cd658 Mon Sep 17 00:00:00 2001
|
||||
From 80092d4a5040e235bc0a348cd0a89443bd0580c7 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 13 Jun 2015 13:46:30 -0600
|
||||
Subject: [PATCH 2/4] at91: arietta-g25 support
|
||||
Subject: [PATCH 2/3] at91: arietta-g25 support
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 81c4a76ccdbb38cb396dea44a0e369106b8b9ea0 Mon Sep 17 00:00:00 2001
|
||||
From 384f2e08067ad20dc117c4ac1776d6044f228535 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 3/4] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 3/3] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
|
|
|
@ -1,45 +0,0 @@
|
|||
From 5113578f59cbf01fa77fcce252fca94d0ef935d0 Mon Sep 17 00:00:00 2001
|
||||
From: Daniel Lezcano <daniel.lezcano@linaro.org>
|
||||
Date: Mon, 29 Aug 2016 08:44:03 +0200
|
||||
Subject: [PATCH 4/4] clocksource/drivers/atmel-pit: Fix compilation error
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
The previous fix introduced a check against the ret variable which
|
||||
is not defined, hence producing a compilation error:
|
||||
|
||||
linux/drivers/clocksource/timer-atmel-pit.c: In function ‘at91sam926x_pit_dt_init’:
|
||||
linux/drivers/clocksource/timer-atmel-pit.c:264:2: error: ‘ret’ undeclared (first use in this function)
|
||||
ret = clk_prepare_enable(data->mck);
|
||||
^
|
||||
linux/drivers/clocksource/timer-atmel-pit.c:264:2: note: each undeclared identifier is reported only once for each function it appears in
|
||||
|
||||
Add the missing the variable 'ret'.
|
||||
|
||||
Fixes: 504f34c9e45c "clocksource/drivers/atmel-pit: Convert init function to return error"
|
||||
Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
|
||||
Cc: alexandre.belloni@free-electrons.com
|
||||
Cc: motobud@gmail.com
|
||||
Cc: realbright@lgcns.com
|
||||
Link: http://lkml.kernel.org/r/1472453043-24287-1-git-send-email-daniel.lezcano@linaro.org
|
||||
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
|
||||
---
|
||||
drivers/clocksource/timer-atmel-pit.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/drivers/clocksource/timer-atmel-pit.c b/drivers/clocksource/timer-atmel-pit.c
|
||||
index 3494bc5..7f0f5b2 100644
|
||||
--- a/drivers/clocksource/timer-atmel-pit.c
|
||||
+++ b/drivers/clocksource/timer-atmel-pit.c
|
||||
@@ -240,6 +240,7 @@ static int __init at91sam926x_pit_common_init(struct pit_data *data)
|
||||
static int __init at91sam926x_pit_dt_init(struct device_node *node)
|
||||
{
|
||||
struct pit_data *data;
|
||||
+ int ret;
|
||||
|
||||
data = kzalloc(sizeof(*data), GFP_KERNEL);
|
||||
if (!data)
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=2
|
||||
|
||||
_rcver=4.8
|
||||
_rcrel=4
|
||||
_rcrel=5
|
||||
|
||||
pkgbase=linux-armv5-rc
|
||||
_srcname=linux-4.$((${_rcver##*.}-1))
|
||||
|
@ -24,15 +24,13 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0001-at91-ariag25-updates.patch'
|
||||
'0002-at91-arietta-g25-support.patch'
|
||||
'0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch'
|
||||
'config')
|
||||
md5sums=('5276563eb1f39a048e4a8a887408c031'
|
||||
'a0c0753ff460ff35ef9908ecc97fa943'
|
||||
'f17a49529c9105b1ea685f3a326b540e'
|
||||
'b1a4bd88725f79ad85630cac6a4184e2'
|
||||
'a0f5d7cc82d7374c181debe51f2f2cd9'
|
||||
'456df10122a1b902e94e872d67364950'
|
||||
'0365059a0cff74c099ca298e700aada1')
|
||||
'ea5b8a7699091e955e7e77f6a71ecc89'
|
||||
'f09c336bd3d1ad79602c6050e695b098'
|
||||
'f125930e96c46d14ca757e710e26ae34'
|
||||
'54d78627bfeae847edae8f97d572479c'
|
||||
'f34a04bcdd4ff1ff9ed5d62192e29865')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
@ -44,7 +42,6 @@ prepare() {
|
|||
git apply ../0001-at91-ariag25-updates.patch
|
||||
git apply ../0002-at91-arietta-g25-support.patch
|
||||
git apply ../0003-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0004-clocksource-drivers-atmel-pit-Fix-compilation-error.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 4.8.0-rc3-1 Kernel Configuration
|
||||
# Linux/arm 4.8.0-rc5-1 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_ARM_HAS_SG_CHAIN=y
|
||||
|
@ -1494,7 +1494,6 @@ CONFIG_ATMEL_SSC=y
|
|||
# CONFIG_ISL29003 is not set
|
||||
# CONFIG_ISL29020 is not set
|
||||
# CONFIG_SENSORS_TSL2550 is not set
|
||||
# CONFIG_SENSORS_BH1780 is not set
|
||||
# CONFIG_SENSORS_BH1770 is not set
|
||||
# CONFIG_SENSORS_APDS990X is not set
|
||||
# CONFIG_HMC6352 is not set
|
||||
|
|
Loading…
Reference in a new issue