mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/soundtouch to 1.8.0-1.1, v5 fix
This commit is contained in:
parent
da9fe74f3e
commit
d5643d27a1
2 changed files with 32 additions and 3 deletions
|
@ -3,21 +3,25 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - --with-pic for v6h/v7h
|
||||
# - patch to fix v5 softfp issues
|
||||
|
||||
pkgname=soundtouch
|
||||
pkgver=1.8.0
|
||||
pkgrel=1
|
||||
pkgrel=1.1
|
||||
pkgdesc="An audio processing library"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.surina.net/soundtouch/"
|
||||
license=('LGPL')
|
||||
depends=('gcc-libs')
|
||||
source=(http://www.surina.net/soundtouch/${pkgname}-${pkgver}.tar.gz)
|
||||
sha1sums=('2cee2c63194227b4a58da01a7cd92b8632f139cd')
|
||||
source=(http://www.surina.net/soundtouch/${pkgname}-${pkgver}.tar.gz
|
||||
dont-use-integers-if-softfp.patch)
|
||||
sha1sums=('2cee2c63194227b4a58da01a7cd92b8632f139cd'
|
||||
'893fafdca92cc48cd136ca05c05de0ff2063ebc9')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}
|
||||
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADER/' configure.ac
|
||||
patch -p1 -i ../dont-use-integers-if-softfp.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
25
extra/soundtouch/dont-use-integers-if-softfp.patch
Normal file
25
extra/soundtouch/dont-use-integers-if-softfp.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
Description: Do not use integer samples when __SOFTFP__ is defined
|
||||
On armel __SOFTFP__ is defined. Hence in 1.7.1 SAMPLETYPE changed from float to
|
||||
short. Unfortunately, this changes some function signatures and thus breaks the
|
||||
ABI.
|
||||
Author: Sebastian Ramacher <sramacher@debian.org>
|
||||
Bug-Debian: http://bugs.debian.org/723681
|
||||
Forwarded: not-needed
|
||||
Last-Update: 2013-09-19
|
||||
|
||||
--- a/include/STTypes.h
|
||||
+++ b/include/STTypes.h
|
||||
@@ -89,13 +89,6 @@
|
||||
/// runtime performance so recommendation is to keep this off.
|
||||
// #define USE_MULTICH_ALWAYS
|
||||
|
||||
- #if (defined(__SOFTFP__))
|
||||
- // For Android compilation: Force use of Integer samples in case that
|
||||
- // compilation uses soft-floating point emulation - soft-fp is way too slow
|
||||
- #undef SOUNDTOUCH_FLOAT_SAMPLES
|
||||
- #define SOUNDTOUCH_INTEGER_SAMPLES 1
|
||||
- #endif
|
||||
-
|
||||
#if !(SOUNDTOUCH_INTEGER_SAMPLES || SOUNDTOUCH_FLOAT_SAMPLES)
|
||||
|
||||
/// Choose either 32bit floating point or 16bit integer sampletype
|
Loading…
Reference in a new issue