mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
alarm/kodi-rpi to 21.2-2
This commit is contained in:
parent
1a19418f0b
commit
d5d5769711
4 changed files with 15 additions and 475 deletions
|
@ -1,456 +0,0 @@
|
|||
diff --git a/xbmc/utils/EGLFence.cpp b/xbmc/utils/EGLFence.cpp
|
||||
index 9d0065bdaf..535e3bce31 100644
|
||||
--- a/xbmc/utils/EGLFence.cpp
|
||||
+++ b/xbmc/utils/EGLFence.cpp
|
||||
@@ -22,14 +22,6 @@ CEGLFence::CEGLFence(EGLDisplay display)
|
||||
m_eglGetSyncAttribKHR(
|
||||
CEGLUtils::GetRequiredProcAddress<PFNEGLGETSYNCATTRIBKHRPROC>("eglGetSyncAttribKHR"))
|
||||
{
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- m_eglDupNativeFenceFDANDROID =
|
||||
- CEGLUtils::GetRequiredProcAddress<PFNEGLDUPNATIVEFENCEFDANDROIDPROC>(
|
||||
- "eglDupNativeFenceFDANDROID");
|
||||
- m_eglClientWaitSyncKHR =
|
||||
- CEGLUtils::GetRequiredProcAddress<PFNEGLCLIENTWAITSYNCKHRPROC>("eglClientWaitSyncKHR");
|
||||
- m_eglWaitSyncKHR = CEGLUtils::GetRequiredProcAddress<PFNEGLWAITSYNCKHRPROC>("eglWaitSyncKHR");
|
||||
-#endif
|
||||
}
|
||||
|
||||
void CEGLFence::CreateFence()
|
||||
@@ -79,65 +71,3 @@ bool CEGLFence::IsSignaled()
|
||||
|
||||
return false;
|
||||
}
|
||||
-
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
-EGLSyncKHR CEGLFence::CreateFence(int fd)
|
||||
-{
|
||||
- CEGLAttributes<1> attributeList;
|
||||
- attributeList.Add({{EGL_SYNC_NATIVE_FENCE_FD_ANDROID, fd}});
|
||||
-
|
||||
- EGLSyncKHR fence =
|
||||
- m_eglCreateSyncKHR(m_display, EGL_SYNC_NATIVE_FENCE_ANDROID, attributeList.Get());
|
||||
-
|
||||
- if (fence == EGL_NO_SYNC_KHR)
|
||||
- {
|
||||
- CEGLUtils::Log(LOGERROR, "failed to create EGL sync object");
|
||||
- return nullptr;
|
||||
- }
|
||||
-
|
||||
- return fence;
|
||||
-}
|
||||
-
|
||||
-void CEGLFence::CreateGPUFence()
|
||||
-{
|
||||
- m_gpuFence = CreateFence(EGL_NO_NATIVE_FENCE_FD_ANDROID);
|
||||
-}
|
||||
-
|
||||
-void CEGLFence::CreateKMSFence(int fd)
|
||||
-{
|
||||
- m_kmsFence = CreateFence(fd);
|
||||
-}
|
||||
-
|
||||
-EGLint CEGLFence::FlushFence()
|
||||
-{
|
||||
- EGLint fd = m_eglDupNativeFenceFDANDROID(m_display, m_gpuFence);
|
||||
- if (fd == EGL_NO_NATIVE_FENCE_FD_ANDROID)
|
||||
- CEGLUtils::Log(LOGERROR, "failed to duplicate EGL fence fd");
|
||||
-
|
||||
- m_eglDestroySyncKHR(m_display, m_gpuFence);
|
||||
-
|
||||
- return fd;
|
||||
-}
|
||||
-
|
||||
-void CEGLFence::WaitSyncGPU()
|
||||
-{
|
||||
- if (!m_kmsFence)
|
||||
- return;
|
||||
-
|
||||
- if (m_eglWaitSyncKHR(m_display, m_kmsFence, 0) != EGL_TRUE)
|
||||
- CEGLUtils::Log(LOGERROR, "failed to create EGL sync point");
|
||||
-}
|
||||
-
|
||||
-void CEGLFence::WaitSyncCPU()
|
||||
-{
|
||||
- if (!m_kmsFence)
|
||||
- return;
|
||||
-
|
||||
- EGLint status{EGL_FALSE};
|
||||
-
|
||||
- while (status != EGL_CONDITION_SATISFIED_KHR)
|
||||
- status = m_eglClientWaitSyncKHR(m_display, m_kmsFence, 0, EGL_FOREVER_KHR);
|
||||
-
|
||||
- m_eglDestroySyncKHR(m_display, m_kmsFence);
|
||||
-}
|
||||
-#endif
|
||||
diff --git a/xbmc/utils/EGLFence.h b/xbmc/utils/EGLFence.h
|
||||
index 03c246b60b..bd96444e47 100644
|
||||
--- a/xbmc/utils/EGLFence.h
|
||||
+++ b/xbmc/utils/EGLFence.h
|
||||
@@ -30,14 +30,6 @@ public:
|
||||
void DestroyFence();
|
||||
bool IsSignaled();
|
||||
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- void CreateKMSFence(int fd);
|
||||
- void CreateGPUFence();
|
||||
- EGLint FlushFence();
|
||||
- void WaitSyncGPU();
|
||||
- void WaitSyncCPU();
|
||||
-#endif
|
||||
-
|
||||
private:
|
||||
EGLDisplay m_display{nullptr};
|
||||
EGLSyncKHR m_fence{nullptr};
|
||||
@@ -45,17 +37,6 @@ private:
|
||||
PFNEGLCREATESYNCKHRPROC m_eglCreateSyncKHR{nullptr};
|
||||
PFNEGLDESTROYSYNCKHRPROC m_eglDestroySyncKHR{nullptr};
|
||||
PFNEGLGETSYNCATTRIBKHRPROC m_eglGetSyncAttribKHR{nullptr};
|
||||
-
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- EGLSyncKHR CreateFence(int fd);
|
||||
-
|
||||
- EGLSyncKHR m_gpuFence{EGL_NO_SYNC_KHR};
|
||||
- EGLSyncKHR m_kmsFence{EGL_NO_SYNC_KHR};
|
||||
-
|
||||
- PFNEGLDUPNATIVEFENCEFDANDROIDPROC m_eglDupNativeFenceFDANDROID{nullptr};
|
||||
- PFNEGLCLIENTWAITSYNCKHRPROC m_eglClientWaitSyncKHR{nullptr};
|
||||
- PFNEGLWAITSYNCKHRPROC m_eglWaitSyncKHR{nullptr};
|
||||
-#endif
|
||||
};
|
||||
|
||||
}
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbm.cpp b/xbmc/windowing/gbm/WinSystemGbm.cpp
|
||||
index f334156d89..34c8c16fe4 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbm.cpp
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbm.cpp
|
||||
@@ -278,7 +278,7 @@ void CWinSystemGbm::UpdateDisplayHardwareScaling(const RESOLUTION_INFO& resInfo)
|
||||
SetFullScreen(true, resMutable, false);
|
||||
}
|
||||
|
||||
-void CWinSystemGbm::FlipPage(bool rendered, bool videoLayer, bool async)
|
||||
+void CWinSystemGbm::FlipPage(bool rendered, bool videoLayer)
|
||||
{
|
||||
if (m_videoLayerBridge && !videoLayer)
|
||||
{
|
||||
@@ -293,7 +293,7 @@ void CWinSystemGbm::FlipPage(bool rendered, bool videoLayer, bool async)
|
||||
bo = m_GBM->GetDevice()->GetSurface()->LockFrontBuffer()->Get();
|
||||
}
|
||||
|
||||
- m_DRM->FlipPage(bo, rendered, videoLayer, async);
|
||||
+ m_DRM->FlipPage(bo, rendered, videoLayer);
|
||||
|
||||
if (m_videoLayerBridge && !videoLayer)
|
||||
{
|
||||
@@ -310,14 +310,14 @@ bool CWinSystemGbm::UseLimitedColor()
|
||||
bool CWinSystemGbm::Hide()
|
||||
{
|
||||
bool ret = m_DRM->SetActive(false);
|
||||
- FlipPage(false, false, false);
|
||||
+ FlipPage(false, false);
|
||||
return ret;
|
||||
}
|
||||
|
||||
bool CWinSystemGbm::Show(bool raise)
|
||||
{
|
||||
bool ret = m_DRM->SetActive(true);
|
||||
- FlipPage(false, false, false);
|
||||
+ FlipPage(false, false);
|
||||
return ret;
|
||||
}
|
||||
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbm.h b/xbmc/windowing/gbm/WinSystemGbm.h
|
||||
index 879d0f58f8..a800acef6b 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbm.h
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbm.h
|
||||
@@ -49,7 +49,7 @@ public:
|
||||
bool DisplayHardwareScalingEnabled() override;
|
||||
void UpdateDisplayHardwareScaling(const RESOLUTION_INFO& resInfo) override;
|
||||
|
||||
- void FlipPage(bool rendered, bool videoLayer, bool async);
|
||||
+ void FlipPage(bool rendered, bool videoLayer);
|
||||
|
||||
bool CanDoWindowed() override { return false; }
|
||||
void UpdateResolutions() override;
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbmEGLContext.cpp b/xbmc/windowing/gbm/WinSystemGbmEGLContext.cpp
|
||||
index ee27fba1bd..83a59413f7 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbmEGLContext.cpp
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbmEGLContext.cpp
|
||||
@@ -58,17 +58,6 @@ bool CWinSystemGbmEGLContext::InitWindowSystemEGL(EGLint renderableType, EGLint
|
||||
return false;
|
||||
}
|
||||
|
||||
- if (CEGLUtils::HasExtension(m_eglContext.GetEGLDisplay(), "EGL_ANDROID_native_fence_sync") &&
|
||||
- CEGLUtils::HasExtension(m_eglContext.GetEGLDisplay(), "EGL_KHR_fence_sync"))
|
||||
- {
|
||||
- m_eglFence = std::make_unique<KODI::UTILS::EGL::CEGLFence>(m_eglContext.GetEGLDisplay());
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- CLog::Log(LOGWARNING, "[GBM] missing support for EGL_KHR_fence_sync and "
|
||||
- "EGL_ANDROID_native_fence_sync - performance may be impacted");
|
||||
- }
|
||||
-
|
||||
return true;
|
||||
}
|
||||
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbmEGLContext.h b/xbmc/windowing/gbm/WinSystemGbmEGLContext.h
|
||||
index fbd52354ee..84f863d6d3 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbmEGLContext.h
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbmEGLContext.h
|
||||
@@ -9,7 +9,6 @@
|
||||
#pragma once
|
||||
|
||||
#include "WinSystemGbm.h"
|
||||
-#include "utils/EGLFence.h"
|
||||
#include "utils/EGLUtils.h"
|
||||
#include "windowing/linux/WinSystemEGL.h"
|
||||
|
||||
@@ -47,8 +46,6 @@ protected:
|
||||
bool InitWindowSystemEGL(EGLint renderableType, EGLint apiType);
|
||||
virtual bool CreateContext() = 0;
|
||||
|
||||
- std::unique_ptr<KODI::UTILS::EGL::CEGLFence> m_eglFence;
|
||||
-
|
||||
struct delete_CVaapiProxy
|
||||
{
|
||||
void operator()(CVaapiProxy *p) const;
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbmGLContext.cpp b/xbmc/windowing/gbm/WinSystemGbmGLContext.cpp
|
||||
index adbb539f21..e4ff49c618 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbmGLContext.cpp
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbmGLContext.cpp
|
||||
@@ -119,37 +119,13 @@ void CWinSystemGbmGLContext::PresentRender(bool rendered, bool videoLayer)
|
||||
{
|
||||
if (rendered)
|
||||
{
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- if (m_eglFence)
|
||||
- {
|
||||
- int fd = m_DRM->TakeOutFenceFd();
|
||||
- if (fd != -1)
|
||||
- {
|
||||
- m_eglFence->CreateKMSFence(fd);
|
||||
- m_eglFence->WaitSyncGPU();
|
||||
- }
|
||||
-
|
||||
- m_eglFence->CreateGPUFence();
|
||||
- }
|
||||
-#endif
|
||||
-
|
||||
if (!m_eglContext.TrySwapBuffers())
|
||||
{
|
||||
CEGLUtils::Log(LOGERROR, "eglSwapBuffers failed");
|
||||
throw std::runtime_error("eglSwapBuffers failed");
|
||||
}
|
||||
-
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- if (m_eglFence)
|
||||
- {
|
||||
- int fd = m_eglFence->FlushFence();
|
||||
- m_DRM->SetInFenceFd(fd);
|
||||
-
|
||||
- m_eglFence->WaitSyncCPU();
|
||||
- }
|
||||
-#endif
|
||||
}
|
||||
- CWinSystemGbm::FlipPage(rendered, videoLayer, static_cast<bool>(m_eglFence));
|
||||
+ CWinSystemGbm::FlipPage(rendered, videoLayer);
|
||||
|
||||
if (m_dispReset && m_dispResetTimer.IsTimePast())
|
||||
{
|
||||
diff --git a/xbmc/windowing/gbm/WinSystemGbmGLESContext.cpp b/xbmc/windowing/gbm/WinSystemGbmGLESContext.cpp
|
||||
index ad80abf46c..0d071c31f1 100644
|
||||
--- a/xbmc/windowing/gbm/WinSystemGbmGLESContext.cpp
|
||||
+++ b/xbmc/windowing/gbm/WinSystemGbmGLESContext.cpp
|
||||
@@ -128,38 +128,13 @@ void CWinSystemGbmGLESContext::PresentRender(bool rendered, bool videoLayer)
|
||||
{
|
||||
if (rendered)
|
||||
{
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- if (m_eglFence)
|
||||
- {
|
||||
- int fd = m_DRM->TakeOutFenceFd();
|
||||
- if (fd != -1)
|
||||
- {
|
||||
- m_eglFence->CreateKMSFence(fd);
|
||||
- m_eglFence->WaitSyncGPU();
|
||||
- }
|
||||
-
|
||||
- m_eglFence->CreateGPUFence();
|
||||
- }
|
||||
-#endif
|
||||
-
|
||||
if (!m_eglContext.TrySwapBuffers())
|
||||
{
|
||||
CEGLUtils::Log(LOGERROR, "eglSwapBuffers failed");
|
||||
throw std::runtime_error("eglSwapBuffers failed");
|
||||
}
|
||||
-
|
||||
-#if defined(EGL_ANDROID_native_fence_sync) && defined(EGL_KHR_fence_sync)
|
||||
- if (m_eglFence)
|
||||
- {
|
||||
- int fd = m_eglFence->FlushFence();
|
||||
- m_DRM->SetInFenceFd(fd);
|
||||
-
|
||||
- m_eglFence->WaitSyncCPU();
|
||||
- }
|
||||
-#endif
|
||||
}
|
||||
-
|
||||
- CWinSystemGbm::FlipPage(rendered, videoLayer, static_cast<bool>(m_eglFence));
|
||||
+ CWinSystemGbm::FlipPage(rendered, videoLayer);
|
||||
|
||||
if (m_dispReset && m_dispResetTimer.IsTimePast())
|
||||
{
|
||||
diff --git a/xbmc/windowing/gbm/drm/DRMAtomic.cpp b/xbmc/windowing/gbm/drm/DRMAtomic.cpp
|
||||
index ff7f137d60..029b5cae81 100644
|
||||
--- a/xbmc/windowing/gbm/drm/DRMAtomic.cpp
|
||||
+++ b/xbmc/windowing/gbm/drm/DRMAtomic.cpp
|
||||
@@ -111,11 +111,6 @@ void CDRMAtomic::DrmAtomicCommit(int fb_id, int flags, bool rendered, bool video
|
||||
AddProperty(m_gui_plane, "CRTC_H", m_mode->vdisplay);
|
||||
}
|
||||
|
||||
- if (m_inFenceFd != -1)
|
||||
- {
|
||||
- AddProperty(m_crtc, "OUT_FENCE_PTR", reinterpret_cast<uint64_t>(&m_outFenceFd));
|
||||
- AddProperty(m_gui_plane, "IN_FENCE_FD", m_inFenceFd);
|
||||
- }
|
||||
}
|
||||
else if (videoLayer && !CServiceBroker::GetGUI()->GetWindowManager().HasVisibleControls())
|
||||
{
|
||||
@@ -151,12 +146,6 @@ void CDRMAtomic::DrmAtomicCommit(int fb_id, int flags, bool rendered, bool video
|
||||
strerror(errno));
|
||||
}
|
||||
|
||||
- if (m_inFenceFd != -1)
|
||||
- {
|
||||
- close(m_inFenceFd);
|
||||
- m_inFenceFd = -1;
|
||||
- }
|
||||
-
|
||||
if (flags & DRM_MODE_ATOMIC_ALLOW_MODESET)
|
||||
{
|
||||
if (drmModeDestroyPropertyBlob(m_fd, blob_id) != 0)
|
||||
@@ -171,10 +160,9 @@ void CDRMAtomic::DrmAtomicCommit(int fb_id, int flags, bool rendered, bool video
|
||||
m_req = m_atomicRequestQueue.back().get();
|
||||
}
|
||||
|
||||
-void CDRMAtomic::FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async)
|
||||
+void CDRMAtomic::FlipPage(struct gbm_bo *bo, bool rendered, bool videoLayer)
|
||||
{
|
||||
struct drm_fb *drm_fb = nullptr;
|
||||
- uint32_t flags = 0;
|
||||
|
||||
if (rendered)
|
||||
{
|
||||
@@ -189,11 +177,10 @@ void CDRMAtomic::FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, boo
|
||||
CLog::Log(LOGERROR, "CDRMAtomic::{} - Failed to get a new FBO", __FUNCTION__);
|
||||
return;
|
||||
}
|
||||
-
|
||||
- if (async && !m_need_modeset)
|
||||
- flags |= DRM_MODE_ATOMIC_NONBLOCK;
|
||||
}
|
||||
|
||||
+ uint32_t flags = 0;
|
||||
+
|
||||
if (m_need_modeset)
|
||||
{
|
||||
flags |= DRM_MODE_ATOMIC_ALLOW_MODESET;
|
||||
diff --git a/xbmc/windowing/gbm/drm/DRMAtomic.h b/xbmc/windowing/gbm/drm/DRMAtomic.h
|
||||
index 6b19657587..ca2cd9a1d0 100644
|
||||
--- a/xbmc/windowing/gbm/drm/DRMAtomic.h
|
||||
+++ b/xbmc/windowing/gbm/drm/DRMAtomic.h
|
||||
@@ -27,7 +27,7 @@ class CDRMAtomic : public CDRMUtils
|
||||
public:
|
||||
CDRMAtomic() = default;
|
||||
~CDRMAtomic() override = default;
|
||||
- void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async) override;
|
||||
+ void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer) override;
|
||||
bool SetVideoMode(const RESOLUTION_INFO& res, struct gbm_bo* bo) override;
|
||||
bool SetActive(bool active) override;
|
||||
bool InitDrm() override;
|
||||
diff --git a/xbmc/windowing/gbm/drm/DRMLegacy.cpp b/xbmc/windowing/gbm/drm/DRMLegacy.cpp
|
||||
index 4e9c3a6b9f..418d067e70 100644
|
||||
--- a/xbmc/windowing/gbm/drm/DRMLegacy.cpp
|
||||
+++ b/xbmc/windowing/gbm/drm/DRMLegacy.cpp
|
||||
@@ -108,7 +108,7 @@ bool CDRMLegacy::QueueFlip(struct gbm_bo *bo)
|
||||
return true;
|
||||
}
|
||||
|
||||
-void CDRMLegacy::FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async)
|
||||
+void CDRMLegacy::FlipPage(struct gbm_bo *bo, bool rendered, bool videoLayer)
|
||||
{
|
||||
if (rendered || videoLayer)
|
||||
{
|
||||
diff --git a/xbmc/windowing/gbm/drm/DRMLegacy.h b/xbmc/windowing/gbm/drm/DRMLegacy.h
|
||||
index e763f298f7..2b7ff45617 100644
|
||||
--- a/xbmc/windowing/gbm/drm/DRMLegacy.h
|
||||
+++ b/xbmc/windowing/gbm/drm/DRMLegacy.h
|
||||
@@ -22,7 +22,7 @@ class CDRMLegacy : public CDRMUtils
|
||||
public:
|
||||
CDRMLegacy() = default;
|
||||
~CDRMLegacy() override = default;
|
||||
- void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async) override;
|
||||
+ void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer) override;
|
||||
bool SetVideoMode(const RESOLUTION_INFO& res, struct gbm_bo* bo) override;
|
||||
bool SetActive(bool active) override;
|
||||
bool InitDrm() override;
|
||||
diff --git a/xbmc/windowing/gbm/drm/DRMUtils.h b/xbmc/windowing/gbm/drm/DRMUtils.h
|
||||
index f92f716fc4..5327e35570 100644
|
||||
--- a/xbmc/windowing/gbm/drm/DRMUtils.h
|
||||
+++ b/xbmc/windowing/gbm/drm/DRMUtils.h
|
||||
@@ -15,7 +15,6 @@
|
||||
#include "windowing/Resolution.h"
|
||||
#include "windowing/gbm/GBMUtils.h"
|
||||
|
||||
-#include <utility>
|
||||
#include <vector>
|
||||
|
||||
#include <gbm.h>
|
||||
@@ -40,7 +39,7 @@ class CDRMUtils
|
||||
public:
|
||||
CDRMUtils() = default;
|
||||
virtual ~CDRMUtils();
|
||||
- virtual void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async) {}
|
||||
+ virtual void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer) {}
|
||||
virtual bool SetVideoMode(const RESOLUTION_INFO& res, struct gbm_bo* bo) { return false; }
|
||||
virtual bool SetActive(bool active) { return false; }
|
||||
virtual bool InitDrm();
|
||||
@@ -63,13 +62,6 @@ public:
|
||||
static uint32_t FourCCWithAlpha(uint32_t fourcc);
|
||||
static uint32_t FourCCWithoutAlpha(uint32_t fourcc);
|
||||
|
||||
- void SetInFenceFd(int fd) { m_inFenceFd = fd; }
|
||||
- int TakeOutFenceFd()
|
||||
- {
|
||||
- int fd{-1};
|
||||
- return std::exchange(m_outFenceFd, fd);
|
||||
- }
|
||||
-
|
||||
protected:
|
||||
bool OpenDrm(bool needConnector);
|
||||
drm_fb* DrmFbGetFromBo(struct gbm_bo *bo);
|
||||
@@ -86,9 +78,6 @@ protected:
|
||||
int m_width = 0;
|
||||
int m_height = 0;
|
||||
|
||||
- int m_inFenceFd{-1};
|
||||
- int m_outFenceFd{-1};
|
||||
-
|
||||
std::vector<std::unique_ptr<CDRMPlane>> m_planes;
|
||||
|
||||
private:
|
||||
diff --git a/xbmc/windowing/gbm/drm/OffScreenModeSetting.h b/xbmc/windowing/gbm/drm/OffScreenModeSetting.h
|
||||
index bba0db9a53..4270d4ecb2 100644
|
||||
--- a/xbmc/windowing/gbm/drm/OffScreenModeSetting.h
|
||||
+++ b/xbmc/windowing/gbm/drm/OffScreenModeSetting.h
|
||||
@@ -22,7 +22,7 @@ class COffScreenModeSetting : public CDRMUtils
|
||||
public:
|
||||
COffScreenModeSetting() = default;
|
||||
~COffScreenModeSetting() override = default;
|
||||
- void FlipPage(struct gbm_bo* bo, bool rendered, bool videoLayer, bool async) override {}
|
||||
+ void FlipPage(struct gbm_bo *bo, bool rendered, bool videoLayer) override {}
|
||||
bool SetVideoMode(const RESOLUTION_INFO& res, struct gbm_bo *bo) override { return false; }
|
||||
bool SetActive(bool active) override { return false; }
|
||||
bool InitDrm() override;
|
|
@ -15,15 +15,15 @@ pkgname=(
|
|||
'kodi-rpi-eventclients' 'kodi-rpi-tools-texturepacker' 'kodi-rpi-dev'
|
||||
)
|
||||
|
||||
_commitnumber=65793
|
||||
_commit=fa22c8aa85256f3aee8ac9abf024ac75e081c1a1
|
||||
_commitnumber=65923
|
||||
_commit=28071de478f275bafc8da798aa49d041bdeddc87
|
||||
|
||||
# set this to anything to build with clang
|
||||
# recommend manually setting -DUSE_LTO=OFF to -DUSE_LTO=$(nproc) in build()
|
||||
_clangbuild=
|
||||
|
||||
pkgver=21.2
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
arch=('aarch64' 'armv7h')
|
||||
url="https://github.com/graysky2/xbmc/tree/gs-gbm_omega"
|
||||
license=('GPL2')
|
||||
|
@ -70,10 +70,9 @@ source=(
|
|||
https://taglib.github.io/releases/taglib-1.13.1.tar.gz
|
||||
"ArchARM-kodi-init-v$_init_version.tar.gz::https://github.com/graysky2/kodi-standalone-service/archive/v$_init_version.tar.gz"
|
||||
kodi.config.txt
|
||||
0001-temp-revert-fences.patch
|
||||
0002-ffmpeg-build-with-lto-when-duse-lto.patch::https://github.com/xbmc/xbmc/commit/2cc6f1728ccb67ef575fe57680dd42836e3d6a1f.patch
|
||||
0003-taglib-use-1.13.1-for-internal-build-like-LE.patch
|
||||
0004-fix-libnfs-6-compatibility.patch
|
||||
0001-fix-libnfs-6-compatibility.patch
|
||||
0002-taglib-use-1.13.1-for-internal-build-like-LE.patch
|
||||
0003-ffmpeg-build-with-lto-when-duse-lto.patch::https://github.com/xbmc/xbmc/commit/2cc6f1728ccb67ef575fe57680dd42836e3d6a1f.patch
|
||||
)
|
||||
backup=(boot/kodi.config.txt etc/conf.d/kodi-standalone)
|
||||
noextract=(
|
||||
|
@ -87,7 +86,7 @@ noextract=(
|
|||
"libudfread-$_libudfread_version.tar.gz"
|
||||
taglib-1.13.1.tar.gz
|
||||
)
|
||||
sha256sums=('1710bcfeca5d75834179864274f059acfb26952b994eda352979e96c0a610ea8'
|
||||
sha256sums=('5c8d816555e7f6e8b4a44dbdcc2f5664975edfc4ce1105cd60ef032255512256'
|
||||
'f38c4a4e7a4f4da6d8e83b8852489aa3bb6588a915dc41f5ee89d9aad305a06e'
|
||||
'584f62a3896794408d46368e2ecf2c6217ab9c676ce85921b2d68b8961f49dfc'
|
||||
'719130091e3adc9725ba72df808f24a14737a009dca5a4c38c601c0c76449b62'
|
||||
|
@ -99,10 +98,9 @@ sha256sums=('1710bcfeca5d75834179864274f059acfb26952b994eda352979e96c0a610ea8'
|
|||
'c8da2b10f1bfec2cd7dbfcd33f4a2338db0765d851a50583d410bacf055cfd0b'
|
||||
'8f8ab84a0cf3bd382edb118e475b336ca2fe1e1d4da3ad8e4637f8278ed9179c'
|
||||
'5ac76e6ff16d8f0f60a414647bddb13b46402563dd02d69a05e90c0ddbb085f0'
|
||||
'e812fc2f74d71915c3179785a8f99647612bd21ce96f866769ee1bc58682ee3b'
|
||||
'5a2f1c5fa9189d56eaf7e05024071c57e11f92b4eeb68b4bb0555c1fdd66c890'
|
||||
'2cceccdb90c94ef972c2c2cdd1824cb46a783c9611dad334b8cc9044ad221397'
|
||||
'c0efb77425f86e8a743d59529c4ab0b2d634d53413db1c6f71974c000bc31c14'
|
||||
'2cceccdb90c94ef972c2c2cdd1824cb46a783c9611dad334b8cc9044ad221397')
|
||||
'5a2f1c5fa9189d56eaf7e05024071c57e11f92b4eeb68b4bb0555c1fdd66c890')
|
||||
|
||||
prepare() {
|
||||
[[ -d kodi-build ]] && rm -rf kodi-build
|
||||
|
@ -111,16 +109,14 @@ prepare() {
|
|||
|
||||
rm -rf system/certs # remove not needed cacert
|
||||
|
||||
# fix https://forum.kodi.tv/showthread.php?tid=376430
|
||||
patch -p1 -i ../0001-temp-revert-fences.patch
|
||||
|
||||
# honor LTO settings when building ffmpeg
|
||||
patch -p1 -i ../0002-ffmpeg-build-with-lto-when-duse-lto.patch
|
||||
|
||||
patch -p1 -i ../0001-fix-libnfs-6-compatibility.patch
|
||||
|
||||
# modify to use internal taglib v1.13.1 due to build fails for armv7h with v2.0+
|
||||
patch -p1 -i ../0003-taglib-use-1.13.1-for-internal-build-like-LE.patch
|
||||
patch -p1 -i ../0002-taglib-use-1.13.1-for-internal-build-like-LE.patch
|
||||
|
||||
# honor LTO settings when building ffmpeg
|
||||
patch -p1 -i ../0003-ffmpeg-build-with-lto-when-duse-lto.patch
|
||||
|
||||
patch -p1 -i ../0004-fix-libnfs-6-compatibility.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue