community/gnome-software to 3.26.6-1

This commit is contained in:
Kevin Mihelich 2018-02-08 19:48:18 +00:00
parent 6651b57073
commit d5dc928eb8
2 changed files with 5 additions and 51 deletions

View file

@ -1,41 +0,0 @@
From 88f0ba789a24973785444f18dc22e91ab38ea79e Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ball=C3=83=C2=B3=20Gy=C3=83=C2=B6rgy?= <ballogyor@gmail.com>
Date: Thu, 18 Jan 2018 19:41:32 +0100
Subject: [PATCH] Fix build when gtkspell enabled
HAVE_GTKSPELL needs to be defined, otherwise the gtkspell related code never built.
---
meson.build | 1 +
src/meson.build | 4 ++++
2 files changed, 5 insertions(+)
diff --git a/meson.build b/meson.build
index 00f3b2ab..c20f8a6f 100644
--- a/meson.build
+++ b/meson.build
@@ -125,6 +125,7 @@ endif
if get_option('enable-gtkspell')
gtkspell = dependency('gtkspell3-3.0')
+ conf.set('HAVE_GTKSPELL', 1)
endif
if get_option('enable-polkit')
diff --git a/src/meson.build b/src/meson.build
index bf189241..c90366b3 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -100,6 +100,10 @@ if get_option('enable-gnome-desktop')
gnome_software_dependencies += [gnome_desktop]
endif
+if get_option('enable-gtkspell')
+ gnome_software_dependencies += [gtkspell]
+endif
+
executable(
'gnome-software',
resources_src,
--
2.15.1

View file

@ -9,19 +9,17 @@
pkgbase=gnome-software
pkgname=(gnome-software gnome-software-packagekit-plugin)
pkgver=3.26.5
pkgrel=2
pkgver=3.26.6
pkgrel=1
pkgdesc="GNOME Software Tools"
arch=(x86_64)
license=(GPL2)
url="https://wiki.gnome.org/Apps/Software/"
makedepends=(appstream-glib gnome-desktop gtkspell3 libpackagekit-glib flatpak ostree
docbook-xsl git gobject-introspection gtk-doc meson)
_commit=7424bad60e8336079eb7db639e0cc96c99d98354 # tags/3.26.5^0
source=("git+https://git.gnome.org/browse/gnome-software#commit=$_commit"
"0001-Fix-build-when-gtkspell-enabled.patch")
sha256sums=('SKIP'
'c1c4e24d69625f444af32162319fd789f93ad761ea973c0035e5ca3ec761c10a')
_commit=16585115a93f20560d08bc5f53b3ca123174c650 # tags/3.26.6^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-software.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd $pkgbase
@ -30,9 +28,6 @@ pkgver() {
prepare() {
cd $pkgbase
# Fix build when gtkspell enabled
# https://bugzilla.gnome.org/show_bug.cgi?id=792658
patch -Np1 -i ../0001-Fix-build-when-gtkspell-enabled.patch
}
build() {