extra/calligra to 3.2.0-1

This commit is contained in:
Kevin Mihelich 2020-04-24 14:21:57 +00:00
parent 5525977272
commit d74b57967e
9 changed files with 8 additions and 500 deletions

View file

@ -5,19 +5,18 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove makedepend on vc
# - fedora patch to fix ARM build with GCC 6
pkgname=calligra
pkgdesc="A set of applications for productivity and creative usage"
pkgver=3.1.0
pkgrel=32
pkgver=3.2.0
pkgrel=1
arch=(x86_64)
url='https://www.calligra-suite.org/'
license=(FDL1.2 GPL2 LGPL)
depends=(kcmutils knotifyconfig kross kactivities kdiagram libspnav kdelibs4support
gsl openexr kcontacts qca-qt5 poppler-qt5 libodfgen qt5-webkit cauchy khtml)
makedepends=(extra-cmake-modules kdoctools kdesignerplugin boost akonadi-contacts
libwpg okular eigen marble-common pstoedit libvisio libetonyek libwps libgit2 kinit)
gsl openexr kcontacts qca poppler-qt5 libodfgen khtml cauchy)
makedepends=(extra-cmake-modules kdoctools kdesignerplugin kinit libwpg okular eigen marble-common
boost pstoedit libvisio libetonyek libwps libgit2 kcalcore akonadi)
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'libwps: Microsoft Works file word processor format import'
'libvisio: Microsoft Visio import filter'
@ -28,69 +27,19 @@ optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'kirigami2: for Calligra Gemini'
'qt5-quickcontrols: for Calligra Gemini'
'qt5-webengine: for Calligra Gemini')
conflicts=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta
calligra-flow calligra-braindump calligra-gemini calligra-handbook)
replaces=(calligra-devtools calligra-extras calligra-filters calligra-karbon karbon calligra-libs
calligra-plugins calligra-sheets calligra-stage calligra-words calligra-l10n calligra-meta)
for _lang in bs ca ca@valencia cs da de el en_gb es et fi fr gl hu it ja kk nb nl \
pl pt pt_br ru sk sv uk zh_cn zh_tw; do
conflicts+=(calligra-l10n-$_lang)
replaces+=(calligra-l10n-$_lang)
done
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig}
calligra-2.9.11-gcc6_arm.patch
calligra-qt5.11.patch
calligra-qt5.13.patch
calligra-poppler-0.69.patch::"https://cgit.kde.org/calligra.git/patch/?id=a6157182"
calligra-poppler-0.71.patch
calligra-poppler-0.72.patch
calligra-poppler-0.73.patch
calligra-poppler-0.82.patch
calligra-poppler-0.83.patch)
sha256sums=('6818cd6e64136321be217eb57cc7d6ac7c7035191fdb1ee336ebe60bc114e870'
'SKIP'
'33d803c49abefc37f51f824543e889f9e369e86df9ce64d980e0a7dbca2ea27d'
'40ac9fabed8e13c31f6f243bd7e9083c3ec322568991ba84987106b982ffc10a'
'd32a9cda1343f224f5a0cfa2b8122c5571a0dbb09c9948414d6770d9c3814f4d'
'127cc5e0946fbf741279306b4e9d592f5f901a7fab09039fcfc6c7e60193fa80'
'052adc4ea812d7667812ff7867e703327dbe7c1ecad86094fd6772dc09782d87'
'87a09710b9e7e825a46344ddec08eb98b3454d6d067b0177d284733b2342cece'
'ef95f49f69c9f2a5b530e416003f2d6d106bb3c85e8458ae27494c64c8b474a8'
'a2f02dccd8f7748b187dba805220ded95c41bbddc084091794691164184d1b82'
'3877210cc58c11472909c62bdc1678a05deb30051f0180c47893e51bae9182d1')
source=("https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('7e556228665d79e67c062fd1173d6676f0b0d7ceefdd6e1b0bcf9a781ea70951'
'SKIP')
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <foundation@krita.org>
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <danders@get2net.dk>
prepare() {
mkdir -p build
cd $pkgname-$pkgver
# Fix build with Qt 5.11
patch -p1 -i ../calligra-qt5.11.patch
# Fix build with Qt 5.13
patch -p1 -i ../calligra-qt5.13.patch
# Fix build with poppler 0.69
patch -p1 -i ../calligra-poppler-0.69.patch
# Fix build with poppler 0.71
patch -p1 -i ../calligra-poppler-0.71.patch
# Fix build with poppler 0.72
patch -p1 -i ../calligra-poppler-0.72.patch
# Fix build with poppler 0.73
patch -p1 -i ../calligra-poppler-0.73.patch
# Fix build with poppler 0.82
patch -p1 -i ../calligra-poppler-0.82.patch
# Fix build with poppler 0.83
patch -p1 -i ../calligra-poppler-0.83.patch
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
}
build() {
cd build
cmake ../$pkgbase-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

View file

@ -1,12 +0,0 @@
diff -up calligra-2.9.11/libs/flake/KoSnapStrategy.cpp.gcc6_arm calligra-2.9.11/libs/flake/KoSnapStrategy.cpp
--- calligra-2.9.11/libs/flake/KoSnapStrategy.cpp.gcc6_arm 2016-02-02 13:53:15.000000000 -0600
+++ calligra-2.9.11/libs/flake/KoSnapStrategy.cpp 2016-02-08 09:12:39.452896965 -0600
@@ -181,7 +181,7 @@ bool ExtensionSnapStrategy::snap(const Q
Q_ASSERT(isfinite(maxSnapDistance));
const qreal maxDistance = maxSnapDistance * maxSnapDistance;
- qreal minDistances[2] = { HUGE_VAL, HUGE_VAL };
+ qreal minDistances[2] = { (qreal)HUGE_VAL, (qreal)HUGE_VAL };
QPointF snappedPoints[2] = { mousePosition, mousePosition };
QPointF startPoints[2];

View file

@ -1,131 +0,0 @@
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
index 48b08dfa32d..e910dae0756 100644
--- a/filters/karbon/pdf/PdfImport.cpp
+++ b/filters/karbon/pdf/PdfImport.cpp
@@ -88,9 +88,9 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
SvgOutputDev * dev = new SvgOutputDev(m_chain->outputFile());
if (dev->isOk()) {
int rotate = 0;
- GBool useMediaBox = gTrue;
- GBool crop = gFalse;
- GBool printing = gFalse;
+ bool useMediaBox = true;
+ bool crop = false;
+ bool printing = false;
pdfDoc->displayPages(dev, firstPage, lastPage, hDPI, vDPI, rotate, useMediaBox, crop, printing);
dev->dumpContent();
}
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 5692824bc45..43205170991 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -39,7 +39,7 @@ class SvgOutputDev::Private
{
public:
Private(const QString &fname)
- : svgFile(fname), defs(0), body(0), state(gTrue)
+ : svgFile(fname), defs(0), body(0), state(true)
, brush(Qt::SolidPattern) {}
~Private() {
@@ -52,7 +52,7 @@ public:
QString defsData;
QTextStream * defs;
QTextStream * body;
- GBool state;
+ bool state;
QSizeF pageSize;
QPen pen;
QBrush brush;
@@ -62,7 +62,7 @@ SvgOutputDev::SvgOutputDev(const QString &fileName)
: d(new Private(fileName))
{
if (! d->svgFile.open(QIODevice::WriteOnly)) {
- d->state = gFalse;
+ d->state = false;
return;
}
@@ -75,24 +75,24 @@ SvgOutputDev::~SvgOutputDev()
delete d;
}
-GBool SvgOutputDev::isOk()
+bool SvgOutputDev::isOk()
{
return d->state;
}
-GBool SvgOutputDev::upsideDown()
+bool SvgOutputDev::upsideDown()
{
- return gTrue;
+ return true;
}
-GBool SvgOutputDev::useDrawChar()
+bool SvgOutputDev::useDrawChar()
{
- return gFalse;
+ return false;
}
-GBool SvgOutputDev::interpretType3Chars()
+bool SvgOutputDev::interpretType3Chars()
{
- return gFalse;
+ return false;
}
void SvgOutputDev::startPage(int pageNum, GfxState *state, XRef */*xref*/)
@@ -480,7 +480,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- int *maskColors, GBool /*inlineImg*/)
+ int *maskColors, bool /*inlineImg*/)
{
ImageStream * imgStr = new ImageStream(str, width, colorMap->getNumPixelComps(), colorMap->getBits());
imgStr->reset();
@@ -549,7 +549,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- GBool /*interpolate*/, int *maskColors, GBool inlineImg)
+ bool /*interpolate*/, int *maskColors, bool inlineImg)
{
drawImage(state, ref, str, width, height, colorMap, maskColors, inlineImg);
}
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
index 2a4490848bf..cdb1d4e43b1 100644
--- a/filters/karbon/pdf/SvgOutputDev.h
+++ b/filters/karbon/pdf/SvgOutputDev.h
@@ -44,11 +44,11 @@ public:
explicit SvgOutputDev(const QString &fileName);
virtual ~SvgOutputDev();
- GBool isOk();
+ bool isOk();
- virtual GBool upsideDown();
- virtual GBool useDrawChar();
- virtual GBool interpretType3Chars();
+ virtual bool upsideDown();
+ virtual bool useDrawChar();
+ virtual bool interpretType3Chars();
virtual void startPage(int pageNum, GfxState *state, XRef *xref);
virtual void endPage();
@@ -63,10 +63,10 @@ public:
// images
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- int *maskColors, GBool inlineImg);
+ int *maskColors, bool inlineImg);
virtual void drawImage(GfxState *state, Object *ref, Stream *str,
int width, int height, GfxImageColorMap *colorMap,
- GBool interpolate, int *maskColors, GBool inlineImg);
+ bool interpolate, int *maskColors, bool inlineImg);
// styles
virtual void updateAll(GfxState *state);

View file

@ -1,29 +0,0 @@
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 80f01a5f76f..ea69228dbc1 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -407,7 +407,7 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
QString str;
- const char * p = s->getCString();
+ const char * p = s->c_str();
int len = s->getLength();
CharCode code;
Unicode *u = nullptr;
@@ -459,11 +459,11 @@ void SvgOutputDev::drawString(GfxState * state, const GooString * s)
*d->body << " y=\"" << y << "px\"";
if (font && font->getFamily()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->getCString()) << "\"";
- //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getFamily()->c_str()) << "\"";
+ //debugPdf << "font family:" << QString::fromLatin1( font->getFamily()->c_str() );
} else if (font && font->getName()) {
- *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->getCString()) << "\"";
- //debugPdf << "font name:" << QString::fromLatin1( font->getName()->getCString() );
+ *d->body << " font-family=\"" << QString::fromLatin1(font->getName()->c_str()) << "\"";
+ //debugPdf << "font name:" << QString::fromLatin1( font->getName()->c_str() );
}
*d->body << " font-size=\"" << qMax(state->getFontSize(), state->getTransformedFontSize()) << "px\"";

View file

@ -1,32 +0,0 @@
From a1ddd91e6c354e8f0dda40f8a522053c3fa19c39 Mon Sep 17 00:00:00 2001
From: Albert Astals Cid <aacid@kde.org>
Date: Tue, 15 Jan 2019 22:24:08 +0100
Subject: [PATCH] Guchar -> unsigned char
It was just a typdef and it's now gone
---
filters/karbon/pdf/SvgOutputDev.cpp | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
index 80f01a5f76f..1a5aa30bc40 100644
--- a/filters/karbon/pdf/SvgOutputDev.cpp
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
@@ -496,7 +496,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
if (maskColors) {
for (int y = 0; y < height; y++) {
dest = (unsigned int *)(buffer + y * 4 * width);
- Guchar * pix = imgStr->getLine();
+ unsigned char * pix = imgStr->getLine();
colorMap->getRGBLine(pix, dest, width);
for (int x = 0; x < width; x++) {
@@ -515,7 +515,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object *ref, Stream *str,
} else {
for (int y = 0; y < height; y++) {
dest = (unsigned int *)(buffer + y * 4 * width);
- Guchar * pix = imgStr->getLine();
+ unsigned char * pix = imgStr->getLine();
colorMap->getRGBLine(pix, dest, width);
}

View file

@ -1,12 +0,0 @@
diff -upr calligra-3.1.0.orig/filters/karbon/pdf/SvgOutputDev.cpp calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp
--- calligra-3.1.0.orig/filters/karbon/pdf/SvgOutputDev.cpp 2019-11-12 14:55:33.418358543 +0200
+++ calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp 2019-11-12 14:59:26.843199351 +0200
@@ -405,7 +405,7 @@ void SvgOutputDev::drawString(GfxState *
const char * p = s->c_str();
int len = s->getLength();
CharCode code;
- Unicode *u = nullptr;
+ const Unicode *u = nullptr;
int uLen;
double dx, dy, originX, originY;
while (len > 0) {

View file

@ -1,69 +0,0 @@
Source: Timo Gurr <tgurr@exherbo.org>
Upstream: Reported, https://bugs.kde.org/show_bug.cgi?id=414795
Reason: Fix build with poppler 0.83.0
diff -Naur calligra-3.1.0/filters/karbon/pdf/PdfImport.cpp calligra-3.1.0.new/filters/karbon/pdf/PdfImport.cpp
--- calligra-3.1.0/filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:41:13.000000000 +0100
+++ calligra-3.1.0.new/filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:39:03.000000000 +0100
@@ -60,19 +60,17 @@
}
// read config file
- globalParams = new GlobalParams();
+ globalParams.reset(new GlobalParams());
if (! globalParams)
return KoFilter::NotImplemented;
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data());
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0);
if (! pdfDoc) {
- delete globalParams;
return KoFilter::StupidError;
}
if (! pdfDoc->isOk()) {
- delete globalParams;
delete pdfDoc;
return KoFilter::StupidError;
}
@@ -99,7 +97,6 @@
delete dev;
delete pdfDoc;
- delete globalParams;
globalParams = 0;
return KoFilter::OK;
diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.cpp
--- calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:41:14.000000000 +0100
+++ calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:35:30.000000000 +0100
@@ -172,7 +172,7 @@
*d->body << "/>" << endl;
}
-QString SvgOutputDev::convertPath(GfxPath *path)
+QString SvgOutputDev::convertPath(const GfxPath *path)
{
if (! path)
return QString();
@@ -180,7 +180,7 @@
QString output;
for (int i = 0; i < path->getNumSubpaths(); ++i) {
- GfxSubpath * subpath = path->getSubpath(i);
+ const GfxSubpath * subpath = path->getSubpath(i);
if (subpath->getNumPoints() > 0) {
output += QString("M%1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));
int j = 1;
diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.h calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.h
--- calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:41:14.000000000 +0100
+++ calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:30:41.000000000 +0100
@@ -83,7 +83,7 @@
/// Dumps content to svg file
void dumpContent();
private:
- QString convertPath(GfxPath *path);
+ QString convertPath(const GfxPath *path);
QString convertMatrix(const QMatrix &matrix);
QString convertMatrix(const double * matrix);
QString printFill();

View file

@ -1,135 +0,0 @@
From ee83e0f2c251072e47a2799619cdc79efe67e651 Mon Sep 17 00:00:00 2001
From: David Faure <faure@kde.org>
Date: Tue, 3 Apr 2018 00:31:19 +0200
Subject: Fix compilation with Qt 5.11 (missing include)
---
stage/part/KPrPresentationTool.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/stage/part/KPrPresentationTool.cpp b/stage/part/KPrPresentationTool.cpp
index ae743da..3007f91 100644
--- a/stage/part/KPrPresentationTool.cpp
+++ b/stage/part/KPrPresentationTool.cpp
@@ -32,6 +32,7 @@
#include <QDesktopServices>
#include <QUrl>
#include <QDBusConnection>
+#include <QFrame>
#include <KoShape.h>
#include <KoShapeManager.h>
---
From a7ebecb9fbee2190e649c44ed53f1299013baa30 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
Date: Sun, 18 Mar 2018 11:56:57 +0100
Subject: Fix build with Qt 5.11 (missing headers)
Reviewers: #calligra:_3.0, anthonyfieroni, danders
Reviewed By: #calligra:_3.0, anthonyfieroni, danders
Subscribers: anthonyfieroni, danders
Tags: #calligra:_3.0
Differential Revision: https://phabricator.kde.org/D11454
---
libs/widgets/KoCsvImportDialog.cpp | 1 +
libs/widgets/KoPageLayoutWidget.cpp | 2 ++
plugins/chartshape/dialogs/TableEditorDialog.cpp | 1 +
plugins/formulashape/FormulaToolWidget.cpp | 1 +
sheets/dialogs/LayoutDialog.cpp | 1 +
words/part/dialogs/KWAnchoringProperties.cpp | 1 +
words/part/dialogs/KWRunAroundProperties.cpp | 2 ++
15 files changed, 18 insertions(+), 1 deletion(-)
diff --git a/libs/widgets/KoCsvImportDialog.cpp b/libs/widgets/KoCsvImportDialog.cpp
index 0ffdcf6..cdca006 100644
--- a/libs/widgets/KoCsvImportDialog.cpp
+++ b/libs/widgets/KoCsvImportDialog.cpp
@@ -21,6 +21,7 @@
#include "KoCsvImportDialog.h"
// Qt
+#include <QButtonGroup>
#include <QTextCodec>
#include <QTextStream>
diff --git a/libs/widgets/KoPageLayoutWidget.cpp b/libs/widgets/KoPageLayoutWidget.cpp
index f91555c..a3816f9 100644
--- a/libs/widgets/KoPageLayoutWidget.cpp
+++ b/libs/widgets/KoPageLayoutWidget.cpp
@@ -23,6 +23,8 @@
#include <KoUnit.h>
+#include <QButtonGroup>
+
class Q_DECL_HIDDEN KoPageLayoutWidget::Private
{
public:
diff --git a/plugins/chartshape/dialogs/TableEditorDialog.cpp b/plugins/chartshape/dialogs/TableEditorDialog.cpp
index c0d5136..d2a772e 100644
--- a/plugins/chartshape/dialogs/TableEditorDialog.cpp
+++ b/plugins/chartshape/dialogs/TableEditorDialog.cpp
@@ -24,6 +24,7 @@
// Qt
#include <QAbstractItemModel>
+#include <QAction>
// Calligra
#include <KoIcon.h>
diff --git a/plugins/formulashape/FormulaToolWidget.cpp b/plugins/formulashape/FormulaToolWidget.cpp
index ed10919..8f52177 100644
--- a/plugins/formulashape/FormulaToolWidget.cpp
+++ b/plugins/formulashape/FormulaToolWidget.cpp
@@ -30,6 +30,7 @@
#include <QWidgetAction>
#include <QTableWidget>
#include <QAction>
+#include <QHeaderView>
#include <QMenu>
FormulaToolWidget::FormulaToolWidget( KoFormulaTool* tool, QWidget* parent )
diff --git a/sheets/dialogs/LayoutDialog.cpp b/sheets/dialogs/LayoutDialog.cpp
index a0a9832..7d7db53 100644
--- a/sheets/dialogs/LayoutDialog.cpp
+++ b/sheets/dialogs/LayoutDialog.cpp
@@ -36,6 +36,7 @@
#include <math.h>
#include <QIntValidator>
+#include <QButtonGroup>
#include <QCheckBox>
#include <QFrame>
#include <QLabel>
diff --git a/words/part/dialogs/KWAnchoringProperties.cpp b/words/part/dialogs/KWAnchoringProperties.cpp
index d64208c..bfddb3a 100644
--- a/words/part/dialogs/KWAnchoringProperties.cpp
+++ b/words/part/dialogs/KWAnchoringProperties.cpp
@@ -35,6 +35,7 @@
#include <kundo2command.h>
+#include <QButtonGroup>
#include <QComboBox>
const int KWAnchoringProperties::vertRels[4][20] = {
diff --git a/words/part/dialogs/KWRunAroundProperties.cpp b/words/part/dialogs/KWRunAroundProperties.cpp
index e38599a..7e8b2d5 100644
--- a/words/part/dialogs/KWRunAroundProperties.cpp
+++ b/words/part/dialogs/KWRunAroundProperties.cpp
@@ -28,6 +28,8 @@
#include <kundo2command.h>
+#include <QButtonGroup>
+
KWRunAroundProperties::KWRunAroundProperties(FrameConfigSharedState *state)
: m_state(state)
{
--
cgit v0.11.2

View file

@ -1,21 +0,0 @@
From 0c5430697bdcf41a45046107b28014e40c49a11a Mon Sep 17 00:00:00 2001
From: David Faure <faure@kde.org>
Date: Tue, 23 Jul 2019 13:02:34 +0200
Subject: [PATCH] Fix compilation with Qt 5.13 (missing include)
---
sheets/plugins/calendar/CalendarToolWidget.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/sheets/plugins/calendar/CalendarToolWidget.cpp b/sheets/plugins/calendar/CalendarToolWidget.cpp
index b10b23022a2..0c5eeb68cf3 100644
--- a/sheets/plugins/calendar/CalendarToolWidget.cpp
+++ b/sheets/plugins/calendar/CalendarToolWidget.cpp
@@ -30,6 +30,7 @@
#include <kdatepicker.h>
#include <QPushButton>
+#include <QDate>
namespace Calligra
{