extra/mutter to 3.10.2-2

This commit is contained in:
Kevin Mihelich 2013-11-16 17:00:23 +00:00
parent f3ab0d17ad
commit d873af5bde
2 changed files with 41 additions and 3 deletions

View file

@ -0,0 +1,29 @@
From 6b150b3e9f1d16e6c374e178107ab490a18346dd Mon Sep 17 00:00:00 2001
From: Asad Mehmood <asad78611@googlemail.com>
Date: Thu, 17 Oct 2013 16:05:59 +0100
Subject: [PATCH] monitor: expose min-backlight-step
Expose min-backlight-step so that gnome-settings-daemon can
support backlights with less than 10 steps without mutter
normalizing the brightness back to its original value
---
src/core/monitor.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/src/core/monitor.c b/src/core/monitor.c
index 9ec0c2a..6d65f9e 100644
--- a/src/core/monitor.c
+++ b/src/core/monitor.c
@@ -806,6 +806,9 @@ meta_monitor_manager_handle_get_resources (MetaDBusDisplayConfig *skeleton,
g_variant_new_take_string (make_display_name (manager, output)));
g_variant_builder_add (&properties, "{sv}", "backlight",
g_variant_new_int32 (output->backlight));
+ g_variant_builder_add (&properties, "{sv}", "min-backlight-step",
+ g_variant_new_int32 ((output->backlight_max - output->backlight_min) ?
+ 100 / (output->backlight_max - output->backlight_min) : -1));
g_variant_builder_add (&properties, "{sv}", "primary",
g_variant_new_boolean (output->is_primary));
g_variant_builder_add (&properties, "{sv}", "presentation",
--
1.8.4.1

View file

@ -8,7 +8,7 @@
pkgname=mutter pkgname=mutter
pkgver=3.10.2 pkgver=3.10.2
pkgrel=1 pkgrel=2
pkgdesc="A window manager for GNOME" pkgdesc="A window manager for GNOME"
arch=(i686 x86_64) arch=(i686 x86_64)
license=('GPL') license=('GPL')
@ -18,8 +18,17 @@ url="http://www.gnome.org"
groups=('gnome') groups=('gnome')
options=('!libtool' '!emptydirs') options=('!libtool' '!emptydirs')
install=mutter.install install=mutter.install
source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz) source=(http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz
sha256sums=('438163bc7fbab88366b589cab895a1df79eeac389e012c6e26ec559316651100') 0001-monitor-expose-min-backlight-step.patch)
sha256sums=('438163bc7fbab88366b589cab895a1df79eeac389e012c6e26ec559316651100'
'f1ef173d96ac27abdcf765972d2ac434f63bf4629b8bd51c177e8963d07f5eb7')
prepare() {
cd "$pkgname-$pkgver"
# FS#37224
patch -Np1 -i ../0001-monitor-expose-min-backlight-step.patch
}
build() { build() {
cd "$pkgname-$pkgver" cd "$pkgname-$pkgver"