core/systemd to 249-2

This commit is contained in:
Kevin Mihelich 2021-07-11 23:24:27 +00:00
parent 5666788544
commit d875d3f153
2 changed files with 107 additions and 27 deletions

View file

@ -1,4 +1,4 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From f7d07e298c819a81eab965efbdbf53a2ce67fc0e Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 6 Mar 2018 23:39:47 +0100
Subject: [PATCH] Use Arch Linux' device access groups
@ -10,12 +10,81 @@ Content-Transfer-Encoding: 8bit
dialout → uucp
tape → storage
---
meson.build | 6 +++---
meson_options.txt | 12 ++++++------
rules.d/50-udev-default.rules.in | 14 +++++++-------
sysusers.d/basic.conf.in | 6 +++---
2 files changed, 10 insertions(+), 10 deletions(-)
4 files changed, 19 insertions(+), 19 deletions(-)
diff --git a/meson.build b/meson.build
index 32e5413a62..f781e06fed 100644
--- a/meson.build
+++ b/meson.build
@@ -796,19 +796,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
static_ugids = []
foreach option : ['adm-gid',
'audio-gid',
- 'cdrom-gid',
- 'dialout-gid',
'disk-gid',
'input-gid',
'kmem-gid',
'kvm-gid',
'lp-gid',
+ 'optical-gid',
'render-gid',
'sgx-gid',
- 'tape-gid',
+ 'storage-gid',
'tty-gid',
'users-gid',
'utmp-gid',
+ 'uucp-gid',
'video-gid',
'wheel-gid',
'systemd-journal-gid',
diff --git a/meson_options.txt b/meson_options.txt
index 5048de755d..676e5e2e0d 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -235,10 +235,6 @@ option('adm-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "adm" group')
option('audio-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "audio" group')
-option('cdrom-gid', type : 'integer', value : '-1',
- description : 'soft-static allocation for the "cdrom" group')
-option('dialout-gid', type : 'integer', value : '-1',
- description : 'soft-static allocation for the "dialout" group')
option('disk-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "disk" group')
option('input-gid', type : 'integer', value : '-1',
@@ -249,18 +245,22 @@ option('kvm-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "kvm" group')
option('lp-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "lp" group')
+option('optical-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "optical" group')
option('render-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "render" group')
option('sgx-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "sgx" group')
-option('tape-gid', type : 'integer', value : '-1',
- description : 'soft-static allocation for the "tape" group')
+option('storage-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "storage" group')
option('tty-gid', type : 'integer', value : 5,
description : 'the numeric GID of the "tty" group')
option('users-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "users" group')
option('utmp-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "utmp" group')
+option('uucp-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "uucp" group')
option('video-gid', type : 'integer', value : '-1',
description : 'soft-static allocation for the "video" group')
option('wheel-gid', type : 'integer', value : '-1',
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
index edfa8bb107..35b8d4ba41 100644
index 18a3cf46bf..f3c440fd89 100644
--- a/rules.d/50-udev-default.rules.in
+++ b/rules.d/50-udev-default.rules.in
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
@ -27,7 +96,7 @@ index edfa8bb107..35b8d4ba41 100644
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
@@ -62,13 +62,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
@@ -67,13 +67,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
SUBSYSTEM=="block", GROUP="disk"
@ -48,25 +117,27 @@ index edfa8bb107..35b8d4ba41 100644
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
index 4be0bd869e..cc3721b58a 100644
index 8cc1a7cad2..21bb6d8948 100644
--- a/sysusers.d/basic.conf.in
+++ b/sysusers.d/basic.conf.in
@@ -24,15 +24,15 @@ g utmp - - -
@@ -22,17 +22,17 @@ g utmp {{UTMP_GID }} - -
# Hardware access groups
g audio - - -
-g cdrom - - -
-g dialout - - -
g disk - - -
g input - - -
g kvm - - -
g lp - - -
+g optical - - -
g render - - -
g sgx - - -
-g tape - - -
+g storage - - -
+g uucp - - -
g video - - -
# Physical and virtual hardware access groups
g audio {{AUDIO_GID }} - -
-g cdrom {{CDROM_GID }} - -
-g dialout {{DIALOUT_GID}} - -
g disk {{DISK_GID }} - -
g input {{INPUT_GID }} - -
g kmem {{KMEM_GID }} - -
g kvm {{KVM_GID }} - -
g lp {{LP_GID }} - -
+g optical {{OPTICAL_GID}} - -
g render {{RENDER_GID }} - -
g sgx {{SGX_GID }} - -
-g tape {{TAPE_GID }} - -
+g storage {{STORAGE_GID}} - -
g tty {{TTY_GID }} - -
+g uucp {{UUCP_GID }} - -
g video {{VIDEO_GID }} - -
# Default group for normal users

View file

@ -6,12 +6,12 @@
# - disable gold/LTO
# - removed makedepend on gnu-efi-libs, set -Dgnuefi=false for !aarch64
# - add 242-1 changes in systemd.install to fix systemd-timesyncd
# - patch to fix v5 FTBFS
# - change SBAT information for ALARM
pkgbase=systemd
pkgname=('systemd' 'systemd-libs' 'systemd-resolvconf' 'systemd-sysvcompat')
_tag='fd9ad7d3bc35a3633b99edac14ff2a4fb10599b7' # git rev-parse v${_tag_name}
_tag_name=248.3
_tag='b134c9cc4b02eddca2ea098324369018123fdf15' # git rev-parse v${_tag_name}
_tag_name=249
pkgver="${_tag_name/-/}"
pkgrel=2
arch=('x86_64')
@ -19,12 +19,13 @@ url='https://www.github.com/systemd/systemd'
makedepends=('acl' 'cryptsetup' 'docbook-xsl' 'gperf' 'lz4' 'xz' 'pam' 'libelf'
'intltool' 'iptables' 'kmod' 'libcap' 'libidn2' 'libgcrypt'
'libmicrohttpd' 'libxcrypt' 'libxslt' 'util-linux' 'linux-api-headers'
'python-lxml' 'quota-tools' 'shadow' 'git'
'python-jinja' 'python-lxml' 'quota-tools' 'shadow' 'git'
'meson' 'libseccomp' 'pcre2' 'audit' 'kexec-tools' 'libxkbcommon'
'bash-completion' 'p11-kit' 'systemd' 'libfido2' 'tpm2-tss' 'rsync')
makedepends_aarch64=('gnu-efi-libs')
options=('strip')
validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <lennart@poettering.net>
'A9EA9081724FFAE0484C35A1A81CEA22BC8C7E2E' # Luca Boccassi <luca.boccassi@gmail.com>
'5C251B5FC54EB2F80F407AAAC54CA336CFEB557E') # Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
"git+https://github.com/systemd/systemd#tag=v${_tag_name%.*}?signed"
@ -49,7 +50,7 @@ source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
'30-systemd-update.hook')
sha512sums=('SKIP'
'SKIP'
'882e486b6d88c8bafc50088845e41a49686e98981967f72ca1fb4ef07a01767400632f4b648fd31857d2a2a24a8fd65bcc2a8983284dd4fff2380732741d4c41'
'10f3b477527ec263cc6465c84d94416e356435930edc9e26844a0fd4f71e87a27fa0f91ce24b43a22cacdd2ead5e760e9d607369bc537a8da8d34021302a89a1'
'34541f1967536524329867f9f341f8d9250d9d771c60dc3e6a22ccb82fc01f103cfd3f9903329777591ccbecd2446622a5d6b3804fa0411482b85c70593ee8ad'
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
'f599e1a35cba2c4e83e37c2299fac23ae128d8f68081283e71e1729384975dee1c4b677787f31a17890aeb98c8d2fc90405a202644290708ef9c027315022b17'
@ -122,7 +123,9 @@ build() {
[[ $CARCH == "aarch64" ]] && gnu_efi="true" || gnu_efi="false"
local _meson_options=(
-Dversion-tag="${pkgver}-${pkgrel}-arch"
# internal version comparison is incompatible with pacman:
# 249~rc1 < 249 < 249.1 < 249rc
-Dversion-tag="${_tag_name/-/\~}-${pkgrel}-arch"
-Dmode=release
-Dgnu-efi=$gnu_efi
@ -148,6 +151,12 @@ build() {
-Drpmmacrosdir=no
-Dsysvinit-path=
-Dsysvrcnd-path=
-Dsbat-distro='arch'
-Dsbat-distro-summary='Arch Linux ARM'
-Dsbat-distro-pkgname="${pkgname}"
-Dsbat-distro-version="${pkgver}"
-Dsbat-distro-url="https://archlinuxarm.org/packages/${CARCH}/${pkgname}"
)
arch-meson "$pkgbase-stable" build "${_meson_options[@]}"