mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
extra/audacity to 2.0.6-1
This commit is contained in:
parent
31e5cda253
commit
d8ae716f5d
2 changed files with 46 additions and 9 deletions
|
@ -6,27 +6,34 @@
|
|||
# - disable soundtouch on v5
|
||||
|
||||
pkgname=audacity
|
||||
pkgver=2.0.5
|
||||
pkgrel=2
|
||||
pkgver=2.0.6
|
||||
pkgrel=1
|
||||
pkgdesc="A program that lets you manipulate digital audio waveforms"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://audacity.sourceforge.net/"
|
||||
license=('GPL')
|
||||
depends=('libmad' 'libid3tag' 'wxgtk2.8' 'lame' 'hicolor-icon-theme'
|
||||
'desktop-file-utils' 'jack' 'soundtouch' 'ffmpeg-compat')
|
||||
makedepends=('cmake')
|
||||
depends=('libmad' 'libid3tag' 'wxgtk2.8' 'lame' 'jack' 'soundtouch'
|
||||
'ffmpeg' 'desktop-file-utils')
|
||||
makedepends=('cmake' 'python2')
|
||||
options=('!makeflags')
|
||||
install=audacity.install
|
||||
source=(http://audacity.googlecode.com/files/${pkgname}-minsrc-${pkgver}.tar.xz)
|
||||
sha1sums=('f63cafb81f29e7f3813dc9f80fb1dfdbcfe46b33')
|
||||
source=(http://downloads.sourceforge.net/project/audacity/audacity/${pkgver}/${pkgname}-minsrc-${pkgver}.tar.xz
|
||||
audacity-ffmpeg.patch)
|
||||
sha1sums=('9fd664a71684e7e07472a48fa716f89c87b1929d'
|
||||
'3fa0a06501ae525515f3e46ef9d20aa1a9ea8921')
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}-src-${pkgver}
|
||||
patch -p1 -i "${srcdir}/audacity-ffmpeg.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-src-${pkgver}
|
||||
|
||||
[[ $CARCH == 'arm' ]] && CONFIG="--without-soundtouch"
|
||||
|
||||
WX_CONFIG=/usr/bin/wx-config-2.8 PKG_CONFIG_PATH+="/usr/lib/ffmpeg-compat/pkgconfig" \
|
||||
./configure --prefix=/usr --disable-sse $CONFIG
|
||||
WX_CONFIG=/usr/bin/wx-config-2.8 ./configure --prefix=/usr --disable-sse $CONFIG
|
||||
|
||||
make
|
||||
}
|
||||
|
||||
|
|
30
extra/audacity/audacity-ffmpeg.patch
Normal file
30
extra/audacity/audacity-ffmpeg.patch
Normal file
|
@ -0,0 +1,30 @@
|
|||
diff -Naur audacity-src-2.0.6-orig/src/FFmpeg.h audacity-src-2.0.6/src/FFmpeg.h
|
||||
--- audacity-src-2.0.6-orig/src/FFmpeg.h 2014-09-28 21:54:55.159636208 -0400
|
||||
+++ audacity-src-2.0.6/src/FFmpeg.h 2014-09-28 21:55:11.246276766 -0400
|
||||
@@ -688,7 +688,7 @@
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
||||
AVOutputFormat*,
|
||||
av_oformat_next,
|
||||
- (AVOutputFormat *f),
|
||||
+ (const AVOutputFormat *f),
|
||||
(f)
|
||||
);
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
||||
@@ -755,7 +755,7 @@
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
||||
int,
|
||||
av_fifo_size,
|
||||
- (AVFifoBuffer *f),
|
||||
+ (FF_CONST_AVUTIL53 AVFifoBuffer *f),
|
||||
(f)
|
||||
);
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
||||
@@ -801,7 +801,7 @@
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
||||
AVDictionaryEntry *,
|
||||
av_dict_get,
|
||||
- (AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
|
||||
+ (FF_CONST_AVUTIL53 AVDictionary *m, const char *key, const AVDictionaryEntry *prev, int flags),
|
||||
(m, key, prev, flags)
|
||||
);
|
||||
FFMPEG_FUNCTION_WITH_RETURN(
|
Loading…
Reference in a new issue