mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
Updated docker to 1.0.0
This commit is contained in:
parent
e2f4cc5ad3
commit
d8cb21dd33
4 changed files with 41 additions and 80 deletions
|
@ -1,25 +1,29 @@
|
|||
From 204b0076d78108a11e0b60c0dc3a62bb8a6472b6 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 7 May 2014 15:44:57 -0600
|
||||
Subject: [PATCH 2/3] Fix btrfs detection on ARM
|
||||
From 88fd97ad84730327a5f56dc70af6b71547090c2c Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Pouzanov <farcaller@gmail.com>
|
||||
Date: Wed, 18 Jun 2014 21:16:41 +0100
|
||||
Subject: [PATCH] Fix btrfs detection on ARM
|
||||
|
||||
---
|
||||
daemon/graphdriver/btrfs/btrfs.go | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
daemon/graphdriver/driver.go | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/daemon/graphdriver/btrfs/btrfs.go b/daemon/graphdriver/btrfs/btrfs.go
|
||||
index 4d19553..0b437b4 100644
|
||||
--- a/daemon/graphdriver/btrfs/btrfs.go
|
||||
+++ b/daemon/graphdriver/btrfs/btrfs.go
|
||||
@@ -30,7 +30,7 @@ func Init(home string) (graphdriver.Driver, error) {
|
||||
return nil, err
|
||||
}
|
||||
|
||||
- if buf.Type != 0x9123683E {
|
||||
+ if buf.Type != -1859950530 {
|
||||
return nil, fmt.Errorf("%s is not a btrfs filesystem", rootdir)
|
||||
}
|
||||
|
||||
--
|
||||
1.9.0
|
||||
diff --git a/daemon/graphdriver/driver.go b/daemon/graphdriver/driver.go
|
||||
index 4536489..bd9e6df 100644
|
||||
--- a/daemon/graphdriver/driver.go
|
||||
+++ b/daemon/graphdriver/driver.go
|
||||
@@ -10,10 +10,10 @@ import (
|
||||
"github.com/dotcloud/docker/pkg/mount"
|
||||
)
|
||||
|
||||
-type FsMagic uint64
|
||||
+type FsMagic int32
|
||||
|
||||
const (
|
||||
- FsMagicBtrfs = FsMagic(0x9123683E)
|
||||
+ FsMagicBtrfs = FsMagic(-1859950530)
|
||||
FsMagicAufs = FsMagic(0x61756673)
|
||||
)
|
||||
|
||||
--
|
||||
1.8.5.2
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 7348f406a6de412ef070d5e384e35a31e355564d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 7 May 2014 15:47:33 -0600
|
||||
Subject: [PATCH 3/3] setBridgeMacAddress ARM support
|
||||
From 663b9649d37a2d0f2bdae4134ba55ed36e97ba3f Mon Sep 17 00:00:00 2001
|
||||
From: Vladimir Pouzanov <farcaller@gmail.com>
|
||||
Date: Wed, 18 Jun 2014 21:07:31 +0100
|
||||
Subject: [PATCH] setBridgeMacAddress ARM support
|
||||
|
||||
---
|
||||
pkg/netlink/netlink_linux.go | 19 -------------------
|
||||
|
@ -12,7 +12,7 @@ Subject: [PATCH 3/3] setBridgeMacAddress ARM support
|
|||
create mode 100644 pkg/netlink/setbridgemacaddress_arm.go
|
||||
|
||||
diff --git a/pkg/netlink/netlink_linux.go b/pkg/netlink/netlink_linux.go
|
||||
index 6de293d..77a411b 100644
|
||||
index 14e30aa..12aee4d 100644
|
||||
--- a/pkg/netlink/netlink_linux.go
|
||||
+++ b/pkg/netlink/netlink_linux.go
|
||||
@@ -5,7 +5,6 @@ package netlink
|
||||
|
@ -21,10 +21,10 @@ index 6de293d..77a411b 100644
|
|||
"fmt"
|
||||
- "math/rand"
|
||||
"net"
|
||||
"sync/atomic"
|
||||
"syscall"
|
||||
"unsafe"
|
||||
@@ -871,21 +870,3 @@ func AddToBridge(iface, master *net.Interface) error {
|
||||
|
||||
@@ -944,21 +943,3 @@ func AddToBridge(iface, master *net.Interface) error {
|
||||
|
||||
return nil
|
||||
}
|
||||
-
|
||||
|
@ -47,7 +47,7 @@ index 6de293d..77a411b 100644
|
|||
-}
|
||||
diff --git a/pkg/netlink/setbridgemacaddress_amd64.go b/pkg/netlink/setbridgemacaddress_amd64.go
|
||||
new file mode 100644
|
||||
index 0000000..f6e799e
|
||||
index 0000000..dea7e1a
|
||||
--- /dev/null
|
||||
+++ b/pkg/netlink/setbridgemacaddress_amd64.go
|
||||
@@ -0,0 +1,27 @@
|
||||
|
@ -78,10 +78,9 @@ index 0000000..f6e799e
|
|||
+ }
|
||||
+ return nil
|
||||
+}
|
||||
\ No newline at end of file
|
||||
diff --git a/pkg/netlink/setbridgemacaddress_arm.go b/pkg/netlink/setbridgemacaddress_arm.go
|
||||
new file mode 100644
|
||||
index 0000000..a5e59c5
|
||||
index 0000000..f5e116e
|
||||
--- /dev/null
|
||||
+++ b/pkg/netlink/setbridgemacaddress_arm.go
|
||||
@@ -0,0 +1,27 @@
|
||||
|
@ -112,7 +111,6 @@ index 0000000..a5e59c5
|
|||
+ }
|
||||
+ return nil
|
||||
+}
|
||||
\ No newline at end of file
|
||||
--
|
||||
1.9.0
|
||||
--
|
||||
1.8.5.2
|
||||
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
From d60301edb88a4e182a10cd2becb3795b2dd13fab Mon Sep 17 00:00:00 2001
|
||||
From: Tianon Gravi <admwiggin@gmail.com>
|
||||
Date: Thu, 8 May 2014 01:03:45 -0600
|
||||
Subject: [PATCH] Update restrict.Restrict to both show the error message when
|
||||
failing to mount /dev/null over /proc/kcore, and to ignore "not exists"
|
||||
errors while doing so (for when CONFIG_PROC_KCORE=n in the kernel)
|
||||
|
||||
Docker-DCO-1.1-Signed-off-by: Andrew Page <admwiggin@gmail.com> (github: tianon)
|
||||
---
|
||||
pkg/libcontainer/security/restrict/restrict.go | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/pkg/libcontainer/security/restrict/restrict.go b/pkg/libcontainer/security/restrict/restrict.go
|
||||
index e1296b1..361d076 100644
|
||||
--- a/pkg/libcontainer/security/restrict/restrict.go
|
||||
+++ b/pkg/libcontainer/security/restrict/restrict.go
|
||||
@@ -4,6 +4,7 @@ package restrict
|
||||
|
||||
import (
|
||||
"fmt"
|
||||
+ "os"
|
||||
"syscall"
|
||||
|
||||
"github.com/dotcloud/docker/pkg/system"
|
||||
@@ -18,8 +19,8 @@ func Restrict(mounts ...string) error {
|
||||
return fmt.Errorf("unable to remount %s readonly: %s", dest, err)
|
||||
}
|
||||
}
|
||||
- if err := system.Mount("/dev/null", "/proc/kcore", "", syscall.MS_BIND, ""); err != nil {
|
||||
- return fmt.Errorf("unable to bind-mount /dev/null over /proc/kcore")
|
||||
+ if err := system.Mount("/dev/null", "/proc/kcore", "", syscall.MS_BIND, ""); err != nil && !os.IsNotExist(err) {
|
||||
+ return fmt.Errorf("unable to bind-mount /dev/null over /proc/kcore: %s", err)
|
||||
}
|
||||
return nil
|
||||
}
|
||||
--
|
||||
1.9.1
|
||||
|
|
@ -5,7 +5,7 @@
|
|||
# - ARM patches, adjustments
|
||||
|
||||
pkgname=docker
|
||||
pkgver=0.11.1
|
||||
pkgver=1.0.0
|
||||
pkgrel=1
|
||||
epoch=1
|
||||
pkgdesc='Pack, ship and run any application as a lightweight container'
|
||||
|
@ -22,13 +22,11 @@ install=$pkgname.install
|
|||
source=("git+https://github.com/dotcloud/docker.git#tag=v$pkgver"
|
||||
'0001-ARM-as-allowed-architecture.patch'
|
||||
'0002-Fix-btrfs-detection-on-ARM.patch'
|
||||
'0003-setBridgeMacAddress-ARM-support.patch'
|
||||
'0004-Allow-missing-kcore.patch')
|
||||
'0003-setBridgeMacAddress-ARM-support.patch')
|
||||
md5sums=('SKIP'
|
||||
'c003084f4cf0f754c868662a8bae95e8'
|
||||
'f3ed840798065ca2a40e40b07d5e4069'
|
||||
'f42c2001c85556830598a8ec07430d53'
|
||||
'e909f4cccd0e066be06538d0669fa4df')
|
||||
'3ca24a8fe8567a153fad4f9ab31286ae'
|
||||
'1f74fb11f1b10868dbc55ddb6d437125')
|
||||
|
||||
prepare() {
|
||||
cd "docker"
|
||||
|
@ -39,7 +37,6 @@ prepare() {
|
|||
find . -name '*.go' | xargs sed --in-place= -e 's/\/\/ +build linux,amd64/\/\/ +build linux,arm/'
|
||||
# This patch is applicable after the seds.
|
||||
patch -p1 -i ../0003-setBridgeMacAddress-ARM-support.patch
|
||||
patch -p1 -i ../0004-Allow-missing-kcore.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue