core/linux-armv5: add archlinuxarm.patch

This commit is contained in:
Kevin Mihelich 2014-06-21 04:08:55 +00:00
parent de26ba3d19
commit d8d40b0575
3 changed files with 85 additions and 1 deletions

View file

@ -27,6 +27,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0007-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch'
'0008-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch'
'0009-I2C-fixes.patch'
'archlinuxarm.patch'
'config')
md5sums=('97ca1625bb40368dc41b9a7971549071'
'78a944411af297b9e5e9aa430056de4c'
@ -40,7 +41,8 @@ md5sums=('97ca1625bb40368dc41b9a7971549071'
'14570ba571b001b1f42070e2066232d7'
'ad4eb847c301bc3d5a66de3ee2369da8'
'ef607cd7a01d7c287b107f677f6a7808'
'19cf9f2525d8fb1744c8987cfca70a5b')
'e319a8e1a596a39a8951fc6454664b15'
'74a6c44ea27af6d7240cf77586b2a099')
prepare() {
cd "${srcdir}/${_srcname}"
@ -58,6 +60,7 @@ prepare() {
git apply ../0007-Added-ASoC-driver-for-i.MX233-s-builtin-ADC-DAC-code.patch
git apply ../0008-Added-DTS-with-mxs-builtin-entries-for-testing-the-a.patch
git apply ../0009-I2C-fixes.patch
patch -p1 -i ../archlinuxarm.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .

View file

@ -0,0 +1,80 @@
diff -ruN a/drivers/ata/sata_mv.c b/drivers/ata/sata_mv.c
--- a/drivers/ata/sata_mv.c 2013-11-03 16:41:51.000000000 -0700
+++ b/drivers/ata/sata_mv.c 2013-11-08 01:39:48.868014917 -0700
@@ -71,6 +71,7 @@
#include <scsi/scsi_cmnd.h>
#include <scsi/scsi_device.h>
#include <linux/libata.h>
+#include <linux/leds.h>
#define DRV_NAME "sata_mv"
#define DRV_VERSION "1.28"
@@ -1161,6 +1162,8 @@
{
int want_ncq = (protocol == ATA_PROT_NCQ);
+ ledtrig_ide_activity();
+
if (pp->pp_flags & MV_PP_FLAG_EDMA_EN) {
int using_ncq = ((pp->pp_flags & MV_PP_FLAG_NCQ_EN) != 0);
if (want_ncq != using_ncq)
diff -ruN a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
--- a/drivers/leds/trigger/Kconfig 2013-11-03 16:41:51.000000000 -0700
+++ b/drivers/leds/trigger/Kconfig 2013-11-08 01:39:48.958018410 -0700
@@ -35,7 +35,6 @@
config LEDS_TRIGGER_IDE_DISK
bool "LED IDE Disk Trigger"
- depends on IDE_GD_ATA
depends on LEDS_TRIGGERS
help
This allows LEDs to be controlled by IDE disk activity.
diff -ruN a/drivers/mmc/core/core.c b/drivers/mmc/core/core.c
--- a/drivers/mmc/core/core.c 2013-11-03 16:41:51.000000000 -0700
+++ b/drivers/mmc/core/core.c 2013-11-08 01:39:49.008020351 -0700
@@ -805,7 +805,7 @@
*/
limit_us = 3000000;
else
- limit_us = 100000;
+ limit_us = 200000;
/*
* SDHC cards always use these fixed values.
diff -ruN a/drivers/mmc/core/sd.c b/drivers/mmc/core/sd.c
--- a/drivers/mmc/core/sd.c 2013-11-03 16:41:51.000000000 -0700
+++ b/drivers/mmc/core/sd.c 2013-11-08 01:39:49.008020351 -0700
@@ -358,6 +358,15 @@
return -ENOMEM;
}
+ /*
+ * Some SDHC cards, notably those with a Sandisk SD controller
+ * (also found in Kingston products) need a bit of slack
+ * before successfully handling the SWITCH command. So far,
+ * cards identifying themselves as "SD04G" and "SD08G" are
+ * affected
+ */
+ udelay(100);
+
err = mmc_sd_switch(card, 1, 0, 1, status);
if (err)
goto out;
diff -ruN a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
--- a/drivers/mmc/host/mvsdio.c 2013-11-03 16:41:51.000000000 -0700
+++ b/drivers/mmc/host/mvsdio.c 2013-11-08 01:39:49.028021127 -0700
@@ -25,6 +25,7 @@
#include <linux/of_irq.h>
#include <linux/mmc/host.h>
#include <linux/mmc/slot-gpio.h>
+#include <linux/mmc/sd.h>
#include <linux/pinctrl/consumer.h>
#include <asm/sizes.h>
@@ -148,6 +149,7 @@
dev_dbg(host->dev, "cmd %d (hw state 0x%04x)\n",
cmd->opcode, mvsd_read(MVSD_HW_STATE));
+ if (cmd->opcode == SD_SWITCH) mdelay(1); /* Voodoo */
cmdreg = MVSD_CMD_INDEX(cmd->opcode);

View file

@ -3785,6 +3785,7 @@ CONFIG_LEDS_NETXBIG=y
CONFIG_LEDS_TRIGGERS=y
CONFIG_LEDS_TRIGGER_TIMER=y
CONFIG_LEDS_TRIGGER_ONESHOT=y
CONFIG_LEDS_TRIGGER_IDE_DISK=y
CONFIG_LEDS_TRIGGER_HEARTBEAT=y
CONFIG_LEDS_TRIGGER_BACKLIGHT=y
CONFIG_LEDS_TRIGGER_CPU=y