community/libcec to 2.2.0-1

This commit is contained in:
Kevin Mihelich 2014-11-06 13:39:55 +00:00
parent 58c3fe8583
commit d8dc5a3893
3 changed files with 7 additions and 1386 deletions

View file

@ -6,19 +6,15 @@
# - Exynos and RPi support
pkgname=libcec
pkgver=2.1.4
pkgrel=1.1
pkgver=2.2.0
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
arch=('i686' 'x86_64')
url="http://libcec.pulse-eight.com/"
license=('GPL')
depends=('udev' 'lockdev')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz"
'exynos.patch'
'fix-bool_t.patch')
sha256sums=('79bef5232a5c9ab987ca3a2d4bfcaeb80480fd26f502dc1a996fe845d90fe147'
'ae746a22142aec24b4a5cfffa3d42c97a9be5d8a22f7215bf217934b9d1ce9d1'
'ab695a6638d3a4009c4f7f76e2b84b98a7f03c0332f5e1038e53ae804ea12821')
source=("$pkgname-$pkgver.tar.gz::https://github.com/Pulse-Eight/$pkgname/archive/$pkgname-$pkgver.tar.gz")
sha256sums=('fd4f47a18d6e0f4b9e6f5831280207ee2b2a5fc2741ae32ae09ad12a8aa52917')
if [[ $CARCH = 'armv6h' ]]; then
depends+=('raspberrypi-firmware')
@ -26,13 +22,6 @@ if [[ $CARCH = 'armv6h' ]]; then
provides=('libcec-rpi')
fi
prepare() {
cd "$pkgname-$pkgname-$pkgver"
patch -Np1 -i ../exynos.patch
patch -Np1 -i ../fix-bool_t.patch
}
build() {
cd "$pkgname-$pkgname-$pkgver"
autoreconf -vif
@ -40,8 +29,10 @@ build() {
if [[ $CARCH == 'armv7h' ]]; then
CONFIG='--enable-exynos'
elif [[ $CARCH == 'armv6h' ]]; then
CONFIG='--enable-rpi --with-rpi-include-path=/opt/vc/include --with-rpi-lib-path=/opt/vc/lib'
CONFIG='--disable-exynos --enable-rpi --with-rpi-include-path=/opt/vc/include --with-rpi-lib-path=/opt/vc/lib'
unset LDFLAGS
elif [[ $CARCH == 'arm' ]]; then
CONFIG='--disable-exynos'
fi
./configure --prefix=/usr $CONFIG

File diff suppressed because it is too large Load diff

View file

@ -1,33 +0,0 @@
diff -urN a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp
--- a/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2013-12-13 08:03:33.000000000 -0700
+++ b/src/lib/adapter/RPi/RPiCECAdapterCommunication.cpp 2014-01-09 13:51:12.250929575 -0700
@@ -299,7 +299,7 @@
if (bStartListening)
{
// enable passive mode
- vc_cec_set_passive(true);
+ vc_cec_set_passive((bool_t)true);
// register the callbacks
vc_cec_register_callback(rpi_cec_callback, (void*)this);
@@ -358,7 +358,7 @@
UnregisterLogicalAddress();
// disable passive mode
- vc_cec_set_passive(false);
+ vc_cec_set_passive((bool_t)false);
if (!g_bHostInited)
{
diff -urN a/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp b/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp
--- a/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2013-12-13 08:03:33.000000000 -0700
+++ b/src/lib/adapter/RPi/RPiCECAdapterMessageQueue.cpp 2014-01-09 13:51:12.255929509 -0700
@@ -182,7 +182,7 @@
LIB_CEC->AddLog(CEC_LOG_DEBUG, "sending data: %s", strDump.c_str());
#endif
- int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, bIsReply);
+ int iReturn = vc_cec_send_message((uint32_t)command.destination, (uint8_t*)&payload, iLength, (bool_t)bIsReply);
#endif
if (iReturn != VCHIQ_SUCCESS)