mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
core/linux-armv7 to 4.10.0-1
This commit is contained in:
parent
417b9664c5
commit
d9112913e1
15 changed files with 316 additions and 129 deletions
|
@ -1,7 +1,7 @@
|
|||
From 001565916ddb8589ec7920b0d3c0d007225c79c4 Mon Sep 17 00:00:00 2001
|
||||
From b9f6d275e5af76eb4e32beb66480e8f53a7d1685 Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:59:28 +0100
|
||||
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
|
||||
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
|
||||
|
||||
Marvell uses a specific atag in its u-boot which includes among other
|
||||
information the MAC addresses for up to 4 network interfaces.
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
|
|||
1 file changed, 17 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/include/uapi/asm/setup.h b/arch/arm/include/uapi/asm/setup.h
|
||||
index 979ff40..d1d0c19 100644
|
||||
index 979ff4016404..d1d0c1950fa4 100644
|
||||
--- a/arch/arm/include/uapi/asm/setup.h
|
||||
+++ b/arch/arm/include/uapi/asm/setup.h
|
||||
@@ -143,6 +143,18 @@ struct tag_memclk {
|
||||
|
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From c25c95072f199e0d0a56cbd4db701ab5b36a9f0c Mon Sep 17 00:00:00 2001
|
||||
From 3573189a2857cd66d248fb79e48a45ae70399c0b Mon Sep 17 00:00:00 2001
|
||||
From: Willy Tarreau <w@xxxxxx>
|
||||
Date: Sun, 2 Dec 2012 19:56:58 +0100
|
||||
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
|
||||
loader
|
||||
|
||||
The atags are parsed and if a Marvell atag is found, up to 4 MAC
|
||||
|
@ -17,7 +17,7 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
|
|||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
index 9448aa0..ac7b6ae 100644
|
||||
index 9448aa0c6686..ac7b6ae6c00f 100644
|
||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
@@ -18,7 +18,7 @@ static int node_offset(void *fdt, const char *node_path)
|
||||
|
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
|
|||
}
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 3822d03ac84e6581583c3e533eb0e015334242bd Mon Sep 17 00:00:00 2001
|
||||
From 94679e069c9def09906a6b5f85c58ebd981ff615 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:41:19 -0600
|
||||
Subject: [PATCH 3/8] SMILE Plug device tree file
|
||||
Subject: [PATCH 3/9] SMILE Plug device tree file
|
||||
|
||||
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
|
||||
dts with the LED definitions.
|
||||
|
@ -14,10 +14,10 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
create mode 100644 arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
|
||||
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
||||
index befcd26..2be4c48 100644
|
||||
index f10fe8526239..f00e858de082 100644
|
||||
--- a/arch/arm/boot/dts/Makefile
|
||||
+++ b/arch/arm/boot/dts/Makefile
|
||||
@@ -906,6 +906,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
@@ -935,6 +935,7 @@ dtb-$(CONFIG_MACH_ARMADA_370) += \
|
||||
armada-370-db.dtb \
|
||||
armada-370-dlink-dns327l.dtb \
|
||||
armada-370-mirabox.dtb \
|
||||
|
@ -27,7 +27,7 @@ index befcd26..2be4c48 100644
|
|||
armada-370-rd.dtb \
|
||||
diff --git a/arch/arm/boot/dts/armada-370-smileplug.dts b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
new file mode 100644
|
||||
index 0000000..d01308a
|
||||
index 000000000000..d01308ab848b
|
||||
--- /dev/null
|
||||
+++ b/arch/arm/boot/dts/armada-370-smileplug.dts
|
||||
@@ -0,0 +1,173 @@
|
||||
|
@ -205,5 +205,5 @@ index 0000000..d01308a
|
|||
+ };
|
||||
+};
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 51597a7978cb561ba33d2fe4f9fb3aa07f448cc4 Mon Sep 17 00:00:00 2001
|
||||
From 4831d1d37e42c17f97ae238d6bbcfda7c8dac028 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Fri, 5 Sep 2014 15:43:56 -0600
|
||||
Subject: [PATCH 4/8] fix mvsdio eMMC timing
|
||||
Subject: [PATCH 4/9] fix mvsdio eMMC timing
|
||||
|
||||
These changes from Globalscale change the MMC timing to allow the eMMC versions
|
||||
of the Mirabox and SMILE Plug to work.
|
||||
|
@ -12,7 +12,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c
|
||||
index 42296e5..e5ce6d2 100644
|
||||
index 42296e55b9de..e5ce6d27ec82 100644
|
||||
--- a/drivers/mmc/host/mvsdio.c
|
||||
+++ b/drivers/mmc/host/mvsdio.c
|
||||
@@ -93,7 +93,7 @@ static int mvsd_setup_data(struct mvsd_host *host, struct mmc_data *data)
|
||||
|
@ -34,5 +34,5 @@ index 42296e5..e5ce6d2 100644
|
|||
host->clock = ios->clock;
|
||||
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
From f0e29c8c8744317cfe946faf4f4ebae76f2c4eb1 Mon Sep 17 00:00:00 2001
|
||||
From 079ecb4f368b983d08e7c19daaf64311b8814ee3 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index 831aa33..0362554 100644
|
||||
index 831aa33d078a..03625547d794 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -60,6 +60,7 @@
|
||||
|
@ -91,5 +91,5 @@ index 831aa33..0362554 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 200fab4de6f535e626095b9782b56e0ed101409c Mon Sep 17 00:00:00 2001
|
||||
From f8ed0685d6606fe27a3e8fc8aa3744f17f9e1956 Mon Sep 17 00:00:00 2001
|
||||
From: dobatog <dobatog@gmail.com>
|
||||
Date: Thu, 26 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 6/8] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
Subject: [PATCH 6/9] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
|
||||
related to input routing signals.
|
||||
|
||||
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
|
||||
|
@ -27,7 +27,7 @@ Tested-by: Max Filippov <jcmvbkbc@gmail.com>
|
|||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/sound/soc/codecs/tlv320aic23.c b/sound/soc/codecs/tlv320aic23.c
|
||||
index 410cae0..0bb8e26 100644
|
||||
index 410cae0f2060..0bb8e2602d8e 100644
|
||||
--- a/sound/soc/codecs/tlv320aic23.c
|
||||
+++ b/sound/soc/codecs/tlv320aic23.c
|
||||
@@ -174,10 +174,10 @@ static const struct snd_soc_dapm_route tlv320aic23_intercon[] = {
|
||||
|
@ -45,5 +45,5 @@ index 410cae0..0bb8e26 100644
|
|||
/* input mux */
|
||||
{"Capture Source", "Line", "Line Input"},
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 011f5e6c9ef7350ac6e7bbd486318b1b96d78652 Mon Sep 17 00:00:00 2001
|
||||
From 6a7d1d2fab44c1830903b7af1a8a844ce4925763 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 14 Feb 2015 12:32:27 +0100
|
||||
Subject: [PATCH 7/8] set default cubietruck led triggers
|
||||
Subject: [PATCH 7/9] set default cubietruck led triggers
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
|
@ -9,7 +9,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
index 83f39b0..15e9626 100644
|
||||
index 83f39b0362cb..15e9626ea81b 100644
|
||||
--- a/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
+++ b/arch/arm/boot/dts/sun7i-a20-cubietruck.dts
|
||||
@@ -70,6 +70,7 @@
|
||||
|
@ -29,5 +29,5 @@ index 83f39b0..15e9626 100644
|
|||
};
|
||||
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 21fd4defb20c41ae93e86c4a5e6adcb1afd36be9 Mon Sep 17 00:00:00 2001
|
||||
From 5bd43bf12a2258976be01fe1211de9ad4d8e9145 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 11 Aug 2016 00:42:37 -0600
|
||||
Subject: [PATCH 8/8] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
Subject: [PATCH 8/9] exynos4412-odroid: set higher minimum buck2 regulator
|
||||
voltage
|
||||
|
||||
Set a higher minimum voltage to help reboot issue.
|
||||
|
@ -13,7 +13,7 @@ Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
|||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
index 8aa19ba..8e2d94e 100644
|
||||
index 8aa19ba14436..8e2d94e3af72 100644
|
||||
--- a/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
+++ b/arch/arm/boot/dts/exynos4412-odroid-common.dtsi
|
||||
@@ -423,7 +423,7 @@
|
||||
|
@ -26,5 +26,5 @@ index 8aa19ba..8e2d94e 100644
|
|||
regulator-always-on;
|
||||
regulator-boot-on;
|
||||
--
|
||||
2.10.0
|
||||
2.11.0
|
||||
|
||||
|
|
23
core/linux-armv7/0009-drm-armada-tracing-fix.patch
Normal file
23
core/linux-armv7/0009-drm-armada-tracing-fix.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
From 24b08faa09d097e432fe36817dce69335c63d412 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 26 Dec 2016 12:56:09 -0700
|
||||
Subject: [PATCH 9/9] drm/armada tracing fix
|
||||
|
||||
https://lists.freedesktop.org/archives/dri-devel/2016-December/126212.html
|
||||
---
|
||||
drivers/gpu/drm/armada/Makefile | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/drivers/gpu/drm/armada/Makefile b/drivers/gpu/drm/armada/Makefile
|
||||
index a18f156c8b66..64c0b4546fb2 100644
|
||||
--- a/drivers/gpu/drm/armada/Makefile
|
||||
+++ b/drivers/gpu/drm/armada/Makefile
|
||||
@@ -4,3 +4,5 @@ armada-y += armada_510.o
|
||||
armada-$(CONFIG_DEBUG_FS) += armada_debugfs.o
|
||||
|
||||
obj-$(CONFIG_DRM_ARMADA) := armada.o
|
||||
+
|
||||
+CFLAGS_armada_trace.o := -I$(src)
|
||||
--
|
||||
2.11.0
|
||||
|
11
core/linux-armv7/99-linux.hook
Normal file
11
core/linux-armv7/99-linux.hook
Normal file
|
@ -0,0 +1,11 @@
|
|||
[Trigger]
|
||||
Type = File
|
||||
Operation = Install
|
||||
Operation = Upgrade
|
||||
Target = boot/zImage
|
||||
Target = usr/lib/initcpio/*
|
||||
|
||||
[Action]
|
||||
Description = Updating %PKGBASE% initcpios
|
||||
When = PostTransaction
|
||||
Exec = /usr/bin/mkinitcpio -p %PKGBASE%
|
|
@ -4,19 +4,19 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=linux-armv7
|
||||
_srcname=linux-4.9
|
||||
_srcname=linux-4.10
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ARMv7 multi-platform"
|
||||
pkgver=4.9.11
|
||||
pkgver=4.10.0
|
||||
pkgrel=1
|
||||
rcnrel=armv7-x4
|
||||
rcnrel=armv7-x1
|
||||
arch=('armv7h')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'vboot-utils' 'dtc')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
"http://rcn-ee.com/deb/sid-armhf/v${pkgver}-${rcnrel}/patch-${pkgver%.0}-${rcnrel}.diff.gz"
|
||||
'0001-ARM-atags-add-support-for-Marvell-s-u-boot.patch'
|
||||
'0002-ARM-atags-fdt-retrieve-MAC-addresses-from-Marvell-bo.patch'
|
||||
|
@ -26,33 +26,36 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
|||
'0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
|
||||
'0007-set-default-cubietruck-led-triggers.patch'
|
||||
'0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
|
||||
'0009-drm-armada-tracing-fix.patch'
|
||||
'config'
|
||||
'cmdline'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk')
|
||||
md5sums=('0a68ef3615c64bd5ee54a3320e46667d'
|
||||
'738953d9d33739f3a333c7ef6ce33e3d'
|
||||
'49c7f6725c400994e12675d3fa4690bf'
|
||||
'7bad9743fd2f1690f479cbbec5a556ab'
|
||||
'57998a8dbf42d2237f2f3a650b93ef26'
|
||||
'75e392a161842813d0ff3d0beaf68038'
|
||||
'5840b71b7b2600388aa9a1195a5af528'
|
||||
'25c3f00750a1aa951b857bf06ec79a8e'
|
||||
'dd1c99be98c43f06a07aa14fc47d6e3e'
|
||||
'ef825f8c3563a87bab10f4782e7a0efc'
|
||||
'ef5fd8e682fed9dce4bc3d1c821acbd1'
|
||||
'8f06a784da37647e0421d97cbed22a56'
|
||||
'1813b39074d01af6548951764a0f6444'
|
||||
'kernel_data_key.vbprivk'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('b5e7f6b9b2fe1b6cc7bc56a3a0bfc090'
|
||||
'4d5a9908ea800a6aa704a9cb31e4c86b'
|
||||
'214847b73b9001db1362e8bb3f9aed87'
|
||||
'82ffb2a8297f35e56f8827bd6cc89a32'
|
||||
'70bc3d3d13f4e77728bbc324dc81a9d3'
|
||||
'47eae7e2c1d8e41137c4214b3091aa99'
|
||||
'cfa66bcafa51215e71be60c63e978e35'
|
||||
'5f76b742e3d04056a6bb49c1bde4a190'
|
||||
'a93178aff351099bdc1932b15c09e506'
|
||||
'd9986312d2a15c29cf816a967d3447e1'
|
||||
'62e75ec9b302e39ac51227ebb4243b76'
|
||||
'b31f5c531af2b831e82977bee36d9420'
|
||||
'4f2379ed84258050edb858ee8d281678'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
'584777ae88bce2c5659960151b64c7d8')
|
||||
'584777ae88bce2c5659960151b64c7d8'
|
||||
'fb034fe5f2e28a4cce30ae2d8cf6be3c'
|
||||
'79fa396e3f9a09a85156d6d7c2d34b58')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# RCN patch
|
||||
git apply ../patch-${pkgver%.0}-${rcnrel}.diff
|
||||
|
@ -66,6 +69,7 @@ prepare() {
|
|||
git apply ../0006-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
|
||||
git apply ../0007-set-default-cubietruck-led-triggers.patch
|
||||
git apply ../0008-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
|
||||
git apply ../0009-drm-armada-tracing-fix.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
@ -110,6 +114,7 @@ _package() {
|
|||
pkgdesc="The Linux Kernel and modules - ${_desc}"
|
||||
depends=('coreutils' 'linux-firmware' 'kmod' 'mkinitcpio>=0.7')
|
||||
optdepends=('crda: to set the correct wireless channels of your country')
|
||||
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
|
||||
provides=('kernel26' "linux=${pkgver}")
|
||||
conflicts=('linux')
|
||||
replaces=('linux-mvebu' 'linux-udoo' 'linux-sun4i' 'linux-sun5i' 'linux-sun7i' 'linux-usbarmory' 'linux-wandboard')
|
||||
|
@ -135,6 +140,17 @@ _package() {
|
|||
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||
-i "${startdir}/${pkgname}.install"
|
||||
|
||||
# install mkinitcpio preset file for kernel
|
||||
install -D -m644 "${srcdir}/linux.preset" "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
|
||||
sed \
|
||||
-e "1s|'linux.*'|'${pkgbase}'|" \
|
||||
-e "s|ALL_kver=.*|ALL_kver=\"${_kernver}\"|" \
|
||||
-i "${pkgdir}/etc/mkinitcpio.d/${pkgbase}.preset"
|
||||
|
||||
# install pacman hook for initramfs regeneration
|
||||
sed "s|%PKGBASE%|${pkgbase}|g" "${srcdir}/99-linux.hook" |
|
||||
install -D -m644 /dev/stdin "${pkgdir}/usr/share/libalpm/hooks/99-${pkgbase}.hook"
|
||||
|
||||
# remove build and source links
|
||||
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
||||
# remove the firmware
|
||||
|
@ -355,6 +371,7 @@ _package-chromebook() {
|
|||
cp ../kernel.its .
|
||||
mkimage -D "-I dts -O dtb -p 2048" -f kernel.its vmlinux.uimg
|
||||
dd if=/dev/zero of=bootloader.bin bs=512 count=1
|
||||
echo 'console=tty0 init=/sbin/init root=PARTUUID=%U/PARTNROFF=1 rootwait rw noinitrd' > cmdline
|
||||
vbutil_kernel \
|
||||
--pack vmlinux.kpart \
|
||||
--version 1 \
|
||||
|
@ -362,7 +379,7 @@ _package-chromebook() {
|
|||
--arch arm \
|
||||
--keyblock ../kernel.keyblock \
|
||||
--signprivate ../kernel_data_key.vbprivk \
|
||||
--config ../cmdline \
|
||||
--config cmdline \
|
||||
--bootloader bootloader.bin
|
||||
|
||||
mkdir -p "${pkgdir}/boot"
|
||||
|
|
|
@ -1 +0,0 @@
|
|||
console=tty0 init=/sbin/init root=PARTUUID=%U/PARTNROFF=1 rootwait rw noinitrd
|
File diff suppressed because it is too large
Load diff
|
@ -2,7 +2,7 @@
|
|||
# arg 2: the old package version
|
||||
|
||||
KERNEL_NAME=-armv7
|
||||
KERNEL_VERSION=3.14.0-1-ARCH
|
||||
KERNEL_VERSION=4.10.0-1-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
@ -17,3 +17,7 @@ post_upgrade() {
|
|||
echo ">>> Updating module dependencies. Please wait ..."
|
||||
depmod ${KERNEL_VERSION}
|
||||
}
|
||||
|
||||
post_remove() {
|
||||
rm -f boot/initramfs-linux.img
|
||||
}
|
||||
|
|
10
core/linux-armv7/linux.preset
Normal file
10
core/linux-armv7/linux.preset
Normal file
|
@ -0,0 +1,10 @@
|
|||
# mkinitcpio preset file for the linux-armv7 package
|
||||
|
||||
ALL_config="/etc/mkinitcpio.conf"
|
||||
ALL_kver="4.10.0-1-ARCH"
|
||||
|
||||
PRESETS=('default')
|
||||
|
||||
#default_config="/etc/mkinitcpio.conf"
|
||||
default_image="/boot/initramfs-linux.img"
|
||||
#default_options=""
|
Loading…
Reference in a new issue