extra/boost to 1.81.0-2

This commit is contained in:
Kevin Mihelich 2023-01-22 20:29:43 +00:00
parent b82b2101c9
commit d9511ed98a
2 changed files with 28 additions and 10 deletions

View file

@ -13,8 +13,8 @@
# - specify arm architecture to b2 for aarch64
pkgname=('boost' 'boost-libs')
pkgver=1.80.0
pkgrel=3
pkgver=1.81.0
pkgrel=2
_srcname=boost_${pkgver//./_}
pkgdesc="Free peer-reviewed portable C++ source libraries"
arch=('x86_64')
@ -22,19 +22,26 @@ url="https://www.boost.org/"
license=('custom')
makedepends=('icu' 'python' 'python-numpy' 'bzip2' 'zlib' 'openmpi' 'zstd')
source=(https://boostorg.jfrog.io/artifactory/main/release/$pkgver/source/$_srcname.tar.bz2
boost-1.81.0-phoenix-multiple-definitions.patch
$pkgname-ublas-c++20-iterator.patch::https://github.com/boostorg/ublas/commit/a31e5cffa85f.patch)
sha256sums=('1e19565d82e43bc59209a168f5ac899d3ba471d55c7610c677d4ccf2c9c500c0'
sha256sums=('71feeed900fbccca04a3b4f2f84a7c217186f28a940ed8b7ed4725986baf99fa'
'3ebf428ef6be090a7b56a233330375539ac429333b83708e28fe5db049cfecdb'
'aa38addb40d5f44b4a8472029b475e7e6aef1c460509eb7d8edf03491dc1b5ee')
prepare() {
cd $_srcname
# https://github.com/boostorg/phoenix/issues/111
patch -Np1 -i ../boost-1.81.0-phoenix-multiple-definitions.patch
# https://github.com/boostorg/ublas/pull/97
patch -Np2 -i ../$pkgname-ublas-c++20-iterator.patch
}
build() {
local JOBS="$(sed 's/.*\(-j *[0-9]\+\).*/\1/' <<<$MAKEFLAGS)"
local python_version=$(
python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
pushd $_srcname/tools/build
./bootstrap.sh --cxxflags="$CXXFLAGS $LDFLAGS"
@ -61,7 +68,7 @@ build() {
runtime-link=shared \
link=shared,static \
toolset=gcc \
python=3.10 \
python=$python_version \
cflags="$CPPFLAGS $CFLAGS -fPIC -O3" \
cxxflags="$CPPFLAGS $CXXFLAGS -fPIC -O3" \
linkflags="$LDFLAGS" \
@ -108,17 +115,17 @@ package_boost-libs() {
libboost_stacktrace_addr2line.so libboost_stacktrace_basic.so
libboost_stacktrace_noop.so libboost_system.so libboost_thread.so
libboost_timer.so libboost_type_erasure.so libboost_unit_test_framework.so
libboost_wave.so libboost_wserialization.so)
libboost_url.so libboost_wave.so libboost_wserialization.so)
install -dm755 "$pkgdir"/usr/lib
cp -a fakeinstall/lib/*.so.* "$pkgdir"/usr/lib/
# https://github.com/boostorg/mpi/issues/112
install -d "$pkgdir"/usr/lib/python3.10/site-packages/boost
touch "$pkgdir"/usr/lib/python3.10/site-packages/boost/__init__.py
python -m compileall -o 0 -o 1 -o 2 "$pkgdir"/usr/lib/python3.10/site-packages/boost
cp fakeinstall/lib/boost-python3.10/mpi.so \
"$pkgdir"/usr/lib/python3.10/site-packages/boost/mpi.so
local site_packages=$(python -c 'import site; print(site.getsitepackages()[0])')
install -d "$pkgdir"$site_packages/boost
touch "$pkgdir"$site_packages/boost/__init__.py
python -m compileall -o 0 -o 1 -o 2 "$pkgdir"$site_packages/boost
cp fakeinstall/lib/boost-python*/mpi.so "$pkgdir"$site_packages/boost/mpi.so
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" $_srcname/LICENSE_1_0.txt
}

View file

@ -0,0 +1,11 @@
https://bugs.gentoo.org/887041
https://github.com/boostorg/phoenix/issues/111
--- a/boost/phoenix/stl.hpp
+++ b/boost/phoenix/stl.hpp
@@ -11,6 +11,5 @@
#include <boost/phoenix/stl/algorithm.hpp>
#include <boost/phoenix/stl/container.hpp>
-#include <boost/phoenix/stl/tuple.hpp>
#endif