removed extra/libtorrent-rasterbar

This commit is contained in:
Kevin Mihelich 2016-07-22 00:24:24 +00:00
parent 899c384d29
commit d98dbfeec1
2 changed files with 0 additions and 69 deletions

View file

@ -1,47 +0,0 @@
# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - remove -msse4.2 compile flag
pkgname=libtorrent-rasterbar
pkgver=1.1
pkgrel=2
epoch=1
pkgdesc="A C++ BitTorrent library that aims to be a good alternative to all the other implementations around"
url="http://www.rasterbar.com/products/libtorrent/"
arch=('i686' 'x86_64')
license=('BSD')
depends=('boost-libs' 'geoip' 'python2')
makedepends=('boost')
options=('!emptydirs')
source=(https://github.com/arvidn/libtorrent/archive/libtorrent-${pkgver//./_}/$pkgname-$pkgver.tar.gz)
sha1sums=('ac6e871d3b71a56e849ab1fc6369165a80acfd32')
prepare() {
# https://github.com/qbittorrent/qBittorrent/issues/5265#issuecomment-220007436
export CXXFLAGS="$CXXFLAGS -std=c++11"
# remove sse
sed -i 's/-msse4.2//' libtorrent-libtorrent-${pkgver//./_}/configure.ac
}
build() {
cd libtorrent-libtorrent-${pkgver//./_}
./autotool.sh
PYTHON=/usr/bin/python2 \
./configure \
--prefix=/usr \
--enable-python-binding \
--with-libgeoip=system \
--with-libiconv
make
}
package() {
cd libtorrent-libtorrent-${pkgver//./_}
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

View file

@ -1,22 +0,0 @@
From 5330ba5af717b983e456be9f576d66b78d9ca214 Mon Sep 17 00:00:00 2001
From: Andrew Resch <andrewresch@gmail.com>
Date: Sat, 2 Jan 2016 14:40:02 -0800
Subject: [PATCH] register_ptr_to_python for boost::shared_ptr<alert>
---
bindings/python/src/session.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/bindings/python/src/session.cpp b/bindings/python/src/session.cpp
index fe53e10..727a54a 100644
--- a/bindings/python/src/session.cpp
+++ b/bindings/python/src/session.cpp
@@ -799,7 +799,7 @@ void bind_session()
.def("settings", &get_feed_settings)
;
- register_ptr_to_python<std::auto_ptr<alert> >();
+ register_ptr_to_python<boost::shared_ptr<alert> >();
def("high_performance_seed", high_performance_seed);
def("min_memory_usage", min_memory_usage);