mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-odroid-c2 to 3.14.79-13
This commit is contained in:
parent
a0fbfc56f5
commit
d9c202a269
3 changed files with 102 additions and 7 deletions
|
@ -1,7 +1,7 @@
|
|||
From 7474934d7294f066a04d258fdcb364bbe3c92a85 Mon Sep 17 00:00:00 2001
|
||||
From 27611b7b580f13397bc38b19c224f47c38a9cea3 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 26 May 2016 06:29:07 -0600
|
||||
Subject: [PATCH] add extra errata 843419 build flags
|
||||
Subject: [PATCH 1/2] add extra errata 843419 build flags
|
||||
|
||||
---
|
||||
arch/arm64/Makefile | 1 +
|
||||
|
@ -20,5 +20,5 @@ index 18ea69f..59c5e48 100644
|
|||
|
||||
# Default value
|
||||
--
|
||||
2.7.2
|
||||
2.10.2
|
||||
|
||||
|
|
|
@ -0,0 +1,92 @@
|
|||
From 577171f3e8ada245e12261484b5154def1a0c3c9 Mon Sep 17 00:00:00 2001
|
||||
From: Philip Pettersson <philip.pettersson@gmail.com>
|
||||
Date: Wed, 30 Nov 2016 14:55:36 -0800
|
||||
Subject: [PATCH 2/2] packet: fix race condition in packet_set_ring
|
||||
|
||||
When packet_set_ring creates a ring buffer it will initialize a
|
||||
struct timer_list if the packet version is TPACKET_V3. This value
|
||||
can then be raced by a different thread calling setsockopt to
|
||||
set the version to TPACKET_V1 before packet_set_ring has finished.
|
||||
|
||||
This leads to a use-after-free on a function pointer in the
|
||||
struct timer_list when the socket is closed as the previously
|
||||
initialized timer will not be deleted.
|
||||
|
||||
The bug is fixed by taking lock_sock(sk) in packet_setsockopt when
|
||||
changing the packet version while also taking the lock at the start
|
||||
of packet_set_ring.
|
||||
|
||||
Fixes: f6fb8f100b80 ("af-packet: TPACKET_V3 flexible buffer implementation.")
|
||||
Signed-off-by: Philip Pettersson <philip.pettersson@gmail.com>
|
||||
Signed-off-by: Eric Dumazet <edumazet@google.com>
|
||||
Signed-off-by: David S. Miller <davem@davemloft.net>
|
||||
---
|
||||
net/packet/af_packet.c | 18 ++++++++++++------
|
||||
1 file changed, 12 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
|
||||
index c8078af..cafd6ec 100644
|
||||
--- a/net/packet/af_packet.c
|
||||
+++ b/net/packet/af_packet.c
|
||||
@@ -3291,19 +3291,25 @@ packet_setsockopt(struct socket *sock, int level, int optname, char __user *optv
|
||||
|
||||
if (optlen != sizeof(val))
|
||||
return -EINVAL;
|
||||
- if (po->rx_ring.pg_vec || po->tx_ring.pg_vec)
|
||||
- return -EBUSY;
|
||||
if (copy_from_user(&val, optval, sizeof(val)))
|
||||
return -EFAULT;
|
||||
switch (val) {
|
||||
case TPACKET_V1:
|
||||
case TPACKET_V2:
|
||||
case TPACKET_V3:
|
||||
- po->tp_version = val;
|
||||
- return 0;
|
||||
+ break;
|
||||
default:
|
||||
return -EINVAL;
|
||||
}
|
||||
+ lock_sock(sk);
|
||||
+ if (po->rx_ring.pg_vec || po->tx_ring.pg_vec) {
|
||||
+ ret = -EBUSY;
|
||||
+ } else {
|
||||
+ po->tp_version = val;
|
||||
+ ret = 0;
|
||||
+ }
|
||||
+ release_sock(sk);
|
||||
+ return ret;
|
||||
}
|
||||
case PACKET_RESERVE:
|
||||
{
|
||||
@@ -3766,6 +3772,7 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
/* Added to avoid minimal code churn */
|
||||
struct tpacket_req *req = &req_u->req;
|
||||
|
||||
+ lock_sock(sk);
|
||||
/* Opening a Tx-ring is NOT supported in TPACKET_V3 */
|
||||
if (!closing && tx_ring && (po->tp_version > TPACKET_V2)) {
|
||||
WARN(1, "Tx-ring is not supported.\n");
|
||||
@@ -3847,7 +3854,6 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
goto out;
|
||||
}
|
||||
|
||||
- lock_sock(sk);
|
||||
|
||||
/* Detach socket from network */
|
||||
spin_lock(&po->bind_lock);
|
||||
@@ -3896,11 +3902,11 @@ static int packet_set_ring(struct sock *sk, union tpacket_req_u *req_u,
|
||||
if (!tx_ring)
|
||||
prb_shutdown_retire_blk_timer(po, tx_ring, rb_queue);
|
||||
}
|
||||
- release_sock(sk);
|
||||
|
||||
if (pg_vec)
|
||||
free_pg_vec(pg_vec, order, req->tp_block_nr);
|
||||
out:
|
||||
+ release_sock(sk);
|
||||
return err;
|
||||
}
|
||||
|
||||
--
|
||||
2.10.2
|
||||
|
|
@ -4,12 +4,12 @@
|
|||
buildarch=8
|
||||
|
||||
pkgbase=linux-odroid-c2
|
||||
_commit=503a8af934ca5351a2ec3690ad30d33e0d2f0f00
|
||||
_commit=0778f0b332d5919b15d32dab15604d440fb7984e
|
||||
_srcname=linux-${_commit}
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="ODROID-C2"
|
||||
pkgver=3.14.79
|
||||
pkgrel=12
|
||||
pkgrel=13
|
||||
arch=('aarch64')
|
||||
url="https://github.com/hardkernel/linux/tree/odroidc2-3.14.y"
|
||||
license=('GPL2')
|
||||
|
@ -18,12 +18,14 @@ options=('!strip')
|
|||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
"git+https://github.com/mdrjr/c2_bootini.git"
|
||||
'0001-add-extra-errata-843419-build-flags.patch'
|
||||
'0002-packet-fix-race-condition-in-packet_set_ring.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'amlogic.service')
|
||||
md5sums=('5d14b06b27a8c04b0398984a42f50dee'
|
||||
md5sums=('6761af79e532603d047333922d14d5b2'
|
||||
'SKIP'
|
||||
'3c4a5342ac88d86b4bf99e7d0b8b2977'
|
||||
'7df92923b447253d37234fec3f3c48b1'
|
||||
'09ddfd3c3e1b76cd2ffb2e9a61d08bbe'
|
||||
'b1d8a7d34532252fa4434911b09c5527'
|
||||
'85fd3026c435ffa6d7c2d7f9767b4251'
|
||||
'b8956789318f49cec5b8bb0b41654a9b')
|
||||
|
@ -40,6 +42,7 @@ prepare() {
|
|||
sed -i '2iexit 0' scripts/depmod.sh
|
||||
|
||||
patch -p1 -i ../0001-add-extra-errata-843419-build-flags.patch
|
||||
patch -p1 -i ../0002-packet-fix-race-condition-in-packet_set_ring.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue