extra/libunwind to 1.1-3

This commit is contained in:
Kevin Mihelich 2015-09-30 23:43:52 +00:00
parent 1cace15b8b
commit d9e33ed29f
2 changed files with 16 additions and 1 deletions

View file

@ -0,0 +1,11 @@
--- a/include/dwarf_i.h
+++ b/include/dwarf_i.h
@@ -20,7 +20,7 @@
extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
/* REG is evaluated multiple times; it better be side-effects free! */
# define dwarf_to_unw_regnum(reg) \
- (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
+ (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
#endif
#ifdef UNW_LOCAL_ONLY

View file

@ -9,18 +9,22 @@
pkgname=libunwind
pkgver=1.1
pkgrel=2
pkgrel=3
pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
arch=('i686' 'x86_64')
url='http://www.nongnu.org/libunwind/'
license=('GPL')
depends=('glibc' 'xz')
source=("http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
'001-invalid-dwarf-opcodes-can-cause-references-beyond.patch'
'libunwind-aarch64.patch')
md5sums=('fb4ea2f6fbbe45bf032cd36e586883ce'
'73db2376e195a716f271ebce6bb7e5c0'
'5dd4c2661baa949389259a027d3b89e2')
prepare() {
patch -p1 -d $pkgname-$pkgver < 001-invalid-dwarf-opcodes-can-cause-references-beyond.patch
cd $pkgname-$pkgver
patch -p1 -i ../libunwind-aarch64.patch
autoreconf -fi